summaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-11-08 09:31:13 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-11-08 09:31:13 +0000
commit2bf9ca57b161dda80ac325ace89ff2fb273a9127 (patch)
tree25eee2b7e2ec8a9eedb1ce84f62e5e2d0ad71b11 /comms
parent6a379e2d3ac1c6ae44bfa961e42ea2f6877e4346 (diff)
downloadfreebsd-ports-2bf9ca57b161dda80ac325ace89ff2fb273a9127.zip
c*: Add missing USES={gnome,php,sdl,xorg}
Diffstat (limited to 'comms')
-rw-r--r--comms/freedv/Makefile2
-rw-r--r--comms/gnocky/Makefile2
-rw-r--r--comms/gnokii/Makefile4
-rw-r--r--comms/grig/Makefile2
-rw-r--r--comms/hamlib/Makefile3
-rw-r--r--comms/kb/Makefile2
-rw-r--r--comms/libimobiledevice/Makefile1
-rw-r--r--comms/libticables2/Makefile3
-rw-r--r--comms/libticalcs2/Makefile3
-rw-r--r--comms/lysdr/Makefile2
-rw-r--r--comms/pear-Horde_ActiveSync/Makefile2
-rw-r--r--comms/syncterm/Makefile1
-rw-r--r--comms/tilp2/Makefile5
-rw-r--r--comms/xdx/Makefile2
-rw-r--r--comms/xmorse/Makefile1
-rw-r--r--comms/xnec2c/Makefile2
-rw-r--r--comms/xnecview/Makefile2
17 files changed, 22 insertions, 17 deletions
diff --git a/comms/freedv/Makefile b/comms/freedv/Makefile
index a52912f5bdd9..64fc1a71c56f 100644
--- a/comms/freedv/Makefile
+++ b/comms/freedv/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libcodec2.so:audio/codec2 \
libspeex.so:audio/speex \
libspeexdsp.so:audio/speexdsp
-USES= cmake compiler:c++11-lib tar:xz
+USES= cmake compiler:c++11-lib gnome tar:xz
USE_WX= 3.0+
CMAKE_ARGS+= -DCODEC2_INCLUDE_DIRS=${LOCALBASE}/include/codec2 \
-DCODEC2_LIBRARY=${LOCALBASE}/lib/libcodec2.so \
diff --git a/comms/gnocky/Makefile b/comms/gnocky/Makefile
index db59f711bf12..fc8c3ae3cc3b 100644
--- a/comms/gnocky/Makefile
+++ b/comms/gnocky/Makefile
@@ -12,7 +12,7 @@ COMMENT= Graphical (GTK+2) frontend for gnokii
LIB_DEPENDS= libgnokii.so:comms/gnokii
-USES= pkgconfig tar:bzip2
+USES= gnome pkgconfig tar:bzip2
USE_GNOME= gtk20 libglade2
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index b16059a0f070..8a3b4a9a955c 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -18,8 +18,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= p5-XML-Parser>=0:textproc/p5-XML-Parser
GROUPS= ${PORTNAME}
-USES= gettext gmake iconv libtool localbase pathfix pkgconfig readline \
- tar:bzip2
+USES= gettext gmake gnome iconv libtool localbase pathfix pkgconfig \
+ readline tar:bzip2
USE_LDCONFIG= yes
USE_CSTD= gnu89
USE_GNOME= glib20 intltool
diff --git a/comms/grig/Makefile b/comms/grig/Makefile
index ac9d1e7476ed..fb75e4de3f79 100644
--- a/comms/grig/Makefile
+++ b/comms/grig/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libhamlib.so:comms/hamlib
USE_GNOME= gtk20 intltool
GNU_CONFIGURE= yes
-USES= gettext gmake pkgconfig
+USES= gettext gmake gnome pkgconfig
LIBS+= -lm
diff --git a/comms/hamlib/Makefile b/comms/hamlib/Makefile
index d050c56dce29..64ffbece6f2c 100644
--- a/comms/hamlib/Makefile
+++ b/comms/hamlib/Makefile
@@ -15,7 +15,8 @@ LICENSE= LGPL20
BUILD_DEPENDS= swig3.0:devel/swig30
LIB_DEPENDS= libltdl.so:devel/libltdl
-USES= autoreconf libtool:keepla pathfix perl5 pathfix pkgconfig python readline shebangfix tcl
+USES= autoreconf gnome libtool:keepla pathfix perl5 pkgconfig python \
+ readline shebangfix tcl
USE_PYTHON= py3kplist
USE_PERL5= build run
USE_GNOME= libxml2
diff --git a/comms/kb/Makefile b/comms/kb/Makefile
index e7588a34e52d..c05654fd8b96 100644
--- a/comms/kb/Makefile
+++ b/comms/kb/Makefile
@@ -10,7 +10,7 @@ DISTFILES= kb_src-${PORTVERSION}.tar.gz kb_inst-${PORTVERSION}.tar.gz
MAINTAINER= hamradio@FreeBSD.org
COMMENT= Amateur Radio contest logger
-USES= pkgconfig
+USES= gnome pkgconfig
USE_GNOME= libgnome gtk20 libbonobo
NO_WRKSUBDIR= yes
PKGMESSAGE= ${FILESDIR}/pkg_message
diff --git a/comms/libimobiledevice/Makefile b/comms/libimobiledevice/Makefile
index e94efb3d59f6..243af005ad88 100644
--- a/comms/libimobiledevice/Makefile
+++ b/comms/libimobiledevice/Makefile
@@ -26,6 +26,7 @@ INSTALL_TARGET= install-strip
LIB_DEPENDS= libplist.so:devel/libplist \
libusbmuxd.so:comms/libusbmuxd
+USES+= gnome
USE_GNOME= glib20
CONFIGURE_ARGS+=--without-cython
USE_CSTD= gnu89
diff --git a/comms/libticables2/Makefile b/comms/libticables2/Makefile
index 45966ca09026..77673147e984 100644
--- a/comms/libticables2/Makefile
+++ b/comms/libticables2/Makefile
@@ -13,7 +13,8 @@ LICENSE= GPLv2
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= autoreconf gettext-tools gmake libtool pkgconfig tar:bzip2
+USES= autoreconf gettext-tools gmake gnome libtool pkgconfig \
+ tar:bzip2
USE_GNOME= glib20
USE_LDCONFIG= yes
diff --git a/comms/libticalcs2/Makefile b/comms/libticalcs2/Makefile
index 951360ed25da..c65a0e08784a 100644
--- a/comms/libticalcs2/Makefile
+++ b/comms/libticalcs2/Makefile
@@ -16,7 +16,8 @@ LIB_DEPENDS= libticables2.so:comms/libticables2 \
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= autoreconf gettext-tools gmake libtool pkgconfig tar:bzip2
+USES= autoreconf gettext-tools gmake gnome libtool pkgconfig \
+ tar:bzip2
USE_GNOME= glib20
USE_LDCONFIG= yes
diff --git a/comms/lysdr/Makefile b/comms/lysdr/Makefile
index f8b8d5aea4be..18ab9c9c2be9 100644
--- a/comms/lysdr/Makefile
+++ b/comms/lysdr/Makefile
@@ -17,7 +17,7 @@ USE_GITHUB= yes
GH_ACCOUNT= gordonjcp
GH_TAGNAME= stable-0
-USES= pkgconfig
+USES= gnome pkgconfig
USE_GNOME= gtk20
PLIST_FILES= bin/lysdr
diff --git a/comms/pear-Horde_ActiveSync/Makefile b/comms/pear-Horde_ActiveSync/Makefile
index de7291132448..3aabbdf698dd 100644
--- a/comms/pear-Horde_ActiveSync/Makefile
+++ b/comms/pear-Horde_ActiveSync/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= comms www pear
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde ActiveSync Server Library
-USES= horde
+USES= horde php
USE_PHP= ctype
USE_HORDE_RUN= Horde_Compress \
Horde_Date \
diff --git a/comms/syncterm/Makefile b/comms/syncterm/Makefile
index 635d9ed847b6..23693a9cb9a1 100644
--- a/comms/syncterm/Makefile
+++ b/comms/syncterm/Makefile
@@ -35,6 +35,7 @@ X11_USES= xorg
X11_USE= xorg=x11
X11_MAKE_ARGS_OFF= NO_X=1
+SDL_USES= sdl
SDL_USE= SDL=sdl
SDL_MAKE_ARGS= USE_SDL=1
SDL_MAKE_ARGS_OFF= WITHOUT_SDL=1
diff --git a/comms/tilp2/Makefile b/comms/tilp2/Makefile
index bdba0f71ccde..590ea1f268a8 100644
--- a/comms/tilp2/Makefile
+++ b/comms/tilp2/Makefile
@@ -18,9 +18,8 @@ LIB_DEPENDS= libticables2.so:comms/libticables2 \
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= autoreconf compiler:c11 desktop-file-utils gettext \
- gmake groff localbase \
- libtool pkgconfig shared-mime-info tar:bzip2
+USES= autoreconf compiler:c11 desktop-file-utils gettext gmake gnome \
+ groff libtool localbase pkgconfig shared-mime-info tar:bzip2
USE_GNOME= gtk20 intltool
OPTIONS_DEFINE= NLS
diff --git a/comms/xdx/Makefile b/comms/xdx/Makefile
index 8c5e6f78d9f4..c6bf277a1e34 100644
--- a/comms/xdx/Makefile
+++ b/comms/xdx/Makefile
@@ -13,7 +13,7 @@ COMMENT= Amateur Radio DX cluster monitor
LICENSE= GPLv2
-USES= gmake pkgconfig
+USES= gmake gnome pkgconfig
USE_GNOME= gtk20
GNU_CONFIGURE= yes
diff --git a/comms/xmorse/Makefile b/comms/xmorse/Makefile
index 3f786b1d123e..4aa22f7567e1 100644
--- a/comms/xmorse/Makefile
+++ b/comms/xmorse/Makefile
@@ -15,6 +15,7 @@ COMMENT= Fully automatic Morse code teaching machine
LIB_DEPENDS= libfltk.so:x11-toolkits/fltk
+USES= sdl
USE_SDL= sdl
PLIST_FILES= bin/xmorse
diff --git a/comms/xnec2c/Makefile b/comms/xnec2c/Makefile
index d915875a314b..35fa0156b3ca 100644
--- a/comms/xnec2c/Makefile
+++ b/comms/xnec2c/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libccm.so:math/ccmath
GNU_CONFIGURE= yes
-USES= gettext gmake pkgconfig tar:bzip2
+USES= gettext gmake gnome pkgconfig tar:bzip2
USE_GNOME= gtk20 intltool
OPTIONS_DEFINE= DOCS
diff --git a/comms/xnecview/Makefile b/comms/xnecview/Makefile
index 17018580e912..7f6f5a821f55 100644
--- a/comms/xnecview/Makefile
+++ b/comms/xnecview/Makefile
@@ -12,7 +12,7 @@ COMMENT= A X viewer of nec2c data
LIB_DEPENDS= libpng.so:graphics/png
-USES= gmake pkgconfig tar:tgz
+USES= gmake gnome pkgconfig tar:tgz
USE_GNOME= gtk20
PLIST_FILES= bin/xnecview man/man1/xnecview.1.gz