summaryrefslogtreecommitdiff
path: root/comms/hidapi
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2021-10-07 17:52:00 +0200
committerEmanuel Haupt <ehaupt@FreeBSD.org>2021-10-07 17:52:05 +0200
commita25d8b2a68117b2fae70a8fc46df808b58e5dd60 (patch)
tree3b605eb8ddd6ebf9bf9d87c1041d04c5bbbeffc0 /comms/hidapi
parent557ce392a7e48b074bff2593d118d81fa9ce03eb (diff)
downloadfreebsd-ports-a25d8b2a68117b2fae70a8fc46df808b58e5dd60.zip
comms/hidapi: Switch from cmake back to autoreconf build
Switch from cmake back to to autoreconf build as this broke comms/py-hidapi. Once this has been investigated and fixed we can switch back to cmake. Notified by: pkg-fallout
Diffstat (limited to 'comms/hidapi')
-rw-r--r--comms/hidapi/Makefile6
-rw-r--r--comms/hidapi/pkg-plist19
2 files changed, 16 insertions, 9 deletions
diff --git a/comms/hidapi/Makefile b/comms/hidapi/Makefile
index aefe928eabd9..6f8e21853f59 100644
--- a/comms/hidapi/Makefile
+++ b/comms/hidapi/Makefile
@@ -1,6 +1,7 @@
PORTNAME= hidapi
DISTVERSIONPREFIX= ${PORTNAME}-
DISTVERSION= 0.11.0
+PORTREVISION= 1
CATEGORIES= comms
MAINTAINER= ehaupt@FreeBSD.org
@@ -9,11 +10,14 @@ COMMENT= Library to access USB HID-class devices
LICENSE= BSD3CLAUSE GPLv3
LICENSE_COMB= dual
-USES= cmake gettext-tools iconv:wchar_t libtool localbase pkgconfig
+USES= autoreconf gettext-tools iconv:wchar_t libtool localbase \
+ pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= libusb
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
OPTIONS_DEFINE= DOCS
diff --git a/comms/hidapi/pkg-plist b/comms/hidapi/pkg-plist
index e835d67b0d96..dd74e0e56603 100644
--- a/comms/hidapi/pkg-plist
+++ b/comms/hidapi/pkg-plist
@@ -1,10 +1,13 @@
include/hidapi/hidapi.h
include/hidapi/hidapi_libusb.h
-lib/cmake/hidapi/hidapi-config-version.cmake
-lib/cmake/hidapi/hidapi-config.cmake
-lib/cmake/hidapi/hidapi-%%CMAKE_BUILD_TYPE%%.cmake
-lib/cmake/hidapi/hidapi.cmake
-lib/libhidapi-libusb.so
-lib/libhidapi-libusb.so.0
-lib/libhidapi-libusb.so.0.11.0
-libdata/pkgconfig/hidapi-libusb.pc
+lib/libhidapi.a
+lib/libhidapi.so
+lib/libhidapi.so.0
+lib/libhidapi.so.0.0.0
+libdata/pkgconfig/hidapi.pc
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE-bsd.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE-gpl3.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE-orig.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.md