summaryrefslogtreecommitdiff
path: root/cad/netgen
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2020-06-03 05:05:30 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2020-06-03 05:05:30 +0000
commit481fc36263d5eb3ab63857368e5993a694995cc0 (patch)
tree31881cb329e1ac19ace2c5106fd1048511d742a1 /cad/netgen
parent01b3e1b93971414b9bfd7603a81fb185d6263f0d (diff)
downloadfreebsd-ports-481fc36263d5eb3ab63857368e5993a694995cc0.zip
- Switch off superbuild in cmake. I did this because cmake seemed to
place all of its output in some cache file, and then print it at the end. I'm also getting mysterious build errors from pkg-fallout, and I am hoping this change will fix this. - I found that this change caused pybind11 include files to be not part of plist. - Bump portrevision because of the change to plist.
Diffstat (limited to 'cad/netgen')
-rw-r--r--cad/netgen/Makefile3
-rw-r--r--cad/netgen/pkg-plist25
2 files changed, 3 insertions, 25 deletions
diff --git a/cad/netgen/Makefile b/cad/netgen/Makefile
index 0c310f1208d9..bb325569f27d 100644
--- a/cad/netgen/Makefile
+++ b/cad/netgen/Makefile
@@ -3,6 +3,7 @@
PORTNAME= netgen
PORTVERSION= 6.2.2004
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= cad
@@ -27,6 +28,8 @@ USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include -I${TK_INCLUDEDIR}/generic -I${TK_INCLUDEDIR}/unix
CXXFLAGS+= -I${LOCALBASE}/include -I${TK_INCLUDEDIR}/generic -I${TK_INCLUDEDIR}/unix
+CMAKE_ARGS+= -DUSE_SUPERBUILD=OFF
+
OPTIONS_DEFINE= JPEG MPEG CGNS
JPEG_DESC= Enable snapshots using jpeg
diff --git a/cad/netgen/pkg-plist b/cad/netgen/pkg-plist
index d24eb87568a8..39ea2776e554 100644
--- a/cad/netgen/pkg-plist
+++ b/cad/netgen/pkg-plist
@@ -153,31 +153,6 @@ include/nglib.h
include/occ/occgeom.hpp
include/occ/occmeshsurf.hpp
include/occ/vsocc.hpp
-include/pybind11/LICENSE
-include/pybind11/attr.h
-include/pybind11/buffer_info.h
-include/pybind11/cast.h
-include/pybind11/chrono.h
-include/pybind11/common.h
-include/pybind11/complex.h
-include/pybind11/detail/class.h
-include/pybind11/detail/common.h
-include/pybind11/detail/descr.h
-include/pybind11/detail/init.h
-include/pybind11/detail/internals.h
-include/pybind11/detail/typeid.h
-include/pybind11/eigen.h
-include/pybind11/embed.h
-include/pybind11/eval.h
-include/pybind11/functional.h
-include/pybind11/iostream.h
-include/pybind11/numpy.h
-include/pybind11/operators.h
-include/pybind11/options.h
-include/pybind11/pybind11.h
-include/pybind11/pytypes.h
-include/pybind11/stl.h
-include/pybind11/stl_bind.h
include/soldata.hpp
include/stlgeom/meshstlsurface.hpp
include/stlgeom/stlgeom.hpp