summaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2017-03-06 23:50:09 +0000
committerJason E. Hale <jhale@FreeBSD.org>2017-03-06 23:50:09 +0000
commitdb40a4a04e2d1395737ecf0c98d224a11765c2a5 (patch)
treed614706c9a3dae3f3b631c013ef8fe868b3e32a1 /audio
parentd30300fa92dbff9fc1e4d7c404ebf42ac52932ca (diff)
downloadfreebsd-ports-db40a4a04e2d1395737ecf0c98d224a11765c2a5.zip
Add missing Qt4 xml dependency to fix build failure when TEST option is ON
Register Qt4 corelib dependency Fix LICENSE and add LICENSE_FILE Approved by: portmgr (blanket) MFH: 2017Q1 (blanket)
Diffstat (limited to 'audio')
-rw-r--r--audio/libechonest/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/audio/libechonest/Makefile b/audio/libechonest/Makefile
index 3e616b6d79a8..4e4809fb81fe 100644
--- a/audio/libechonest/Makefile
+++ b/audio/libechonest/Makefile
@@ -3,13 +3,14 @@
PORTNAME= libechonest
PORTVERSION= 2.3.1
-#PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= audio
MAINTAINER= nivit@FreeBSD.org
COMMENT= Collection of C++/Qt classes designed to use the APIs of The Echo Nest
-LICENSE= GPLv2
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libqjson.so:devel/qjson
@@ -19,12 +20,12 @@ OPTIONS_DEFINE= TEST
PLIST_SUB= PORTVERSION=${PORTVERSION}
-TEST_CMAKE_OFF= -DECHONEST_BUILD_TESTS:BOOL=OFF
-TEST_USE= qt4=qtestlib_build
+TEST_CMAKE_BOOL=ECHONEST_BUILD_TESTS
+TEST_USE= qt4=qtestlib_build,xml_build
USES= cmake pkgconfig
USE_GITHUB= yes
USE_LDCONFIG= yes
-USE_QT4= qmake_build moc_build network rcc_build
+USE_QT4= corelib qmake_build moc_build network rcc_build
.include <bsd.port.mk>