summaryrefslogtreecommitdiff
path: root/audio/wmsmixer
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-04-24 10:22:14 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-04-24 10:22:14 +0000
commit6be9ba55408f7d867e343cf3ecc487e33dafea25 (patch)
treee773812fd747f4466966dd4ad9eb7bb063b742c9 /audio/wmsmixer
parent5956fa7b3c4f7eec70d23943d2ff341ac191f2c4 (diff)
downloadfreebsd-ports-6be9ba55408f7d867e343cf3ecc487e33dafea25.zip
- Resurrect, unbreak, and undeprecate the port
- Transfer maintainership to the new volunteer - Add some missing USE_XORG entries while here PR: 244041 Submitted by: blackend
Diffstat (limited to 'audio/wmsmixer')
-rw-r--r--audio/wmsmixer/Makefile32
-rw-r--r--audio/wmsmixer/distinfo2
-rw-r--r--audio/wmsmixer/files/patch-Imakefile8
-rw-r--r--audio/wmsmixer/files/patch-mixctl.h11
-rw-r--r--audio/wmsmixer/files/patch-wmsmixer.cc11
-rw-r--r--audio/wmsmixer/pkg-descr3
6 files changed, 67 insertions, 0 deletions
diff --git a/audio/wmsmixer/Makefile b/audio/wmsmixer/Makefile
new file mode 100644
index 000000000000..2791ce55fe4c
--- /dev/null
+++ b/audio/wmsmixer/Makefile
@@ -0,0 +1,32 @@
+# Created by: Konstantinos Konstantinidis <kkonstan@daemon.gr>
+# $FreeBSD$
+
+PORTNAME= wmsmixer
+PORTVERSION= 0.5.1
+PORTREVISION= 1
+CATEGORIES= audio windowmaker
+MASTER_SITES= https://www.dockapps.net/download/
+
+MAINTAINER= blackend@FreeBSD.org
+COMMENT= Audio mixer for the WindowMaker dock
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= alias imake xorg
+USE_XORG= x11 xext xpm
+MAKE_ARGS= CC="${CXX}" CFLAGS="${CXXFLAGS}"
+
+PLIST_FILES= bin/wmsmixer
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/wmsmixer ${STAGEDIR}${PREFIX}/bin
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/audio/wmsmixer/distinfo b/audio/wmsmixer/distinfo
new file mode 100644
index 000000000000..c1f6ac3d1532
--- /dev/null
+++ b/audio/wmsmixer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wmsmixer-0.5.1.tar.gz) = 168b0f608e4da9fab078845652a8bbffcfeabbcdce949faf597ba9a17c4bb556
+SIZE (wmsmixer-0.5.1.tar.gz) = 33085
diff --git a/audio/wmsmixer/files/patch-Imakefile b/audio/wmsmixer/files/patch-Imakefile
new file mode 100644
index 000000000000..5f9b582ac665
--- /dev/null
+++ b/audio/wmsmixer/files/patch-Imakefile
@@ -0,0 +1,8 @@
+--- Imakefile.orig 2003-04-12 22:08:16 UTC
++++ Imakefile
+@@ -12,4 +12,4 @@ LD = c++ -m32 -nostdlib
+ SRCS = wmsmixer.cc
+ OBJS = wmsmixer.o
+
+-ComplexProgramTarget(wmsmixer)
++ComplexProgramTargetNoMan(wmsmixer)
diff --git a/audio/wmsmixer/files/patch-mixctl.h b/audio/wmsmixer/files/patch-mixctl.h
new file mode 100644
index 000000000000..9a27cf4c6dce
--- /dev/null
+++ b/audio/wmsmixer/files/patch-mixctl.h
@@ -0,0 +1,11 @@
+--- mixctl.h.orig 2001-03-02 10:32:05 UTC
++++ mixctl.h
+@@ -19,7 +19,7 @@
+ #include <soundcard.h>
+ #endif
+ #ifdef __FreeBSD__
+-#include <machine/soundcard.h>
++#include <sys/soundcard.h>
+ #endif
+ #ifdef __linux__
+ #include <linux/soundcard.h>
diff --git a/audio/wmsmixer/files/patch-wmsmixer.cc b/audio/wmsmixer/files/patch-wmsmixer.cc
new file mode 100644
index 000000000000..dc388a529c67
--- /dev/null
+++ b/audio/wmsmixer/files/patch-wmsmixer.cc
@@ -0,0 +1,11 @@
+--- wmsmixer.cc.orig 2003-04-12 22:08:58 UTC
++++ wmsmixer.cc
+@@ -547,7 +547,7 @@ void readFile()
+ }
+ }
+
+-void checkVol(bool forced=true)
++void checkVol(bool forced)
+ {
+ mixctl->readVol(channel[curchannel], true);
+ int nl=mixctl->readLeft(channel[curchannel]);
diff --git a/audio/wmsmixer/pkg-descr b/audio/wmsmixer/pkg-descr
new file mode 100644
index 000000000000..7f6180f28850
--- /dev/null
+++ b/audio/wmsmixer/pkg-descr
@@ -0,0 +1,3 @@
+Improved version of wmmixer, an audio mixer for the WindowMaker dock.
+
+WWW: http://www.dockapps.org/file.php/id/63