summaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-01 21:55:23 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-01 21:55:23 +0000
commit1049351b5c76802d31dfb9e01571643fd73d8fd0 (patch)
treed2f707243b5945f82d1126063d33965fe8a5f35d /astro
parent0092bdd5e411a0b5c74bc1a53b80aadeed6131ee (diff)
downloadfreebsd-ports-1049351b5c76802d31dfb9e01571643fd73d8fd0.zip
The SWISS EPHEMERIS is the high precision ephemeris
developed by Astrodienst, largely based upon the DE406 ephemeris from NASA's JPL. Developers can license the Ephemeris library.Ephemeris users find 3200 years of read-made printable files of ephemerides, containing 19'200 print pages in PDF quality. The Swiss Ephemeris is available under a dual licensing model: GPL2 or Swiss Ephemeris Professional License. WWW: http://www.astro.com/swisseph/ PR: ports/128481 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/swe/Makefile36
-rw-r--r--astro/swe/distinfo3
-rw-r--r--astro/swe/pkg-descr12
-rw-r--r--astro/swe/pkg-plist19
5 files changed, 71 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 21092ea0b4d0..752f6a3f6437 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -72,6 +72,7 @@
SUBDIR += stars
SUBDIR += stellarium
SUBDIR += sunclock
+ SUBDIR += swe
SUBDIR += tclgeomap
SUBDIR += tkgeomap
SUBDIR += viking
diff --git a/astro/swe/Makefile b/astro/swe/Makefile
new file mode 100644
index 000000000000..29686d2ea8bd
--- /dev/null
+++ b/astro/swe/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: swe
+# Date created: 30 Oct 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= swe
+PORTVERSION= 1.75.00
+CATEGORIES= astro devel
+MASTER_SITES= ftp://ftp.astro.com/pub/swisseph/
+DISTNAME= ${PORTNAME}_unix_src_${PORTVERSION}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= The High Precision Ephemeris Developed By Astrodienst
+
+WRKSRC= ${WRKDIR}/src
+USE_GMAKE= yes
+ALL_TARGET=
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-pedantic||' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libswe.a ${LOCALBASE}/lib
+ ${MKDIR} ${LOCALBASE}/include/swe
+ ${INSTALL_DATA} ${WRKSRC}/*.h ${LOCALBASE}/include/swe
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/doc/* ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/astro/swe/distinfo b/astro/swe/distinfo
new file mode 100644
index 000000000000..e342626accfd
--- /dev/null
+++ b/astro/swe/distinfo
@@ -0,0 +1,3 @@
+MD5 (swe_unix_src_1.75.00.tar.gz) = 173ec325bc0238685308fc6b33d1cd25
+SHA256 (swe_unix_src_1.75.00.tar.gz) = 0cdc7257c64669da3fa142637eae20524fdb069009fe1ee4f55d893d6bc4d45c
+SIZE (swe_unix_src_1.75.00.tar.gz) = 1924363
diff --git a/astro/swe/pkg-descr b/astro/swe/pkg-descr
new file mode 100644
index 000000000000..73e77af100ed
--- /dev/null
+++ b/astro/swe/pkg-descr
@@ -0,0 +1,12 @@
+The SWISS EPHEMERIS is the high precision ephemeris
+developed by Astrodienst, largely based upon the DE406
+ephemeris from NASA's JPL.
+
+Developers can license the Ephemeris library.Ephemeris
+users find 3200 years of read-made printable files of
+ephemerides, containing 19'200 print pages in PDF quality.
+
+The Swiss Ephemeris is available under a dual licensing
+model: GPL2 or Swiss Ephemeris Professional License.
+
+WWW: http://www.astro.com/swisseph/
diff --git a/astro/swe/pkg-plist b/astro/swe/pkg-plist
new file mode 100644
index 000000000000..98830e3a5157
--- /dev/null
+++ b/astro/swe/pkg-plist
@@ -0,0 +1,19 @@
+lib/libswe.a
+include/swe/swedate.h
+include/swe/swedll.h
+include/swe/swehouse.h
+include/swe/swejpl.h
+include/swe/swenut2000a.h
+include/swe/sweodef.h
+include/swe/swepcalc.h
+include/swe/sweph.h
+include/swe/swephexp.h
+include/swe/swephlib.h
+%%PORTDOCS%%%%DOCSDIR%%/sweph.gif
+%%PORTDOCS%%%%DOCSDIR%%/swephin.gif
+%%PORTDOCS%%%%DOCSDIR%%/swephprg.htm
+%%PORTDOCS%%%%DOCSDIR%%/swephprg.pdf
+%%PORTDOCS%%%%DOCSDIR%%/swisseph.htm
+%%PORTDOCS%%%%DOCSDIR%%/swisseph.pdf
+@dirrm include/swe
+%%PORTDOCS%%@dirrm %%DOCSDIR%%