summaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-04-18 14:55:40 +0000
committerKai Knoblich <kai@FreeBSD.org>2019-04-18 14:55:40 +0000
commit68a5e7840e3224837230758ba48b39f59b5bb5fe (patch)
tree322f01832c45ea87fb8180e567410c810fa3522b /archivers
parent414932c313e220a3a2f1daad4d2dcd7cae0f5aa5 (diff)
downloadfreebsd-ports-68a5e7840e3224837230758ba48b39f59b5bb5fe.zip
New port: archivers/lizard
Lizard (formerly LZ5) is an efficient compressor with very fast decompression. It achieves compression ratio that is comparable to zip/zlib and zstd/brotli (at low and medium compression levels) at decompression speed of 1000 MB/s and faster. WWW: https://github.com/inikep/lizard PR: 237310 Submitted by: Hiroki Tagato <tagattie@yandex.com> Approved by: miwi (mentor) Differential Revision: https://reviews.freebsd.org/D19933
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/lizard/Makefile27
-rw-r--r--archivers/lizard/distinfo3
-rw-r--r--archivers/lizard/pkg-descr6
-rw-r--r--archivers/lizard/pkg-plist14
5 files changed, 51 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 57a2a270a767..c7985a390030 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -74,6 +74,7 @@
SUBDIR += libunrar
SUBDIR += libunrar5
SUBDIR += libzip
+ SUBDIR += lizard
SUBDIR += lrzip
SUBDIR += lua-lzlib
SUBDIR += lua51-zlib
diff --git a/archivers/lizard/Makefile b/archivers/lizard/Makefile
new file mode 100644
index 000000000000..8538851beab0
--- /dev/null
+++ b/archivers/lizard/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= lizard
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0
+CATEGORIES= archivers
+
+MAINTAINER= tagattie@yandex.com
+COMMENT= Efficient compressor with very fast decompression
+
+LICENSE= BSD2CLAUSE GPLv2
+LICENSE_COMB= multi
+LICENSE_FILE_BSD2CLAUSE= ${WRKSRC}/lib/LICENSE
+LICENSE_FILE_GPLv2= ${WRKSRC}/programs/COPYING
+
+USES= gmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= inikep
+
+USE_LDCONFIG= yes
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/lizard \
+ ${STAGEDIR}/${PREFIX}/lib/liblizard.so.1.0.0
+
+.include <bsd.port.mk>
diff --git a/archivers/lizard/distinfo b/archivers/lizard/distinfo
new file mode 100644
index 000000000000..f7bfadb5b040
--- /dev/null
+++ b/archivers/lizard/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1550625881
+SHA256 (inikep-lizard-v1.0_GH0.tar.gz) = 6f666ed699fc15dc7fdaabfaa55787b40ac251681b50c0d8df017c671a9457e6
+SIZE (inikep-lizard-v1.0_GH0.tar.gz) = 213732
diff --git a/archivers/lizard/pkg-descr b/archivers/lizard/pkg-descr
new file mode 100644
index 000000000000..ba4879068d6f
--- /dev/null
+++ b/archivers/lizard/pkg-descr
@@ -0,0 +1,6 @@
+Lizard (formerly LZ5) is an efficient compressor with very fast
+decompression. It achieves compression ratio that is comparable to
+zip/zlib and zstd/brotli (at low and medium compression levels) at
+decompression speed of 1000 MB/s and faster.
+
+WWW: https://github.com/inikep/lizard
diff --git a/archivers/lizard/pkg-plist b/archivers/lizard/pkg-plist
new file mode 100644
index 000000000000..df125082d16f
--- /dev/null
+++ b/archivers/lizard/pkg-plist
@@ -0,0 +1,14 @@
+bin/lizard
+bin/lizardcat
+bin/unlizard
+include/lizard_common.h
+include/lizard_compress.h
+include/lizard_frame.h
+lib/liblizard.a
+lib/liblizard.so
+lib/liblizard.so.1
+lib/liblizard.so.1.0.0
+libdata/pkgconfig/liblizard.pc
+man/man1/lizard.1.gz
+man/man1/lizardcat.1.gz
+man/man1/unlizard.1.gz