summaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /archivers
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadfreebsd-ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'archivers')
-rw-r--r--archivers/dact/Makefile2
-rw-r--r--archivers/file-roller/Makefile2
-rw-r--r--archivers/libarchive/Makefile2
-rw-r--r--archivers/liblzxcomp/Makefile2
-rw-r--r--archivers/libmspack/Makefile2
-rw-r--r--archivers/linux-f10-ucl/Makefile2
-rw-r--r--archivers/linux-f8-ucl/Makefile2
-rw-r--r--archivers/linux-ucl/Makefile2
-rw-r--r--archivers/lzo/Makefile2
-rw-r--r--archivers/lzo2/Makefile2
-rw-r--r--archivers/unshield/Makefile2
-rw-r--r--archivers/xarchive/Makefile6
12 files changed, 13 insertions, 15 deletions
diff --git a/archivers/dact/Makefile b/archivers/dact/Makefile
index 05456268dc63..57e4cfd471b3 100644
--- a/archivers/dact/Makefile
+++ b/archivers/dact/Makefile
@@ -27,7 +27,7 @@ MAKE_ARGS= CONF=${EXAMPLESDIR}/dact.conf \
TOBUILD="dact libdact.so dact.conf"
MAN1= dact.1
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-patch:
@${REINPLACE_CMD} -e "s|prefix = @prefix@|prefix = ${PREFIX}|" \
diff --git a/archivers/file-roller/Makefile b/archivers/file-roller/Makefile
index 68bafd523dd9..11195fff1dc9 100644
--- a/archivers/file-roller/Makefile
+++ b/archivers/file-roller/Makefile
@@ -8,6 +8,7 @@
PORTNAME= file-roller
PORTVERSION= 2.22.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= archivers gnome
MASTER_SITES= GNOME
@@ -26,7 +27,6 @@ USE_BZIP2= yes
USE_GETTEXT= yes
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
-USE_XLIB= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix intlhack gnomehack desktopfileutils nautilus2 \
gnomedocutils
diff --git a/archivers/libarchive/Makefile b/archivers/libarchive/Makefile
index b7144136d57f..84551e46404d 100644
--- a/archivers/libarchive/Makefile
+++ b/archivers/libarchive/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= glewis@FreeBSD.org
COMMENT= Library to create and read several streaming archive formats
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
OPTIONS= BSDCPIO "Enable bsdcpio" on
diff --git a/archivers/liblzxcomp/Makefile b/archivers/liblzxcomp/Makefile
index 4481edf3ffa8..3669cf5b7097 100644
--- a/archivers/liblzxcomp/Makefile
+++ b/archivers/liblzxcomp/Makefile
@@ -16,7 +16,7 @@ COMMENT= LZX compression library
MAKE_ENV= PREFIX=${PREFIX}
-INSTALLS_SHLIB= YES
+USE_LDCONFIG= YES
SHLIB_MAJOR= 1
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
diff --git a/archivers/libmspack/Makefile b/archivers/libmspack/Makefile
index f709c79c56cd..eaee5c03a102 100644
--- a/archivers/libmspack/Makefile
+++ b/archivers/libmspack/Makefile
@@ -18,7 +18,7 @@ COMMENT= A library for Microsoft compression formats
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-patch:
@${REINPLACE_CMD} -e 's,\*this,*self,'\
diff --git a/archivers/linux-f10-ucl/Makefile b/archivers/linux-f10-ucl/Makefile
index 2143d1b9eb3e..b672de7a3ebe 100644
--- a/archivers/linux-f10-ucl/Makefile
+++ b/archivers/linux-f10-ucl/Makefile
@@ -17,7 +17,7 @@ COMMENT= RPM of UCL, a lossless data compression library
USE_LINUX_RPM= yes
RPMVERSION= 3
LINUX_DIST_VER= 4
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MASTER_SITE_SRC_SUBDIR= ../extras/${LINUX_DIST_VER}/SRPMS
DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
diff --git a/archivers/linux-f8-ucl/Makefile b/archivers/linux-f8-ucl/Makefile
index 2143d1b9eb3e..b672de7a3ebe 100644
--- a/archivers/linux-f8-ucl/Makefile
+++ b/archivers/linux-f8-ucl/Makefile
@@ -17,7 +17,7 @@ COMMENT= RPM of UCL, a lossless data compression library
USE_LINUX_RPM= yes
RPMVERSION= 3
LINUX_DIST_VER= 4
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MASTER_SITE_SRC_SUBDIR= ../extras/${LINUX_DIST_VER}/SRPMS
DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
diff --git a/archivers/linux-ucl/Makefile b/archivers/linux-ucl/Makefile
index 2143d1b9eb3e..b672de7a3ebe 100644
--- a/archivers/linux-ucl/Makefile
+++ b/archivers/linux-ucl/Makefile
@@ -17,7 +17,7 @@ COMMENT= RPM of UCL, a lossless data compression library
USE_LINUX_RPM= yes
RPMVERSION= 3
LINUX_DIST_VER= 4
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MASTER_SITE_SRC_SUBDIR= ../extras/${LINUX_DIST_VER}/SRPMS
DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
diff --git a/archivers/lzo/Makefile b/archivers/lzo/Makefile
index a50e6a0f2eef..62a939d0262e 100644
--- a/archivers/lzo/Makefile
+++ b/archivers/lzo/Makefile
@@ -20,7 +20,7 @@ USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-shared
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-install:
.if !defined(NOPORTDOCS)
diff --git a/archivers/lzo2/Makefile b/archivers/lzo2/Makefile
index f4f1a2a7ad12..6f78d4fc22f2 100644
--- a/archivers/lzo2/Makefile
+++ b/archivers/lzo2/Makefile
@@ -22,7 +22,7 @@ USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-shared
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-install:
.if !defined(NOPORTDOCS)
diff --git a/archivers/unshield/Makefile b/archivers/unshield/Makefile
index 882d0e9d53d0..1d2cb9a10bea 100644
--- a/archivers/unshield/Makefile
+++ b/archivers/unshield/Makefile
@@ -17,7 +17,7 @@ COMMENT= Extract data from InstallShield CAB files
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ARGS= --program-prefix=""
.include <bsd.port.mk>
diff --git a/archivers/xarchive/Makefile b/archivers/xarchive/Makefile
index b9011b31b653..7c97a3123ae8 100644
--- a/archivers/xarchive/Makefile
+++ b/archivers/xarchive/Makefile
@@ -7,10 +7,9 @@
PORTNAME= xarchive
PORTVERSION= 0.2.8.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= archivers
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
DISTNAME= ${PORTNAME}-0.2.8-6
MAINTAINER= mark@mkproductions.org
@@ -22,7 +21,6 @@ MAN1= xarchive.1
GNU_CONFIGURE= yes
USE_GNOME= gtk20
-USE_X_PREFIX= yes
OPTIONS= 7ZIP "Support for 7zip archives" off \
ARJ "Support for ARJ archives" off \