summaryrefslogtreecommitdiff
path: root/archivers/unadf
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-08-25 11:45:43 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-08-25 11:45:43 +0000
commiteefc3f4c5f522cc50ee3dbaa35e271a73a804c0e (patch)
treea78072bf9a8d56273c5802bbf6b93e9ee2df4255 /archivers/unadf
parentae6aeefdf51faacae1956b2b951059604cc14fff (diff)
downloadfreebsd-ports-eefc3f4c5f522cc50ee3dbaa35e271a73a804c0e.zip
- Respect CC
- Respect CFLAGS - Install docs if NOPORTDOCS is not set - Bump PORTREVISION PR: 101810 Submitted by: gabor Approved by: maintainer timeout
Diffstat (limited to 'archivers/unadf')
-rw-r--r--archivers/unadf/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/archivers/unadf/Makefile b/archivers/unadf/Makefile
index 7ca05afb5643..24cf2efd7d4e 100644
--- a/archivers/unadf/Makefile
+++ b/archivers/unadf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= unadf
PORTVERSION= 0.7.9b
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= archivers
MASTER_SITES= http://perso.club-internet.fr/lclevy/adflib/
DISTNAME= adflib
@@ -17,12 +17,26 @@ COMMENT= Extracts files from .adf-files used by Amiga emulators
NO_WRKSUBDIR= yes
PLIST_FILES= bin/unadf
+PORTDOCS= API.txt api_device.html api_dir.html api_env.html api_file.html \
+ api_index.html api_native.html api_salv.html api_volume.html
USE_ZIP= yes
-pre-build:
+post-patch:
@${REINPLACE_CMD} -e "s@tests lib demo@lib demo@g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} 's|CFLAGS=-I$$(LIBDIR) -O2 -Wall -Wno-uninitialized -pedantic|CFLAGS+= -I$$(LIBDIR)|' \
+ ${WRKSRC}/Demo/Makefile
+ @${REINPLACE_CMD} -e 's|CFLAGS=|CFLAGS+=|' \
+ -e 's|-Wall -O2 -pedantic||' \
+ -e 's|CC=|CC?=|' \
+ ${WRKSRC}/Lib/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/Demo/unadf ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/Docs/${i} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>