summaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2020-12-02 00:09:14 +0000
committerMatthias Andree <mandree@FreeBSD.org>2020-12-02 00:09:14 +0000
commite03a2e6775a3c969a0b85aa099d37005019a6a36 (patch)
tree9bd56460eaa7dbe7aecb0e0d19ba50e7f7c0b0a6 /Mk
parent273b0bb5c1f51ad32baf8a2006f062515b91e8a0 (diff)
downloadfreebsd-ports-e03a2e6775a3c969a0b85aa099d37005019a6a36.zip
New port: databases/db18 Oracle Berkeley DB, Release 18.1
Oracle Berkeley DB is a family of open source embeddable databases that allows developers to incorporate within their applications a fast, scalable, transactional database engine with industrial grade reliability and availability. As a result, customers and end-users will experience an application that simply works, reliably manages data, can scale under extreme load, but requires no ongoing database administration. As a developer, you can focus on your application and be confident that Oracle Berkeley DB will manage your persistence needs. This port is derived from databases/db6 (by svn copy + edits). PR: 248415 Submitted by: Yasuhiro KIMURA
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/bdb.mk22
-rw-r--r--Mk/bsd.default-versions.mk2
2 files changed, 17 insertions, 7 deletions
diff --git a/Mk/Uses/bdb.mk b/Mk/Uses/bdb.mk
index f11b82cc7ad2..4e5394652e33 100644
--- a/Mk/Uses/bdb.mk
+++ b/Mk/Uses/bdb.mk
@@ -59,19 +59,25 @@ BDB_UNIQUENAME?= ${PKGNAMEPREFIX}${PORTNAME}
_BDB_DEFAULT_save:=${BDB_DEFAULT}
-_DB_PORTS= 5 6
+_DB_PORTS= 5 6 18
_DB_DEFAULTS= 5 # does not include 6 due to different licensing
# but user can re-add it through WITH_BDB6_PERMITTED
+#
+# Since 2020-12-02, this name is not fitting too much but
+# retained for now for compatibility. The name of this variable
+# is subject to change especially once db6 were removed.
. if defined(WITH_BDB6_PERMITTED)
-_DB_DEFAULTS+= 6
+_DB_DEFAULTS+= 6 18
. endif
# Dependency lines for different db versions
db5_DEPENDS= libdb-5.3.so:databases/db5
db6_DEPENDS= libdb-6.2.so:databases/db6
+db18_DEPENDS= libdb-18.1.so:databases/db18
# Detect db versions by finding some files
db5_FIND= ${LOCALBASE}/include/db5/db.h
db6_FIND= ${LOCALBASE}/include/db6/db.h
+db18_FIND= ${LOCALBASE}/include/db18/db.h
# Override the global BDB_DEFAULT with the
# port specific <BDB_UNIQUENAME>_WITH_BDB_VER
@@ -109,9 +115,9 @@ _INST_BDB_VER+=${bdb}
# 2. parse supported versions:
# 2a. build list from _bdb_ARGS
_SUPP_BDB_VER=
-__bdb_ARGS:=${_bdb_ARGS:C,\+$,,:C/(.)(.)$/\1.\2/}
+__bdb_ARGS:=${_bdb_ARGS:C,\+$,,}
.if !empty(_bdb_ARGS:M*+)
-. for bdb in ${_DB_PORTS:C/(.)(.)$/\1.\2/}
+. for bdb in ${_DB_PORTS}
. if ${__bdb_ARGS} <= ${bdb}
_SUPP_BDB_VER+=${bdb:C/\.//}
. endif
@@ -121,9 +127,9 @@ _SUPP_BDB_VER=${_bdb_ARGS}
.endif
# 2b. expand INVALID_BDB_VER if given with "+":
.if !empty(INVALID_BDB_VER:M*+)
-_INV_BDB:=${INVALID_BDB_VER:C,\+$,,:C/(.)(.)$/\1.\2/}
+_INV_BDB:=${INVALID_BDB_VER:C,\+$,,}
_INV_BDB_VER:=
-. for bdb in ${_DB_PORTS:C/(.)(.)$/\1.\2/}
+. for bdb in ${_DB_PORTS}
. if ${_INV_BDB} <= ${bdb}
_INV_BDB_VER+=${bdb:C/\.//}
. endif
@@ -183,6 +189,10 @@ BDB_LIB_DIR= ${LOCALBASE}/lib/db5
BDB_LIB_NAME= db-6.2
BDB_LIB_CXX_NAME= db_cxx-6.2
BDB_LIB_DIR= ${LOCALBASE}/lib/db6
+. elif ${_BDB_VER} == 18
+BDB_LIB_NAME= db-18.1
+BDB_LIB_CXX_NAME= db_cxx-18.1
+BDB_LIB_DIR= ${LOCALBASE}/lib/db18
. endif
BDB_LIB_NAME?= db${_BDB_VER}
BDB_LIB_CXX_NAME?= db${_BDB_VER}_cxx
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index 02cac8363bff..1ae3a4431ca2 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -35,7 +35,7 @@ ${_l:tu}_DEFAULT= ${lang:C/.*=//g}
# Possible values: 2.4
APACHE_DEFAULT?= 2.4
-# Possible values: 48, 5, 6
+# Possible values: 5, 6, 18
BDB_DEFAULT?= 5
# Possible values: 2, 3
COROSYNC_DEFAULT?= 2