summaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-06-11 15:59:05 -0500
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-06-11 16:02:49 -0500
commit665b149d2692ff6926a092568304091995e07d39 (patch)
tree43733e6164a8fac2635af7542a26e80c2524c28c /Mk
parent86d3a1352320828ae4d68b3a49ea1916d4ee3389 (diff)
downloadfreebsd-ports-665b149d2692ff6926a092568304091995e07d39.zip
*/*php82*: Welcome php 8.2.0 Alpha 1
Please DO NOT use this version in production, it is an early test version. port-committers@ please DO NOT mark your ports IGNORE_WITH_PHP=82. A build is running to check all php ports with php82 and will be committed in batch tomorrow. Sponsored by: Bounce Experts
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/php.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/Mk/Uses/php.mk b/Mk/Uses/php.mk
index 5a3de6c0b62f..a17c82ac344d 100644
--- a/Mk/Uses/php.mk
+++ b/Mk/Uses/php.mk
@@ -110,7 +110,7 @@ DIST_SUBDIR= PECL
PHPBASE?= ${LOCALBASE}
-_ALL_PHP_VERSIONS= 74 80 81
+_ALL_PHP_VERSIONS= 74 80 81 82
# Make the already installed PHP the default one.
. if exists(${PHPBASE}/etc/php.conf)
@@ -183,7 +183,10 @@ PHP_VER= ${FLAVOR:S/^php//}
(${FLAVOR:Mphp[0-9][0-9]} && ${FLAVOR} != ${FLAVORS:[1]})
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
-. if ${PHP_VER} == 81
+. if ${PHP_VER} == 82
+PHP_EXT_DIR= 20210903
+PHP_EXT_INC= hash json openssl pcre spl
+. elif ${PHP_VER} == 81
PHP_EXT_DIR= 20210902
PHP_EXT_INC= hash json openssl pcre spl
. elif ${PHP_VER} == 80
@@ -391,6 +394,7 @@ _USE_PHP_ALL= bcmath bitset bz2 calendar ctype curl dba dom \
_USE_PHP_VER74= ${_USE_PHP_ALL} pdf
_USE_PHP_VER80= ${_USE_PHP_ALL}
_USE_PHP_VER81= ${_USE_PHP_ALL}
+_USE_PHP_VER82= ${_USE_PHP_ALL}
bcmath_DEPENDS= math/php${PHP_VER}-bcmath
bitset_DEPENDS= math/pecl-bitset@${PHP_FLAVOR}