summaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2022-08-25 19:41:53 +0200
committerTobias C. Berner <tcberner@FreeBSD.org>2022-08-26 08:30:22 +0200
commit630a8a1ea538f72e0a0e00e645758982cdba095a (patch)
tree0e26ab49e5a4688668fe8e495be28d7370232db9 /Mk
parent827afb1759885006e4b8cf0fff60f37d8a366ff8 (diff)
downloadfreebsd-ports-630a8a1ea538f72e0a0e00e645758982cdba095a.zip
devel/qca: add flavors for Qt 5 and Qt 6
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/qca.mk9
1 files changed, 7 insertions, 2 deletions
diff --git a/Mk/Uses/qca.mk b/Mk/Uses/qca.mk
index 72f46105946c..29ef2215f72f 100644
--- a/Mk/Uses/qca.mk
+++ b/Mk/Uses/qca.mk
@@ -13,11 +13,16 @@ _INCLUDE_QCA_MK= yes
IGNORE+= USES=qca takes no arguments
. endif
-_QCA_LIB= libqca-qt5.so
+. if empty(USES:Mqt*)
+IGNORE+= Qt version not specified
+. endif
+
+_QCA_LIB= libqca-qt${_QT_VER}.so
_QCA_DEFAULT_PORT= devel/qca
_QCA_CHOSEN_PORT= DEFAULT
+_QCA_FLAVOR= qt${_QT_VER}
-LIB_DEPENDS+= ${_QCA_LIB}:${_QCA_${_QCA_CHOSEN_PORT}_PORT}
+LIB_DEPENDS+= ${_QCA_LIB}:${_QCA_${_QCA_CHOSEN_PORT}_PORT}@${_QCA_FLAVOR}
.endif