summaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2023-12-03 22:44:37 +0100
committerTobias C. Berner <tcberner@FreeBSD.org>2023-12-03 23:17:33 +0100
commitb2a438e1ba2f1f806519a925c2f241d2f4675c65 (patch)
tree5f69bdec864a286a791a1f694f3aabd4a6b97b70 /Mk
parent067a18449b4160d67a5e903ace93cfcf3086694a (diff)
downloadfreebsd-ports-b2a438e1ba2f1f806519a925c2f241d2f4675c65.zip
framework: move 'phonon4' from qt.mk to kde.mk as 'phonon'
To depend on phonon, you now need USES= kde:<ver> USE_KDE=phonon if you want to depend on the backend, also add USE_KDE= phonon-backend
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/kde.mk14
-rw-r--r--Mk/Uses/qt.mk5
2 files changed, 13 insertions, 6 deletions
diff --git a/Mk/Uses/kde.mk b/Mk/Uses/kde.mk
index 33db1bf5d6c7..609c37c1638b 100644
--- a/Mk/Uses/kde.mk
+++ b/Mk/Uses/kde.mk
@@ -342,10 +342,13 @@ _USE_KDEPIM5_ALL= akonadicontacts akonadiimportwizard akonadimime akonadinotes \
kalarm kmail-account-wizard kmail knotes kontact \
korganizer pim-data-exporter ktextaddons
+_USE_PHONON_ALL= phonon phonon-backend
+
_USE_KDE5_ALL= ${_USE_FRAMEWORKS_ALL} \
${_USE_PLASMA_ALL} \
${_USE_KDEPIM5_ALL} \
- ${_USE_KDE_BOTH}
+ ${_USE_KDE_BOTH} \
+ ${_USE_PHONON_ALL}
# TODO: fix
_USE_KDE6_ALL= ecm colorscheme \
svg \
@@ -353,7 +356,8 @@ _USE_KDE6_ALL= ecm colorscheme \
mediaplayer \
${_USE_FRAMEWORKS_ALL} \
${_USE_PLASMA_ALL} \
- plasma5support activities activities-stats kpipewire wayland globalacceld libplasma
+ plasma5support activities activities-stats kpipewire wayland globalacceld libplasma \
+ ${_USE_PHONON_ALL}
# ====================== frameworks components =================================
kde-activities_PORT5= x11/kf${_KDE_VERSION}-kactivities
@@ -987,6 +991,12 @@ kde-kosm_LIB= libKOSM.so
kde-okular5_PORT= graphics/okular
kde-okular5_LIB= libOkular5Core.so
+
+kde-phonon_PORT= multimedia/phonon@${_QT_RELNAME}
+kde-phonon_LIB= libphonon4${_QT_RELNAME}.so
+
+kde-phonon-backend_PORT= multimedia/phonon-vlc@${_QT_RELNAME}
+kde-phonon-backend_PATH= ${QT_PLUGINDIR}/phonon4${_QT_RELNAME}_backend/phonon_vlc_${_QT_RELNAME}.so
# ====================== end of multiversion components ========================
# ====================== select the proper multiversion component ==============
diff --git a/Mk/Uses/qt.mk b/Mk/Uses/qt.mk
index 276dfa1035fc..330cf6deaea8 100644
--- a/Mk/Uses/qt.mk
+++ b/Mk/Uses/qt.mk
@@ -143,7 +143,7 @@ _QT_MK_POST_INCLUDED= qt.mk
# The Qt components supported by qt.mk: list of shared, and version specific ones
_USE_QT_COMMON= 3d charts connectivity datavis3d declarative doc examples imageformats location \
- multimedia networkauth phonon4 quick3d quicktimeline remoteobjects scxml \
+ multimedia networkauth quick3d quicktimeline remoteobjects scxml \
sensors serialbus serialport speech svg virtualkeyboard wayland \
webchannel webengine websockets webview
@@ -280,9 +280,6 @@ qt-pdf_LIB= libQt${_QT_LIBVER}Pdf.so
qt-pixeltool_PORT= graphics/${_QT_RELNAME}-pixeltool
qt-pixeltool_PATH= ${LOCALBASE}/${QT_BINDIR_REL}/pixeltool
-qt-phonon4_PORT= multimedia/phonon@${_QT_RELNAME}
-qt-phonon4_LIB= libphonon4${_QT_RELNAME}.so
-
qt-positioning_PORT= devel/${_QT_RELNAME}-positioning
qt-positioning_LIB= libQt${_QT_LIBVER}Positioning.so