summaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2015-10-12 23:22:20 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2015-10-12 23:22:20 +0000
commit45535ed69c78738a7e4972c7b4282825a9781412 (patch)
tree4a12cbc70ebef8c12425ac8bf1b68d863252ee72 /Mk
parent16162f77dd8aca489e2991597e4acf7d0879a95f (diff)
downloadfreebsd-ports-45535ed69c78738a7e4972c7b4282825a9781412.zip
Don't check for minimal Pkg version for package building.
Package building always builds Pkg first. If someone downgrades their pkg locally this change will hurt them, but then they are already running an unsupported configuration. With hat: portmgr
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 0c9ca4d75b9a..152e2dbae38c 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1210,7 +1210,7 @@ _OSVERSION_MAJOR= ${OSVERSION:C/([0-9]?[0-9])([0-9][0-9])[0-9]{3}/\1/}
# Only define tools here (for transition period with between pkg tools)
.include "${PORTSDIR}/Mk/bsd.commands.mk"
-.if !defined(_PKG_CHECKED) && exists(${PKG_BIN})
+.if !defined(_PKG_CHECKED) && !defined(PACKAGE_BUILDING) && exists(${PKG_BIN})
.if !defined(_PKG_VERSION)
_PKG_VERSION!= ${PKG_BIN} -v
.endif