summaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2024-01-02 11:55:31 +0100
committerBaptiste Daroussin <bapt@FreeBSD.org>2024-01-02 11:55:31 +0100
commit0823be40fa82c02a1b2395a7529527eca5b25e66 (patch)
treeec483bb0a561eccd0f3524e006ee6130c1d2d1f0 /Mk
parent19fe9683f8da9c2b6d7c174bbcbd2546c7570ed3 (diff)
downloadfreebsd-ports-0823be40fa82c02a1b2395a7529527eca5b25e66.zip
subpackages: fix flavors-package-names
Before subpackages was introduced, flavors-package-names was printing the full <name>-<version>, a regression was introduced with subpackages which made it print <name>. One of the side effect of this is pkg version -v -P was determining all the ports as orphaned. Reported by: stephen@
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index bd09f7c999c0..4b03eb491322 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -4848,20 +4848,20 @@ stage-qa:
pretty-flavors-package-names: .PHONY
. if empty(FLAVORS)
- @${ECHO_CMD} "no flavor: ${_PKGS}"
+ @${ECHO_CMD} "no flavor: ${PKGNAMES}"
. else
. for f in ${FLAVORS}
@${ECHO_CMD} -n "${f}: "
- @cd ${.CURDIR} && ${SETENV} -i FLAVOR=${f} ${MAKE} -B -V _PKGS
+ @cd ${.CURDIR} && ${SETENV} -i FLAVOR=${f} ${MAKE} -B -V PKGNAMES
. endfor
. endif
flavors-package-names: .PHONY
. if empty(FLAVORS)
- @${ECHO_CMD} "${_PKGS}"
+ @${ECHO_CMD} "${PKGNAMES}"
. else
. for f in ${FLAVORS}
- @cd ${.CURDIR} && ${SETENV} -i FLAVOR=${f} ${MAKE} -B -V _PKGS | ${XARGS} -n 1
+ @cd ${.CURDIR} && ${SETENV} -i FLAVOR=${f} ${MAKE} -B -V PKGNAMES | ${XARGS} -n 1
. endfor
. endif