summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-11-27 08:42:19 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-11-27 08:42:19 +0000
commite9f079c5d4f03c463e43d4a3e2a4d8b1ebac1d54 (patch)
treef99579a7855dc0495a1c646449496c7601cb182d
parent5d57d97db9a37dcb229b79d5e3ea46fd617b3cb4 (diff)
downloadfreebsd-ports-e9f079c5d4f03c463e43d4a3e2a4d8b1ebac1d54.zip
- Unbreak build on 9.0
PR: 162901 Submitted by: maintainer Feature safe: yes
-rw-r--r--net/openafs/Makefile2
-rw-r--r--net/openafs/files/patch-src__afs__afs_server.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/net/openafs/Makefile b/net/openafs/Makefile
index 906b5e8e64ff..2099ff94828f 100644
--- a/net/openafs/Makefile
+++ b/net/openafs/Makefile
@@ -8,7 +8,7 @@
PORTNAME= openafs
DISTVERSION= ${AFS_DISTVERSION}.${DBVERSION:S/-//g}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net kld
MASTER_SITES= http://dl.central.org/dl/openafs/${AFS_DISTVERSION}/:openafs \
http://dl.openafs.org/dl/openafs/${AFS_DISTVERSION}/:openafs \
diff --git a/net/openafs/files/patch-src__afs__afs_server.c b/net/openafs/files/patch-src__afs__afs_server.c
new file mode 100644
index 000000000000..ec52e26b24d7
--- /dev/null
+++ b/net/openafs/files/patch-src__afs__afs_server.c
@@ -0,0 +1,13 @@
+diff --git a/src/afs/afs_server.c b/src/afs/afs_server.c
+index ad28100..cafd355 100644
+--- a/src/afs/afs_server.c
++++ b/src/afs/afs_server.c
+@@ -1032,7 +1032,7 @@ afsi_SetServerIPRank(struct srvAddr *sa, struct in_ifaddr *ifa)
+ struct sockaddr_in *sin;
+ int t;
+
+- if ((ntohl(sa->sa_ip) & ifa->ia_netmask) == ifa->ia_net) {
++ if (1) {
+ if ((ntohl(sa->sa_ip) & ifa->ia_subnetmask) == ifa->ia_subnet) {
+ sin = IA_SIN(ifa);
+ if (SA2ULONG(sin) == ntohl(sa->sa_ip)) { /* ie, ME!!! */