summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg A. Mamontov <oleg@mamontov.net>2023-08-30 23:59:50 +0300
committerRobert Clausecker <fuz@FreeBSD.org>2023-09-10 12:13:00 -0400
commita5ce289590099e32f52a0dc4e57b27244401ea45 (patch)
tree4e10a550046d79e709796a0fbbfc2be13236be8e
parent4f01b389e58948217780305bc7080ea36357c013 (diff)
downloadfreebsd-ports-a5ce289590099e32f52a0dc4e57b27244401ea45.zip
www/angie-module-echo: Angie echo dynamic module
Module brings "echo", "sleep", "time", "exec" and more shell-style goodies to config file. It provides various utilities that help testing and debugging of other modules by trivially emulating different kinds of faked subrequest locations. PR: 273462
-rw-r--r--www/Makefile1
-rw-r--r--www/angie-module-echo/Makefile22
-rw-r--r--www/angie-module-echo/files/pkg-message.in15
-rw-r--r--www/angie-module-echo/pkg-descr4
-rw-r--r--www/angie-module-echo/pkg-plist3
5 files changed, 45 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index bd97f64df551..51875e64f8a9 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -31,6 +31,7 @@
SUBDIR += angie-module-auth-spnego
SUBDIR += angie-module-brotli
SUBDIR += angie-module-cache-purge
+ SUBDIR += angie-module-echo
SUBDIR += angie-module-geoip2
SUBDIR += angie-module-image-filter
SUBDIR += angie-module-jwt
diff --git a/www/angie-module-echo/Makefile b/www/angie-module-echo/Makefile
new file mode 100644
index 000000000000..94804caec685
--- /dev/null
+++ b/www/angie-module-echo/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= angie-module-echo
+GH_TUPLE= openresty:echo-nginx-module:v0.63:module
+
+COMMENT= Angie echo dynamic module
+
+MASTERDIR= ${.CURDIR}/../../www/angie
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${MODDIR}
+
+ ${INSTALL_LIB} ${WRKSRC}/objs/ngx_http_echo_module.so \
+ ${STAGEDIR}${MODDIR}
+
+ ${INSTALL_MAN} ${WRKSRC_module}/README.markdown ${STAGEDIR}${DOCSDIR}
+
+do-install-DEBUG-on:
+ ${INSTALL} ${COPY} -m ${_SHAREMODE} \
+ ${WRKSRC_DEBUG}/objs/ngx_http_echo_module.so \
+ ${STAGEDIR}${MODDIR}/ngx_http_echo_module-debug.so
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/angie-module-echo/files/pkg-message.in b/www/angie-module-echo/files/pkg-message.in
new file mode 100644
index 000000000000..e4f266cac252
--- /dev/null
+++ b/www/angie-module-echo/files/pkg-message.in
@@ -0,0 +1,15 @@
+[
+{ type: install
+ message: <<EOM
+
+The echo dynamic module for Angie has been installed.
+To enable this module, add the following to %%PREFIX%%/etc/angie/angie.conf
+and reload angie:
+
+ load_module modules/ngx_http_echo_module.so;
+
+Please refer to the module documentation for further details:
+https://github.com/openresty/echo-nginx-module
+EOM
+}
+]
diff --git a/www/angie-module-echo/pkg-descr b/www/angie-module-echo/pkg-descr
new file mode 100644
index 000000000000..54c524ccae98
--- /dev/null
+++ b/www/angie-module-echo/pkg-descr
@@ -0,0 +1,4 @@
+Module brings "echo", "sleep", "time", "exec" and more shell-style goodies
+to config file.
+It provides various utilities that help testing and debugging of other modules
+by trivially emulating different kinds of faked subrequest locations.
diff --git a/www/angie-module-echo/pkg-plist b/www/angie-module-echo/pkg-plist
new file mode 100644
index 000000000000..3a7750ec54b6
--- /dev/null
+++ b/www/angie-module-echo/pkg-plist
@@ -0,0 +1,3 @@
+%%DOCSDIR%%/README.markdown
+%%MODDIR%%/ngx_http_echo_module.so
+%%DEBUG%%%%MODDIR%%/ngx_http_echo_module-debug.so