summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-11-27 09:53:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-11-27 09:53:01 +0000
commit5b6232705ab0673d0bcc369d12b687e04e427eba (patch)
tree11282af7cf7bcde5d2444b29b628c0c3ebdf59bc
parent3daca20fea8da4c00f97b4e0755c2a5c0adbe61b (diff)
downloadfreebsd-ports-5b6232705ab0673d0bcc369d12b687e04e427eba.zip
- Fix MASTER_SITES
- Support USE_TCL PR: 162853 Submitted by: Ports Fury Feature safe: yes
-rw-r--r--devel/liboop/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/devel/liboop/Makefile b/devel/liboop/Makefile
index 5f1921dbd36a..90bb6d735cf8 100644
--- a/devel/liboop/Makefile
+++ b/devel/liboop/Makefile
@@ -8,30 +8,30 @@
PORTNAME= liboop
PORTVERSION= 1.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_GENTOO}
-MASTER_SITE_SUBDIR= distfiles
+MASTER_SITES= GENTOO/distfiles \
+ http://download.ofb.net/liboop/
MAINTAINER= ports@FreeBSD.org
COMMENT= A low-level event loop management library for POSIX-based OS
LIB_DEPENDS= adns.1:${PORTSDIR}/dns/adns \
- tcl84.1:${PORTSDIR}/lang/tcl84 \
wwwcore.1:${PORTSDIR}/www/libwww
-USE_AUTOTOOLS= libtool
USE_BZIP2= yes
USE_GNOME= glib12 glib20 gnomehack
-GNU_CONFIGURE= yes
+USE_TCL_BUILD= yes
+USE_TCL= yes
+USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --with-libwww
USE_LDCONFIG= yes
-MAKE_JOBS_UNSAFE= yes
+MAKE_JOBS_UNSAFE=yes
-CPPFLAGS+= -I${LOCALBASE}/include/tcl8.4 -I${LOCALBASE}/include
+CPPFLAGS+= -I${TCL_INCLUDEDIR} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
- @${REINPLACE_CMD} -e 's|8\.4|84|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|8\.4|${TCL_VER:S/.//}|g' ${WRKSRC}/configure
.include <bsd.port.mk>