summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-07-12 15:41:37 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-07-12 15:41:37 +0000
commit46032573634c4abb224b81921d1dec4efc5d4827 (patch)
tree31aab455360013c3428de91118147698771e8421
parent37904ce32a86a56891e2b729f78c288f112b86f2 (diff)
downloadfreebsd-ports-46032573634c4abb224b81921d1dec4efc5d4827.zip
Simplify architecture tests for 64-bit. Listing each ARCH is fragile; e.g.,
misses some 64-bit mips variants. While here, further collapse tests for multiple variants of arm, mips, powerpc. Approved by: portmgr (tier-2 blanket)
-rw-r--r--databases/ldb14/Makefile3
-rw-r--r--devel/cxxtools/Makefile6
-rw-r--r--devel/stlink/Makefile2
-rw-r--r--math/metis/Makefile2
-rw-r--r--science/openkim/Makefile4
-rw-r--r--security/matrixssl/Makefile2
6 files changed, 9 insertions, 10 deletions
diff --git a/databases/ldb14/Makefile b/databases/ldb14/Makefile
index d1d1fa81b4bc..22fea27c3910 100644
--- a/databases/ldb14/Makefile
+++ b/databases/ldb14/Makefile
@@ -78,7 +78,7 @@ LDB_LIBS= lib/libldb.so \
lib/shared-modules/ldb/tdb.so
# Only for 64-bit architectures
-.if ${ARCH} != armv6 && ${ARCH} != armv7 && ${ARCH} != i386 && ${ARCH} != mips && ${ARCH} != powerpc && ${ARCH} != powerpcspe
+.if ${ARCH:M*64*}
LDB_DEPENDS+= lmdb>=0.9.16:databases/lmdb
LDB_LIBS+= lib/ldb/libldb-mdb-int.so \
lib/shared-modules/ldb/mdb.so
@@ -149,7 +149,6 @@ CFLAGS+= -fno-color-diagnostics
CONFIGURE_ENV+= NOCOLOR=yes
MAKE_ENV+= NOCOLOR=yes
-
LDB_MAN1= man/man1/ldbadd.1.gz \
man/man1/ldbdel.1.gz \
man/man1/ldbedit.1.gz \
diff --git a/devel/cxxtools/Makefile b/devel/cxxtools/Makefile
index 55e8b227f7ea..b41918ee9b57 100644
--- a/devel/cxxtools/Makefile
+++ b/devel/cxxtools/Makefile
@@ -45,19 +45,19 @@ PLIST_SUB+= X86_ONLY=""
PLIST_SUB+= X86_ONLY="@comment "
.endif
-.if ${ARCH} == arm || ${ARCH} == armv6 || ${ARCH} == armv7
+.if ${ARCH} == aarch64 || ${ARCH:Marm*}
PLIST_SUB+= ARM_ONLY=""
.else
PLIST_SUB+= ARM_ONLY="@comment "
.endif
-.if ${ARCH} == mips || ${ARCH} == mips64
+.if ${ARCH:Mmips*}
PLIST_SUB+= MIPS_ONLY=""
.else
PLIST_SUB+= MIPS_ONLY="@comment "
.endif
-.if ${ARCH} == powerpc || ${ARCH} == powerpc64
+.if ${ARCH:Mpowerpc*}
PLIST_SUB+= PPC_ONLY=""
.else
PLIST_SUB+= PPC_ONLY="@comment "
diff --git a/devel/stlink/Makefile b/devel/stlink/Makefile
index 38c6aa534845..883b88e696ef 100644
--- a/devel/stlink/Makefile
+++ b/devel/stlink/Makefile
@@ -25,7 +25,7 @@ PORTDOCS= README.md tested-boards.md tutorial.md
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386" || ${ARCH} == "powerpc" || ${ARCH} == "arm" || ${ARCH} == "armv6" || ${ARCH} == "mips"
+.if ! ${ARCH:M*64*}
EXTRA_PATCHES+= ${FILESDIR}/extra-pacth-32bit
.endif
diff --git a/math/metis/Makefile b/math/metis/Makefile
index b019fdb37c21..f1ec33acc3dd 100644
--- a/math/metis/Makefile
+++ b/math/metis/Makefile
@@ -67,7 +67,7 @@ pre-configure:
${WRKSRC}/GKlib/GKlibSystem.cmake
@${REINPLACE_CMD} -e "\|/home/karypis/|d" \
${WRKSRC}/programs/CMakeLists.txt
-.if ((${ARCH}=="amd64") || (${ARCH}=="aarch64") || (${ARCH}=="sparc64") || (${ARCH}=="powerpc64"))
+.if ${ARCH:M*64*}
@${REINPLACE_CMD}-e \
's|IDXTYPEWIDTH 32|IDXTYPEWIDTH 64|' \
${WRKSRC}/include/metis.h
diff --git a/science/openkim/Makefile b/science/openkim/Makefile
index 632df3a884c3..5707dbd06f6f 100644
--- a/science/openkim/Makefile
+++ b/science/openkim/Makefile
@@ -20,8 +20,8 @@ MAKE_JOBS_UNSAFE=yes
.include <bsd.port.options.mk>
-# Is there a better way to detect 32-bit systems?
-.if ${ARCH} == armv6 || ${ARCH} == armv7 || ${ARCH} == i386 || ${ARCH} == mips || ${ARCH} == powerpc
+# determine if we are on a 32-bit arch
+.if ! ${ARCH:M*64*}
MAKE_ENV+= KIM_SYSTEM32="yes"
.endif
diff --git a/security/matrixssl/Makefile b/security/matrixssl/Makefile
index 55e110c3e108..7a3b2c2b8eb2 100644
--- a/security/matrixssl/Makefile
+++ b/security/matrixssl/Makefile
@@ -24,7 +24,7 @@ OPTIONS_DEFINE= DOCS EXAMPLES
.include <bsd.port.pre.mk>
-.if ${ARCH} == aarch64 || ${ARCH} == amd64 || ${ARCH} == mips64 || ${ARCH} == powerpc64 || ${ARCH} == sparc64
+.if ${ARCH:M*64*}
CFLAGS+= -DPSTM_64BIT
.endif