summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2023-03-31 00:35:57 -0400
committerSergey A. Osokin <osa@FreeBSD.org>2023-03-31 00:42:05 -0400
commit3135fc31a3be491137af51eeb64b0568e2e30f48 (patch)
tree5787cf8cd6df1f06282c87fbca1501b5731152f2
parent9b3b685dbff328ba3c6d9fd8d9af0a55af811dcc (diff)
downloadfreebsd-ports-3135fc31a3be491137af51eeb64b0568e2e30f48.zip
www/nginx-devel: is able to build with OpenSSL compatibility layer now
Here's the quote from README file. A library that provides QUIC support is recommended to build nginx, there are several of those available on the market: o) BoringSSL o) LibreSSL o) QuicTLS Alternatively, nginx can be configured with OpenSSL compatibility layer, which emulates BoringSSL QUIC API for OpenSSL. This mode is enabled by default if native QUIC support is not detected. 0-RTT is not supported in OpenSSL compatibility mode. Bump PORTREVISION.
-rw-r--r--www/nginx-devel/Makefile10
1 files changed, 1 insertions, 9 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index dfaa815a9e60..8a993472fda2 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -1,6 +1,6 @@
PORTNAME?= nginx
PORTVERSION= 1.23.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= https://nginx.org/download/ \
LOCAL/osa
@@ -230,14 +230,6 @@ CFLAGS+= -DNDEBUG
CFLAGS+= -Wno-compound-token-split-by-macro
.endif
-.if ${PORT_OPTIONS:MHTTPV3} && \
- (empty(PORT_OPTIONS:MHTTPV3_BORING) && \
- empty(PORT_OPTIONS:MHTTPV3_LSSL) && \
- empty(PORT_OPTIONS:MHTTPV3_QTLS))
-IGNORE= required HTTPV3_BORING or HTTPV3_LSSL or HTTPV3_QTLS \
- to be defined. Please do 'make config' again
-.endif
-
.if empty(PORT_OPTIONS:MDYNAMIC_HC) && empty(PORT_OPTIONS:MLUA) && \
empty(PORT_OPTIONS:MMODSECURITY3) && empty(PORT_OPTIONS:MPASSENGER) && \
empty(PORT_OPTIONS:MSMALL_LIGHT)