summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-04-28 21:26:03 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-04-28 21:26:03 +0000
commit12b4a3aef67acae98e9ee98168558d25ee8c9ed6 (patch)
tree41146c136922c4c724765de3f03143181adf3f1c
parent9731d9968b5156d57ba8b3d7946a891e66f16b8b (diff)
downloadfreebsd-ports-12b4a3aef67acae98e9ee98168558d25ee8c9ed6.zip
Add rubygem-erubi 1.6.0
Erubi is a ERB template engine for Ruby. It is a simplified fork of Erubis, using the same basic algorithm, with the following differences: - Handles postfix conditionals when using escaping (e.g. <%= foo if bar %>) - Supports frozen_string_literal: true in templates via :freeze option - Works with Ruby's -enable-frozen-string-literal option - Automatically freezes strings for template text when Ruby optimizes it (on Ruby 2.1+) - Escapes ' (apostrophe) when escaping for better XSS protection - Has 6x faster escaping on Ruby 2.3+ by using cgi/escape - Has 86% smaller memory footprint - Does no monkey patching (Erubis adds a method to Kernel) - Uses an immutable design (all options passed to the constructor, which returns a frozen object) - Has simpler internals (1 file, <150 lines of code) - Has an open development model (Erubis doesn't have a public source control repository or bug tracker) - Is not dead (Erubis hasn't been updated since 2011) WWW: https://github.com/jeremyevans/erubi
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-erubi/Makefile19
-rw-r--r--www/rubygem-erubi/distinfo3
-rw-r--r--www/rubygem-erubi/pkg-descr19
4 files changed, 42 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 35ed93b65110..4e5453686146 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1950,6 +1950,7 @@
SUBDIR += rubygem-em-twitter
SUBDIR += rubygem-em-websocket
SUBDIR += rubygem-emk-sinatra-url-for
+ SUBDIR += rubygem-erubi
SUBDIR += rubygem-erubis
SUBDIR += rubygem-ethon
SUBDIR += rubygem-eventmachine_httpserver
diff --git a/www/rubygem-erubi/Makefile b/www/rubygem-erubi/Makefile
new file mode 100644
index 000000000000..e9948379bbac
--- /dev/null
+++ b/www/rubygem-erubi/Makefile
@@ -0,0 +1,19 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= erubi
+PORTVERSION= 1.6.0
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= ERB template engine for Ruby
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-erubi/distinfo b/www/rubygem-erubi/distinfo
new file mode 100644
index 000000000000..552bb2519e98
--- /dev/null
+++ b/www/rubygem-erubi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1493403401
+SHA256 (rubygem/erubi-1.6.0.gem) = 3d5c1d19390f201a209e5d01a3c41bee253c0b0afa508ee872b979ee3c778a0f
+SIZE (rubygem/erubi-1.6.0.gem) = 12288
diff --git a/www/rubygem-erubi/pkg-descr b/www/rubygem-erubi/pkg-descr
new file mode 100644
index 000000000000..29c50ecf6ee0
--- /dev/null
+++ b/www/rubygem-erubi/pkg-descr
@@ -0,0 +1,19 @@
+Erubi is a ERB template engine for Ruby. It is a simplified fork of Erubis,
+using the same basic algorithm, with the following differences:
+- Handles postfix conditionals when using escaping (e.g. <%= foo if bar %>)
+- Supports frozen_string_literal: true in templates via :freeze option
+- Works with Ruby's -enable-frozen-string-literal option
+- Automatically freezes strings for template text when Ruby optimizes it (on
+ Ruby 2.1+)
+- Escapes ' (apostrophe) when escaping for better XSS protection
+- Has 6x faster escaping on Ruby 2.3+ by using cgi/escape
+- Has 86% smaller memory footprint
+- Does no monkey patching (Erubis adds a method to Kernel)
+- Uses an immutable design (all options passed to the constructor, which returns
+ a frozen object)
+- Has simpler internals (1 file, <150 lines of code)
+- Has an open development model (Erubis doesn't have a public source control
+ repository or bug tracker)
+- Is not dead (Erubis hasn't been updated since 2011)
+
+WWW: https://github.com/jeremyevans/erubi