summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVVD <vvd@unislabs.com>2022-06-26 22:31:43 +0200
committerThierry Thomas <thierry@FreeBSD.org>2022-06-26 22:31:43 +0200
commitf117f2c48552792743a74a931a49e76fc4a9c0f7 (patch)
tree54dfdf5b262ea18e5ce8e7de4c39aee2121677bf
parent897606dcde0eeb3cae2cb04bade909133068c391 (diff)
downloadfreebsd-ports-f117f2c48552792743a74a931a49e76fc4a9c0f7.zip
Mk/bsd.default-versions.mk: Switch default Python version to 3.9
PR: 261703 Reported by: VVD Tested by: exp-run by antoin@ Approved by: maintainer’s time-out
-rw-r--r--Mk/Uses/python.mk4
-rw-r--r--Mk/bsd.default-versions.mk4
-rw-r--r--UPDATING33
3 files changed, 37 insertions, 4 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index 3839cd590101..5c75f4c86f29 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -275,8 +275,8 @@ _INCLUDE_USES_PYTHON_MK= yes
# What Python version and what Python interpreters are currently supported?
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
-_PYTHON_VERSIONS= 3.8 3.9 3.7 3.10 3.11 2.7 # preferred first
-_PYTHON_PORTBRANCH= 3.8 # ${_PYTHON_VERSIONS:[1]}
+_PYTHON_VERSIONS= 3.9 3.8 3.7 3.10 3.11 2.7 # preferred first
+_PYTHON_PORTBRANCH= 3.9 # ${_PYTHON_VERSIONS:[1]}
_PYTHON_BASECMD= ${LOCALBASE}/bin/python
_PYTHON_RELPORTDIR= lang/python
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index 2327e4d2410f..c727a4d9feef 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -112,11 +112,11 @@ PGSQL_DEFAULT?= 13
# Possible values: 7.4, 8.0, 8.1
PHP_DEFAULT?= 8.0
# Possible values: 2.7, 3.7, 3.8, 3.9, 3.10, 3.11
-PYTHON_DEFAULT?= 3.8
+PYTHON_DEFAULT?= 3.9
# Possible values: 2.7
PYTHON2_DEFAULT?= 2.7
# Possible values: 3.7, 3.8, 3.9, 3.10, 3.11
-PYTHON3_DEFAULT?= 3.8
+PYTHON3_DEFAULT?= 3.9
# Possible values: 2.7, 3.0, 3.1, 3.2
RUBY_DEFAULT?= 3.0
# Possible values: rust, rust-nightly
diff --git a/UPDATING b/UPDATING
index dd97de6ce469..01ea8a799abb 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,39 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20220626:
+ AFFECTS: users of python
+ AUTHOR: thierry@FreeBSD.org
+
+ The default version of python3 and python was switched to 3.9.
+
+ For ports users wanting to keep version 3.8 as default,
+ add DEFAULT_VERSIONS+= python=3.8 python3=3.8 to make.conf
+
+ Following procedures may ease the upgrade:
+
+ For users of pre-build packages:
+ # sh
+ # for i in $(pkg query -g %n 'py38-*'); do pkg set -yn ${i}:py39-${i#py38-}; done
+ # pkg upgrade
+
+ For portmaster users:
+ # sh
+ # portmaster -o lang/python39 python38
+ # REINSTALL="$(pkg info -o "*py38*" | awk '{printf "%s ", $2}')"
+ # pkg delete -f "*py38*"
+ # portmaster $REINSTALL
+ # REBUILD=$(pkg query -g "%n:%dn" '*' | grep py3 | grep -v py39 | cut -d : -f 1 | sort -u)
+ # portmaster $REBUILD
+ # REBUILD2=$(pkg list | grep python-38 | xargs pkg which | awk '{print $6}' | sort -u)
+ # portmaster $REBUILD2
+
+ Final steps (for pre-built packages & portmaster):
+
+ If no longer required, Python 3.8 can be removed via
+ "pkg remove python38" and the directory /usr/local/lib/python3.8 can
+ then be deleted afterwards, if not empty.
+
20220625:
AFFECTS: users of sysutils/fusefs-bindfs
AUTHOR: doralitze@chaotikum.org