summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-06-08 05:59:13 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-06-08 05:59:13 +0000
commitf0d0f3d8e0d520067cc0bfd76df3ed050f014370 (patch)
tree6222d08cad20cc04a280a9ae4718b7060765e092
parent9d006776f57e3309bca33411c015f107deb1fe78 (diff)
downloadfreebsd-ports-f0d0f3d8e0d520067cc0bfd76df3ed050f014370.zip
Make ports using libtool treat elftoolchain's strip the same as GNU strip
Any strip on any FreeBSD version should be able to handle stripping requested by libtool PR: 198611 Reviewed by: emaste Exp-run: self
-rw-r--r--Mk/Uses/libtool.mk1
-rw-r--r--audio/liblscp/Makefile4
-rw-r--r--audio/mac/files/patch-configure9
-rw-r--r--devel/pcre/files/patch-configure13
-rw-r--r--devel/synfig/Makefile1
-rw-r--r--graphics/gthumb/Makefile3
-rw-r--r--graphics/pixie/files/patch-configure9
-rw-r--r--graphics/synfigstudio/Makefile1
-rw-r--r--math/yacas/Makefile2
-rw-r--r--multimedia/subtitleeditor/Makefile4
-rw-r--r--net-im/gloox/Makefile3
-rw-r--r--net/nanomsg/Makefile4
-rw-r--r--science/gwyddion/Makefile2
-rw-r--r--sysutils/powerman/Makefile2
14 files changed, 3 insertions, 55 deletions
diff --git a/Mk/Uses/libtool.mk b/Mk/Uses/libtool.mk
index d90126bdf45e..d9db2c28b113 100644
--- a/Mk/Uses/libtool.mk
+++ b/Mk/Uses/libtool.mk
@@ -33,6 +33,7 @@ patch-libtool:
-e '/gcc_ver=\\`/s/gcc /$$CC /' \
-e '/link_all_deplibs[0-9A-Z_]*=/s/=unknown/=no/' \
-e '/objformat=/s/echo aout/echo elf/' \
+ -e '/STRIP -V/s/"GNU strip"/"strip"/' \
-e "/freebsd-elf\\*)/,/;;/ { \
/deplibs_check_method=/s/=.*/=pass_all/; \
/library_names_spec=.*\\.so/ \
diff --git a/audio/liblscp/Makefile b/audio/liblscp/Makefile
index 6caf320718e2..71ef2515a5a1 100644
--- a/audio/liblscp/Makefile
+++ b/audio/liblscp/Makefile
@@ -18,8 +18,4 @@ GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|"GNU strip"|"strip"|' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/audio/mac/files/patch-configure b/audio/mac/files/patch-configure
index 531d0ba82e43..6b94f3d3899f 100644
--- a/audio/mac/files/patch-configure
+++ b/audio/mac/files/patch-configure
@@ -9,12 +9,3 @@
ac_ext=cpp
ac_cpp='$CXXCPP $CPPFLAGS'
ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
-@@ -11215,7 +11215,7 @@ striplib=
- old_striplib=
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether stripping libraries is possible" >&5
- $as_echo_n "checking whether stripping libraries is possible... " >&6; }
--if test -n "$STRIP" && $STRIP -V 2>&1 | $GREP "GNU strip" >/dev/null; then
-+if test -n "$STRIP" && $STRIP -V 2>&1 | $EGREP "GNU|elftoolchain" >/dev/null; then
- test -z "$old_striplib" && old_striplib="$STRIP --strip-debug"
- test -z "$striplib" && striplib="$STRIP --strip-unneeded"
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
diff --git a/devel/pcre/files/patch-configure b/devel/pcre/files/patch-configure
deleted file mode 100644
index 9cfa8c00a599..000000000000
--- a/devel/pcre/files/patch-configure
+++ /dev/null
@@ -1,13 +0,0 @@
---- configure.orig 2015-04-28 11:17:21 UTC
-+++ configure
-@@ -14090,8 +14090,8 @@ striplib=
- old_striplib=
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether stripping libraries is possible" >&5
- $as_echo_n "checking whether stripping libraries is possible... " >&6; }
--if test -n "$STRIP" && $STRIP -V 2>&1 | $GREP "GNU strip" >/dev/null; then
-- test -z "$old_striplib" && old_striplib="$STRIP --strip-debug"
-+if test -n "$STRIP" && $STRIP -V 2>&1 | $GREP "GNU strip" >/dev/null ||
-+ test -n "$STRIP" && $STRIP -V 2>&1 | $GREP "elftoolchain" >/dev/null; then
- test -z "$striplib" && striplib="$STRIP --strip-unneeded"
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
- $as_echo "yes" >&6; }
diff --git a/devel/synfig/Makefile b/devel/synfig/Makefile
index d462fc820bd0..6857951c4b0d 100644
--- a/devel/synfig/Makefile
+++ b/devel/synfig/Makefile
@@ -37,7 +37,6 @@ post-patch:
@${REINPLACE_CMD} -e \
'/optimization_flags/s|CXXFLAGS=|#CXXFLAGS=| ; \
/optimization_flags/s|CFLAGS=|#CFLAGS=| ; \
- s|"GNU strip"|"strip"| ; \
s|el_GR|el| ; \
s|ja_JP|ja| ; \
s|no_NO|no| ; \
diff --git a/graphics/gthumb/Makefile b/graphics/gthumb/Makefile
index f7bed07d18df..7ca4810af450 100644
--- a/graphics/gthumb/Makefile
+++ b/graphics/gthumb/Makefile
@@ -93,8 +93,7 @@ YELP_RUN_DEPENDS= yelp:${PORTSDIR}/x11/yelp
post-patch:
@${REINPLACE_CMD} -e \
- 's|"GNU strip"|"strip"| ; \
- s|-Wl,--as-needed|| ; \
+ 's|-Wl,--as-needed|| ; \
/^[[:blank:]]zlib/d ; \
/webkit2gtk/s|-4.0|-3.0|' ${WRKSRC}/configure
diff --git a/graphics/pixie/files/patch-configure b/graphics/pixie/files/patch-configure
index 5a5410f68a3a..c423707d783f 100644
--- a/graphics/pixie/files/patch-configure
+++ b/graphics/pixie/files/patch-configure
@@ -1,14 +1,5 @@
--- configure.orig
+++ configure
-@@ -12199,7 +12199,7 @@
- old_striplib=
- { $as_echo "$as_me:$LINENO: checking whether stripping libraries is possible" >&5
- $as_echo_n "checking whether stripping libraries is possible... " >&6; }
--if test -n "$STRIP" && $STRIP -V 2>&1 | $GREP "GNU strip" >/dev/null; then
-+if test -n "$STRIP" && $STRIP -V 2>&1 | $GREP "strip" >/dev/null; then
- test -z "$old_striplib" && old_striplib="$STRIP --strip-debug"
- test -z "$striplib" && striplib="$STRIP --strip-unneeded"
- { $as_echo "$as_me:$LINENO: result: yes" >&5
@@ -18418,10 +18418,10 @@
if test x$FLTK_CONFIG != xno ; then
if test x$STATIC_FLTK != xtrue ; then
diff --git a/graphics/synfigstudio/Makefile b/graphics/synfigstudio/Makefile
index 1d65515798ac..0da482199ed1 100644
--- a/graphics/synfigstudio/Makefile
+++ b/graphics/synfigstudio/Makefile
@@ -33,7 +33,6 @@ post-patch:
@${REINPLACE_CMD} -e \
'/optimization_flags/s|CXXFLAGS=|#CXXFLAGS=| ; \
/optimization_flags/s|CFLAGS=|#CFLAGS=| ; \
- s|"GNU strip"|"strip"| ; \
/DATADIRNAME/s|lib|share| ; \
s|<tr1/|<| ; \
s|::tr1||' \
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index c06b1fc06feb..17ec563b429e 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -35,8 +35,6 @@ CPPFLAGS+= -D_GLIBCXX_USE_C99
post-patch:
@${REINPLACE_CMD} -e \
- 's|"GNU strip"|"strip"|' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
's|%%DATADIR%%|${DATADIR}|' ${WRKSRC}/src/yacasmain.cpp
# Can't use USES=shebangfix here, cause the path appears several
# times in the file.
diff --git a/multimedia/subtitleeditor/Makefile b/multimedia/subtitleeditor/Makefile
index 5b46895c04bd..d6ed75838797 100644
--- a/multimedia/subtitleeditor/Makefile
+++ b/multimedia/subtitleeditor/Makefile
@@ -36,8 +36,4 @@ OPENGL_LIB_DEPENDS= libgtkglextmm-x11-1.2.so:${PORTSDIR}/x11-toolkits/gtkglextmm
OPENGL_USE= gl=glu
OPENGL_CONFIGURE_ENABLE=gl
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|"GNU strip"|"strip"|' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/net-im/gloox/Makefile b/net-im/gloox/Makefile
index 253e7f0128ea..a9d558a99483 100644
--- a/net-im/gloox/Makefile
+++ b/net-im/gloox/Makefile
@@ -26,8 +26,7 @@ PORTSCOUT= skipv:1.0.x
post-patch:
@${REINPLACE_CMD} -e \
- 's|"GNU strip"|"strip"| ; \
- s| -ansi||' ${WRKSRC}/configure
+ 's| -ansi||' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's| -pedantic|| ; \
s| -pipe||'
diff --git a/net/nanomsg/Makefile b/net/nanomsg/Makefile
index 97dd9e1bc715..b874fe73f993 100644
--- a/net/nanomsg/Makefile
+++ b/net/nanomsg/Makefile
@@ -25,10 +25,6 @@ PORTDOCS= AUTHORS ChangeLog README
OPTIONS_DEFINE= DOCS
-post-patch:
- @${REINPLACE_CMD} -e 's,GREP "GNU strip",EGREP "GNU|elftoolchain",' \
- ${WRKSRC}/configure
-
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
diff --git a/science/gwyddion/Makefile b/science/gwyddion/Makefile
index 29a926a7eb73..d06220a38dcb 100644
--- a/science/gwyddion/Makefile
+++ b/science/gwyddion/Makefile
@@ -49,8 +49,6 @@ UNIQUE_CONFIGURE_WITH= unique
post-patch:
@${REINPLACE_CMD} -e \
- 's|"GNU strip"|"strip"|' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
's|thumbnailer \\|thumbnailer| ; \
s|devel-docs$$||' ${WRKSRC}/Makefile.in
diff --git a/sysutils/powerman/Makefile b/sysutils/powerman/Makefile
index 3e52ee1677f9..6913981781b9 100644
--- a/sysutils/powerman/Makefile
+++ b/sysutils/powerman/Makefile
@@ -27,8 +27,6 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
- @${REINPLACE_CMD} -e 's,GREP "GNU strip",EGREP "GNU|elftoolchain",' \
- ${WRKSRC}/configure
@${REINPLACE_CMD} -e \
'/^install-data-am/s|:.*|:|' ${WRKSRC}/scripts/Makefile.in