summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-05 05:15:36 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-05 05:15:36 +0000
commitea6b9222cb98987ea4deb32c5ee5d65946549dc2 (patch)
tree542bb98ca5f70f177e4c5d81fa8a0c44f0b0a2e6
parent8b1b0d568b58271cd43196af653cd3eff7b8f1d0 (diff)
downloadfreebsd-ports-ea6b9222cb98987ea4deb32c5ee5d65946549dc2.zip
Adding port www/p5-WWW-Mechanize-Pluggable, Custmomize WWW::Mechanize via plugins.
Approved by: tobez (implicit)
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-WWW-Mechanize-Pluggable/Makefile36
-rw-r--r--www/p5-WWW-Mechanize-Pluggable/distinfo3
-rw-r--r--www/p5-WWW-Mechanize-Pluggable/pkg-descr21
-rw-r--r--www/p5-WWW-Mechanize-Pluggable/pkg-plist9
5 files changed, 70 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 465ad7ef1e5d..a21480a79aa2 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -728,6 +728,7 @@
SUBDIR += p5-WWW-Link
SUBDIR += p5-WWW-Mechanize
SUBDIR += p5-WWW-Mechanize-FormFiller
+ SUBDIR += p5-WWW-Mechanize-Pluggable
SUBDIR += p5-WWW-Mechanize-Shell
SUBDIR += p5-WWW-Mixi
SUBDIR += p5-WWW-Robot
diff --git a/www/p5-WWW-Mechanize-Pluggable/Makefile b/www/p5-WWW-Mechanize-Pluggable/Makefile
new file mode 100644
index 000000000000..67e404f1cfc8
--- /dev/null
+++ b/www/p5-WWW-Mechanize-Pluggable/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-WWW-Mechanize-Pluggable
+# Date created: 04 Jun 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Mechanize-Pluggable
+PORTVERSION= 1.00
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Custmomize WWW::Mechanize via plugins
+
+BUILD_DEPENDS= ${SITE_PERL}/HTML/Form.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/HeadParser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/Module/Pluggable.pm:${PORTSDIR}/devel/p5-Module-Pluggable \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML \
+ ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= WWW::Mechanize::Pluggable.3 WWW::Mechanize::Plugin::HelloWorld.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # inherited from textproc/p5-YAML
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-WWW-Mechanize-Pluggable/distinfo b/www/p5-WWW-Mechanize-Pluggable/distinfo
new file mode 100644
index 000000000000..e91fb27eb2e3
--- /dev/null
+++ b/www/p5-WWW-Mechanize-Pluggable/distinfo
@@ -0,0 +1,3 @@
+MD5 (WWW-Mechanize-Pluggable-1.00.tar.gz) = 232a9479667412a869cc500c90647148
+SHA256 (WWW-Mechanize-Pluggable-1.00.tar.gz) = 1a710a2430f62bb83a2f3d34dbfea9fe41a39384e735d62fbe941496a565792b
+SIZE (WWW-Mechanize-Pluggable-1.00.tar.gz) = 40192
diff --git a/www/p5-WWW-Mechanize-Pluggable/pkg-descr b/www/p5-WWW-Mechanize-Pluggable/pkg-descr
new file mode 100644
index 000000000000..84420281c072
--- /dev/null
+++ b/www/p5-WWW-Mechanize-Pluggable/pkg-descr
@@ -0,0 +1,21 @@
+This module provides all of the same functionality of WWW::Mechanize, but
+adds support for plugins using Module::Pluggable; this means that any
+module named WWW::Mechanize::Plugin::whatever... will be found and loaded
+when WWW::Mechanize::Pluggable is loaded.
+
+Big deal, you say. Well, it becomes a big deal in conjunction with
+WWW::Mechanize::Pluggable's other feature: plugin hooks. When plugins are
+loaded, their import() methods can call WWW::Mechanize::Pluggable's
+prehook and posthook methods. These methods add callbacks to the plugin
+code in WWW::Mechanize::Pluggable's methods. These callbacks can act
+before a method or after it, and have to option of short-circuiting the
+call to the WWW::Mechanize::Pluggable method altogether.
+
+These methods receive whatever parameters the WWW::Mechanize::Pluggable
+methods received, plus a reference to the actvive Mech object.
+
+All other extensions to WWW::Mechanize::Pluggable are handled by the
+plugins.
+
+WWW: http://search.cpan.org/dist/WWW-Mechanize-Pluggable
+Author: Joe McMahon
diff --git a/www/p5-WWW-Mechanize-Pluggable/pkg-plist b/www/p5-WWW-Mechanize-Pluggable/pkg-plist
new file mode 100644
index 000000000000..ad56b5b43d5c
--- /dev/null
+++ b/www/p5-WWW-Mechanize-Pluggable/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/WWW/Mechanize/Pluggable.pm
+%%SITE_PERL%%/WWW/Mechanize/Plugin/HelloWorld.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Mechanize/Pluggable/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Mechanize/Pluggable
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Mechanize
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW
+@dirrmtry %%SITE_PERL%%/WWW/Mechanize/Plugin
+@dirrmtry %%SITE_PERL%%/WWW/Mechanize
+@dirrmtry %%SITE_PERL%%/WWW