summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-09-19 19:16:00 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-09-19 19:16:00 +0000
commitd83866a5f290323ca719e5ec2d94d5716ad1bce4 (patch)
tree99f79d8aa1cafc0a406f106e7e84a36cfa78556f
parent6c22d0c337cf48f9b7bc197d4f608ebef4450b70 (diff)
downloadfreebsd-ports-d83866a5f290323ca719e5ec2d94d5716ad1bce4.zip
Depend on ruby-xmlparser rather than ruby-nqxml. This runs much
faster with the former.
-rw-r--r--net/ruby-xmlrpc/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/net/ruby-xmlrpc/Makefile b/net/ruby-xmlrpc/Makefile
index 509edbf37789..f8a388a0bb8d 100644
--- a/net/ruby-xmlrpc/Makefile
+++ b/net/ruby-xmlrpc/Makefile
@@ -15,11 +15,14 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-RUN_DEPENDS= ${RUBY_SITELIBDIR}/nqxml/info.rb:${PORTSDIR}/textproc/ruby-nqxml \
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/xmlparser.rb:${PORTSDIR}/textproc/ruby-xmlparser \
${RUBY_SITELIBDIR}/TCPSocketPipe.rb:${PORTSDIR}/net/ruby-tcpsocketpipe \
${RUBY_SITELIBDIR}/GServer.rb:${PORTSDIR}/net/ruby-gserver
-# Alternative to ruby-nqxml:
-# ${RUBY_SITELIBDIR}/xmlparser.rb:${PORTSDIR}/textproc/ruby-xmlparser
+# Alternative to ruby-xmlparser:
+# NQXML
+# ${RUBY_SITELIBDIR}/nqxml/info.rb:${PORTSDIR}/textproc/ruby-nqxml
+# REXML (not fully supported yet)
+# ${RUBY_SITELIBDIR}/rexml/rexml.rb:${PORTSDIR}/textproc/ruby-rexml
USE_RUBY= yes