summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-08-21 08:58:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-08-21 08:58:59 +0000
commitd5f006b60e4978d5cfbbf6258eca9590530a49a1 (patch)
tree6a3b8d759dfa2b8b6c20da3ff95ed34cb69e7072
parentc922ba5227b6320d6e1dc2a33fd4c01ffa1508de (diff)
downloadfreebsd-ports-d5f006b60e4978d5cfbbf6258eca9590530a49a1.zip
The syck extension is a binding to the Syck library which facilitates
YAML parsing. YAML(tm) (rhymes with "camel") is a straightforward machine parsable data serialization format designed for human readability and interaction with scripting languages. YAML is optimized for data serialization, configuration settings, log files, Internet messaging and filtering. WWW: http://pecl.php.net/package/syck/ PR: ports/115252 Submitted by: Ditesh Shashikant Gathani <ditesh at gathani.org>
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/pecl-syck/Makefile27
-rw-r--r--textproc/pecl-syck/distinfo3
-rw-r--r--textproc/pecl-syck/pkg-descr10
4 files changed, 41 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index d717d7367410..29bbed6b813e 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -738,6 +738,7 @@
SUBDIR += pear-XML_Wddx
SUBDIR += pecl-ctemplate
SUBDIR += pecl-stem
+ SUBDIR += pecl-syck
SUBDIR += pecl-xdiff
SUBDIR += perl2html
SUBDIR += permute
diff --git a/textproc/pecl-syck/Makefile b/textproc/pecl-syck/Makefile
new file mode 100644
index 000000000000..2088528173ff
--- /dev/null
+++ b/textproc/pecl-syck/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: pecl-syck
+# Date created: 7 Aug 2007
+# Whom: Ditesh Shashikant Gathani <ditesh@gathani.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= syck
+PORTVERSION= 0.9.1
+CATEGORIES= textproc pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= ditesh@gathani.org
+COMMENT= A PECL extension which facilitates YAML parsing
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libsyck.a:${PORTSDIR}/textproc/syck
+
+USE_PHP= spl hash
+USE_PHP_BUILD= yes
+USE_PHPEXT= yes
+
+CONFIGURE_ARGS= --enable-syck
+
+.include <bsd.port.mk>
diff --git a/textproc/pecl-syck/distinfo b/textproc/pecl-syck/distinfo
new file mode 100644
index 000000000000..08d90dea7d8d
--- /dev/null
+++ b/textproc/pecl-syck/distinfo
@@ -0,0 +1,3 @@
+MD5 (PECL/syck-0.9.1.tgz) = 8c418a6dbdef13e0b138eb51c43bcb89
+SHA256 (PECL/syck-0.9.1.tgz) = 758fcf95c25ec03fc6aa6a272dc14778283ada3c0a16689814fd26083cb2768f
+SIZE (PECL/syck-0.9.1.tgz) = 8341
diff --git a/textproc/pecl-syck/pkg-descr b/textproc/pecl-syck/pkg-descr
new file mode 100644
index 000000000000..87c697825a97
--- /dev/null
+++ b/textproc/pecl-syck/pkg-descr
@@ -0,0 +1,10 @@
+The syck extension is a binding to the Syck library which facilitates
+YAML parsing.
+
+YAML(tm) (rhymes with "camel") is a straightforward machine parsable
+data serialization format designed for human readability and
+interaction with scripting languages. YAML is optimized for data
+serialization, configuration settings, log files, Internet
+messaging and filtering.
+
+WWW: http://pecl.php.net/package/syck/