summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-01-20 20:30:18 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-01-20 20:30:18 +0000
commitd507da2f3237522ee1bfa35d8e913e779022f7e8 (patch)
treed38466b000f053ee329e2eca9f1eefcbb974047e
parentdf7f31d156379804bd7a0663215e9c6642d3a9aa (diff)
downloadfreebsd-ports-d507da2f3237522ee1bfa35d8e913e779022f7e8.zip
Stage support
-rw-r--r--cad/chipvault/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/cad/chipvault/Makefile b/cad/chipvault/Makefile
index ed6f8a1c0cb4..c0c140f8142a 100644
--- a/cad/chipvault/Makefile
+++ b/cad/chipvault/Makefile
@@ -9,7 +9,7 @@ DISTNAME= cv.pl
EXTRACT_SUFX= .gz
MAINTAINER= ports@FreeBSD.org
-COMMENT= A project organizer for VHDL and Verilog RTL hardware designs
+COMMENT= Project organizer for VHDL and Verilog RTL hardware designs
NO_WRKSUBDIR= yes
EXTRACT_CMD= ${GZCAT}
@@ -17,11 +17,11 @@ EXTRACT_BEFORE_ARGS= # empty
EXTRACT_AFTER_ARGS= > ${DISTNAME}
NO_BUILD= yes
PLIST_FILES= bin/cv
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= run
+SHEBANG_FILES= cv.pl
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/cv.pl ${PREFIX}/bin/cv
+ ${INSTALL_SCRIPT} ${WRKSRC}/cv.pl ${STAGEDIR}${PREFIX}/bin/cv
.include <bsd.port.mk>