summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2010-08-04 15:04:36 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2010-08-04 15:04:36 +0000
commitd04d53a299b822fb2ee4c44685879a1bc7aa4e9d (patch)
treefb896121eb4a3c9d5280596bdbec927a07982aa3
parent4c7abdbeffb22b34de9f7940f1d5030c2bef3642 (diff)
downloadfreebsd-ports-d04d53a299b822fb2ee4c44685879a1bc7aa4e9d.zip
Add support for ECW and JPEG2000 formats via graphics/libecwj2.
Do not bump PORTREVISION because support of these formats are switched off by default. Submitted by: glebius (maintainer)
-rw-r--r--graphics/gdal/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index 12a3634e1c5e..2784a1b18851 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -31,6 +31,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
OPTIONS= CFITSIO "FITS support" off \
CURL "Curl support" off \
+ ECW "ECW & JPEG2000 support" off \
EXPAT "Expat support" off \
GEOS "GEOS support" off \
GEOTIFF "GeoTIFF support" on \
@@ -71,6 +72,13 @@ CONFIGURE_ARGS+= --with-curl=${LOCALBASE}/bin/curl-config
CONFIGURE_ARGS+= --with-curl=no
.endif
+.if defined(WITH_ECW)
+LIB_DEPENDS+= NCSEcw.0:${PORTSDIR}/graphics/libecwj2
+CONFIGURE_ARGS+= --with-ecw=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --with-ecw=no
+.endif
+
.if defined(WITH_EXPAT)
LIB_DEPENDS+= expat.6:${PORTSDIR}/textproc/expat2
CONFIGURE_ARGS+= --with-expat=${LOCALBASE} \