summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-10-19 10:30:47 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-10-19 10:30:47 +0000
commitcf6d76abb66773582f808be3e82fd0b94210e4ff (patch)
tree2a84baeab59c9e94cd5b554846f9a2b2f5b80faf
parentf103c76a3fc6446f42fe2e9f3f72b19dcb10725e (diff)
downloadfreebsd-ports-cf6d76abb66773582f808be3e82fd0b94210e4ff.zip
Fix patch, I think.
Sponsored by: Absolight Differential Revision:
-rw-r--r--games/blockout/Makefile3
-rw-r--r--games/blockout/files/patch-BotPlayer.cpp16
-rw-r--r--games/blockout/files/patch-BotPlayerAI.cpp16
3 files changed, 18 insertions, 17 deletions
diff --git a/games/blockout/Makefile b/games/blockout/Makefile
index 8197eea5cd8f..6be4b84af335 100644
--- a/games/blockout/Makefile
+++ b/games/blockout/Makefile
@@ -17,7 +17,8 @@ ONLY_FOR_ARCHS= i386 amd64
USE_SDL= mixer sdl
USES= gmake dos2unix
-DOS2UNIX_FILES= ${WRKSRC}/ImageLib/src/gif/gif.h ${WRKSRC}/ImageLib/src/gif/gif.cpp
+DOS2UNIX_FILES= ${WRKSRC}/ImageLib/src/gif/gif.h \
+ ${WRKSRC}/ImageLib/src/gif/gif.cpp ${WRKSRC}/BlockOut/*.cpp
LIB_DEPENDS+= libasound.so:${PORTSDIR}/audio/alsa-lib
USE_GL= gl glu
diff --git a/games/blockout/files/patch-BotPlayer.cpp b/games/blockout/files/patch-BotPlayer.cpp
index 49812b548085..5b12e6c94ae0 100644
--- a/games/blockout/files/patch-BotPlayer.cpp
+++ b/games/blockout/files/patch-BotPlayer.cpp
@@ -1,11 +1,11 @@
--- BlockOut/BotPlayer.cpp.orig 2015-08-20 21:42:27.000000000 +0600
+++ BlockOut/BotPlayer.cpp 2015-08-20 21:42:41.000000000 +0600
@@ -16,7 +16,7 @@
- */
-
- #include "BotPlayer.h"
--#include <malloc.h>
-+#include <stdlib.h>
- #include <string.h>
- #include <stdio.h>
- #include <stdlib.h>
+ */
+
+ #include "BotPlayer.h"
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <stdio.h>
+ #include <stdlib.h>
diff --git a/games/blockout/files/patch-BotPlayerAI.cpp b/games/blockout/files/patch-BotPlayerAI.cpp
index a99bff55382d..a9d58e90b0c8 100644
--- a/games/blockout/files/patch-BotPlayerAI.cpp
+++ b/games/blockout/files/patch-BotPlayerAI.cpp
@@ -1,11 +1,11 @@
--- BlockOut/BotPlayerAI.cpp.orig 2015-08-20 21:43:41.000000000 +0600
+++ BlockOut/BotPlayerAI.cpp 2015-08-20 21:43:51.000000000 +0600
@@ -15,7 +15,7 @@
- GNU General Public License for more details.
- */
- #include "BotPlayer.h"
--#include <malloc.h>
-+#include <stdlib.h>
- #include <string.h>
- #include <stdio.h>
- #include <stdlib.h>
+ GNU General Public License for more details.
+ */
+ #include "BotPlayer.h"
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <stdio.h>
+ #include <stdlib.h>