summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2006-05-29 06:29:42 +0000
committerXin LI <delphij@FreeBSD.org>2006-05-29 06:29:42 +0000
commitc5bb3076dfd1da63fa25de040b7325a0a3392511 (patch)
tree0632c464dbd81c3b56655922d2bb7be61b6ee0d6
parent7cd8c2797d9438a09b2b047c323f7f7856f01504 (diff)
downloadfreebsd-ports-c5bb3076dfd1da63fa25de040b7325a0a3392511.zip
Fix wrong PKGNAME and COMMENT when WITH_SASL is defined.
Please note that the openldap 2.2.x series is now considered obsolete and is no longer maintained. Therefore, updates to this port would be more conservative and less effort would be taken here in the future. Current OpenLDAP users are encouraged to upgrade to 2.3.x. Submitted by: Gyorgy TEUBEL <tgyurci freemail hu> (with changes) PR: ports/91902
-rw-r--r--net/openldap22-client/Makefile4
-rw-r--r--net/openldap22-sasl-client/Makefile4
-rw-r--r--net/openldap22-server/Makefile37
3 files changed, 18 insertions, 27 deletions
diff --git a/net/openldap22-client/Makefile b/net/openldap22-client/Makefile
index f5ce1cde5e5b..98353f818e69 100644
--- a/net/openldap22-client/Makefile
+++ b/net/openldap22-client/Makefile
@@ -5,10 +5,6 @@
# $FreeBSD$
#
-PKGNAMESUFFIX= -client
-
-COMMENT= Open source LDAP client implementation
-
CLIENT_ONLY= yes
MASTERDIR= ${.CURDIR}/../openldap22-server
diff --git a/net/openldap22-sasl-client/Makefile b/net/openldap22-sasl-client/Makefile
index def3d97655fe..8bb715886336 100644
--- a/net/openldap22-sasl-client/Makefile
+++ b/net/openldap22-sasl-client/Makefile
@@ -5,10 +5,6 @@
# $FreeBSD$
#
-PKGNAMESUFFIX= -sasl-client
-
-COMMENT= Open source LDAP client implementation with SASL2 support
-
CLIENT_ONLY= yes
WITH_SASL= yes
diff --git a/net/openldap22-server/Makefile b/net/openldap22-server/Makefile
index 12e856b9233a..44d47cb58aab 100644
--- a/net/openldap22-server/Makefile
+++ b/net/openldap22-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openldap
PORTVERSION= 2.2.30
-OPENLDAP_PORTREVISION= ${PORTREVISION_CLIENT}
+PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
http://public.planetmirror.com/pub/openldap/%SUBDIR%/ \
@@ -24,35 +24,36 @@ MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
ftp://sunsite.cnlab-switch.ch/mirror/OpenLDAP/%SUBDIR%/ \
ftp://ftp.plig.org/pub/OpenLDAP/%SUBDIR%/
MASTER_SITE_SUBDIR= openldap-release
-PKGNAMESUFFIX?= -server
EXTRACT_SUFX= .tgz
MAINTAINER= delphij@FreeBSD.org
-COMMENT?= Open source LDAP server implementation
UNIQUENAME?= ${PKGNAMEPREFIX}openldap22
LATEST_LINK?= ${UNIQUENAME}${PKGNAMESUFFIX}
+USE_OPENSSL= yes
WANT_OPENLDAP_VER?= 22
.if ${WANT_OPENLDAP_VER} != 22
BROKEN= "incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}"
.endif
-OPENLDAP_PORTREVISION= ${PORTREVISION_CLIENT}
-OPENLDAP_PORTREVISION= ${PORTREVISION_CLIENT}
+PORTREVISION_CLIENT= 0
+PORTREVISION_SERVER= 0
.if defined(CLIENT_ONLY)
OPENLDAP_PORTREVISION= ${PORTREVISION_CLIENT}
OPENLDAP_PKGFILESUFX= .client
-.if ${PKGNAMESUFFIX} == "-sasl-client"
+.if defined(WITH_SASL)
+COMMENT= Open source LDAP client implementation with SASL2 support
+PKGNAMESUFFIX= -sasl-client
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.* \
${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.[!2].*
-.elif ${PKGNAMESUFFIX} == "-client"
+.else
+COMMENT= Open source LDAP client implementation
+PKGNAMESUFFIX= -client
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.[!2].* \
${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.*
-.else
-BROKEN= Unknown PKGNAMESUFFIX ${PKGNAMESUFFIX}
.endif
.if !defined(NOPORTDOCS)
@@ -62,29 +63,27 @@ PORTDOCS= CHANGES drafts rfc
.if defined(USE_OPENLDAP)
IGNORE= : You have \`USE_OPENLDAP' defined either in your environment or in make(1) arguments
.endif
+USE_OPENLDAP= yes
+WANT_OPENLDAP_VER= 22
+
.else
OPENLDAP_PORTREVISION= ${PORTREVISION_SERVER}
OPENLDAP_PKGFILESUFX=
.if defined(WITH_SASL)
-RUN_DEPENDS= ${LOCALBASE}/lib/libldap-2.2.so.7:${PORTSDIR}/net/openldap22-sasl-client
-.else
-RUN_DEPENDS= ${LOCALBASE}/lib/libldap-2.2.so.7:${PORTSDIR}/net/openldap22-client
-.endif
-
-.if ${PKGNAMESUFFIX} == "-sasl-server"
+COMMENT= Open source LDAP server implementation with SASL2 support
+PKGNAMESUFFIX= -sasl-server
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-server-2.* \
${PKGNAMEPREFIX}${PORTNAME}-sasl-server-2.[!2].*
-.elif ${PKGNAMESUFFIX} == "-server"
+.else
+COMMENT= Open source LDAP server implementation
+PKGNAMESUFFIX= -server
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-server-2.[!2].* \
${PKGNAMEPREFIX}${PORTNAME}-sasl-server-2.*
-.else
-BROKEN= Unknown PKGNAMESUFFIX ${PKGNAMESUFFIX}
.endif
.endif
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
DESCR= ${PKGDIR}/pkg-descr${OPENLDAP_PKGFILESUFX}