summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2015-07-08 18:41:07 +0000
committerSteve Wills <swills@FreeBSD.org>2015-07-08 18:41:07 +0000
commitc079efbd3a92521e375c654bc1cc347e1b13cbd4 (patch)
tree69e3af525ebb36047452f5291f0672151992d985
parent32aef967cf54f2d2c326d80b900f0acff7262a61 (diff)
downloadfreebsd-ports-c079efbd3a92521e375c654bc1cc347e1b13cbd4.zip
devel/libtermkey: create port
This library allows easy processing of keyboard entry from terminal-based programs. It handles all the necessary logic to recognise special keys, UTF-8 combining, and so on, with a simple interface. WWW: http://www.leonerd.org.uk/code/libtermkey/ PR: 198711 Submitted by: Anton Törnqvist <antont@inbox.lv>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libtermkey/Makefile24
-rw-r--r--devel/libtermkey/distinfo2
-rw-r--r--devel/libtermkey/pkg-descr5
-rw-r--r--devel/libtermkey/pkg-plist30
5 files changed, 62 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 44b884bc08dd..88c33ec1c6d5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1251,6 +1251,7 @@
SUBDIR += libtap
SUBDIR += libtar
SUBDIR += libtecla
+ SUBDIR += libtermkey
SUBDIR += libthai
SUBDIR += libtifiles2
SUBDIR += libtool
diff --git a/devel/libtermkey/Makefile b/devel/libtermkey/Makefile
new file mode 100644
index 000000000000..afde71a6f29a
--- /dev/null
+++ b/devel/libtermkey/Makefile
@@ -0,0 +1,24 @@
+# Created by: Anton Tornqvist <antont@inbox.lv>
+# $FreeBSD$
+
+PORTNAME= libtermkey
+PORTVERSION= 0.17
+CATEGORIES= devel
+MASTER_SITES= http://www.leonerd.org.uk/code/libtermkey/
+
+MAINTAINER= antont@inbox.lv
+COMMENT= Easy processing of keyboard entry from terminal-based programs
+
+LICENSE= MIT
+
+USES= gmake libtool:build
+LIB_DEPENDS= libunibilium.so:${PORTSDIR}/devel/unibilium
+USE_LDCONFIG= yes
+
+pre-build:
+ ${REINPLACE_CMD} -e 's|$$(LIBDIR)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' ${WRKSRC}/Makefile
+
+post-stage:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtermkey.so.1.11.0
+
+.include <bsd.port.mk>
diff --git a/devel/libtermkey/distinfo b/devel/libtermkey/distinfo
new file mode 100644
index 000000000000..d6bd51cf690c
--- /dev/null
+++ b/devel/libtermkey/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libtermkey-0.17.tar.gz) = 68949364ed5eaad857b3dea10071cde74b00b9f236dfbb702169f246c3cef389
+SIZE (libtermkey-0.17.tar.gz) = 42176
diff --git a/devel/libtermkey/pkg-descr b/devel/libtermkey/pkg-descr
new file mode 100644
index 000000000000..06ec0b79e2b4
--- /dev/null
+++ b/devel/libtermkey/pkg-descr
@@ -0,0 +1,5 @@
+This library allows easy processing of keyboard entry from terminal-based
+programs. It handles all the necessary logic to recognise special keys,
+UTF-8 combining, and so on, with a simple interface.
+
+WWW: http://www.leonerd.org.uk/code/libtermkey/
diff --git a/devel/libtermkey/pkg-plist b/devel/libtermkey/pkg-plist
new file mode 100644
index 000000000000..a052cacdd605
--- /dev/null
+++ b/devel/libtermkey/pkg-plist
@@ -0,0 +1,30 @@
+include/termkey.h
+lib/libtermkey.a
+lib/libtermkey.so
+lib/libtermkey.so.1
+lib/libtermkey.so.1.11.0
+libdata/pkgconfig/termkey.pc
+share/man/man3/termkey_advisereadable.3.gz
+share/man/man3/termkey_canonicalise.3.gz
+share/man/man3/termkey_get_buffer_remaining.3.gz
+share/man/man3/termkey_get_fd.3.gz
+share/man/man3/termkey_get_keyname.3.gz
+share/man/man3/termkey_getkey.3.gz
+share/man/man3/termkey_interpret_csi.3.gz
+share/man/man3/termkey_interpret_modereport.3.gz
+share/man/man3/termkey_interpret_mouse.3.gz
+share/man/man3/termkey_interpret_position.3.gz
+share/man/man3/termkey_keycmp.3.gz
+share/man/man3/termkey_keyname2sym.3.gz
+share/man/man3/termkey_lookup_keyname.3.gz
+share/man/man3/termkey_new.3.gz
+share/man/man3/termkey_push_bytes.3.gz
+share/man/man3/termkey_set_buffer_size.3.gz
+share/man/man3/termkey_set_canonflags.3.gz
+share/man/man3/termkey_set_flags.3.gz
+share/man/man3/termkey_set_waittime.3.gz
+share/man/man3/termkey_start.3.gz
+share/man/man3/termkey_strfkey.3.gz
+share/man/man3/termkey_strpkey.3.gz
+share/man/man3/termkey_waitkey.3.gz
+share/man/man7/termkey.7.gz