summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2024-02-22 22:06:33 +0100
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2024-02-24 06:23:52 +0100
commitbf09746b742d1fbdeb5235f848c5823c87b51339 (patch)
tree44aa450e9f70d3b2ce9db11818446933beaeeab5
parent4514eec41abbc0c530c639a1a140b8279530ee0a (diff)
downloadfreebsd-ports-bf09746b742d1fbdeb5235f848c5823c87b51339.zip
science/paraview: fix build against pdal 2.6.3
-rw-r--r--science/paraview/Makefile4
-rw-r--r--science/paraview/files/patch-VTK_IO_PDAL_CMakeLists.txt18
2 files changed, 20 insertions, 2 deletions
diff --git a/science/paraview/Makefile b/science/paraview/Makefile
index 93330f5fd840..54ef4f21c32e 100644
--- a/science/paraview/Makefile
+++ b/science/paraview/Makefile
@@ -1,6 +1,6 @@
PORTNAME= paraview
DISTVERSION= ${PARAVIEW_VER}.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= science graphics
MASTER_SITES= http://www.paraview.org/files/v${PARAVIEW_VER}/
DISTNAME= ParaView-v${PORTVERSION}
@@ -38,7 +38,7 @@ LIB_DEPENDS= libhdf5.so:science/hdf5 \
libgeos.so:graphics/geos \
libhpdf.so:print/libharu \
libproj.so:graphics/proj \
- libpdal_base.so:math/pdal \
+ libpdalcpp.so:math/pdal \
libdrm.so:graphics/libdrm \
libcgns.so:science/cgnslib \
liblz4.so:archivers/liblz4 \
diff --git a/science/paraview/files/patch-VTK_IO_PDAL_CMakeLists.txt b/science/paraview/files/patch-VTK_IO_PDAL_CMakeLists.txt
new file mode 100644
index 000000000000..a42187e0f819
--- /dev/null
+++ b/science/paraview/files/patch-VTK_IO_PDAL_CMakeLists.txt
@@ -0,0 +1,18 @@
+--- VTK/IO/PDAL/CMakeLists.txt.orig 2024-02-22 20:32:51 UTC
++++ VTK/IO/PDAL/CMakeLists.txt
+@@ -3,14 +3,7 @@ set(classes
+ set(classes
+ vtkPDALReader)
+
+-set(pdal_libraries pdal_util)
+-if (APPLE OR WIN32)
+- list(APPEND pdal_libraries
+- pdalcpp)
+-else()
+- list(APPEND pdal_libraries
+- pdal_base)
+-endif()
++set(pdal_libraries pdalcpp)
+
+ vtk_module_add_module(VTK::IOPDAL
+ CLASSES ${classes})