summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2015-07-29 17:52:52 +0000
committerBrooks Davis <brooks@FreeBSD.org>2015-07-29 17:52:52 +0000
commitbdf3bffbf75c2696da0386743856fa053d54d4a0 (patch)
tree4a90e3a68fe82db71ec10764b3e63207b0451396
parentef78c0a4b610c069942699d694f855f9f688333e (diff)
downloadfreebsd-ports-bdf3bffbf75c2696da0386743856fa053d54d4a0.zip
Fix some mistakes that preventing fetching and building.
I'll switch to USE_GITHUB in a later commit. Submitted by: jbeich
-rw-r--r--devel/llvm-devel/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index 4895d7b1d3fe..9489c2afaf43 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -8,8 +8,8 @@ CATEGORIES= devel lang
MASTER_SITES= \
http://github.com/llvm-mirror/llvm/archive/${LLVM_COMMIT}.tar.gz?dummy=/ \
http://github.com/llvm-mirror/clang/archive/${CLANG_COMMIT}.tar.gz?dummy=/:clang \
- http://github.com/llvm-mirror/lld/archive/${LLD_COMMIT}.tar.gz?dummy=/:lld
- http://github.com/llvm-mirror/lldb/archive/${LLDB_COMMIT}.tar.gz?dummy=/:lldb
+ http://github.com/llvm-mirror/lld/archive/${LLD_COMMIT}.tar.gz?dummy=/:lld \
+ http://github.com/llvm-mirror/lldb/archive/${LLDB_COMMIT}.tar.gz?dummy=/:lldb \
http://github.com/llvm-mirror/openmp/archive/${OPENMP_COMMIT}.tar.gz?dummy=/:openmp
DISTFILES= ${LLVM_NAME}.tar.gz
PKGNAMESUFFIX= -devel
@@ -56,10 +56,11 @@ CLANG_DESC= Build clang
CLANG_EXTRA_PATCHES= ${PATCHDIR}/clang-patch-tools_clang_lib_Headers_CMakeLists.txt
CLANG_DISTFILES= ${CLANG_NAME}.tar.gz:clang
CLANG_CONFLICTS_INSTALL= clang-devel-3.[1234567]*
-LIT_DESC= Install lit and FileCheck test tools
+LIT_DESC= Install lit and FileCheck test tools
LLD_DESC= Install lld, the LLVM linker
LLD_DISTFILES= ${LLD_NAME}.tar.gz:lld
LLDB_DESC= Install lldb, the LLVM debugger
+LLDB_BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
LLDB_DISTFILES= ${LLDB_NAME}.tar.gz:lldb
OPENMP_DESC= Install libomp, the LLVM OpenMP runtime library
OPENMP_DISTFILES= ${OPENMP_NAME}.tar.gz:openmp