summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-06 12:14:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-06 12:14:48 +0000
commitb6c0292f9ccc90104bed641307dca463317a6e53 (patch)
tree7909b54d8d566ea8027b448f0bb46342df824602
parent01fdcb7f948e3657a40711daee297a44fbb62440 (diff)
downloadfreebsd-ports-b6c0292f9ccc90104bed641307dca463317a6e53.zip
- Stage support
-rw-r--r--sysutils/fanout/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/sysutils/fanout/Makefile b/sysutils/fanout/Makefile
index 9579c45332b8..eddcda514155 100644
--- a/sysutils/fanout/Makefile
+++ b/sysutils/fanout/Makefile
@@ -15,11 +15,8 @@ USES= perl5
USE_PERL5= run
NO_BUILD= yes
PLIST_FILES= bin/fanout bin/fanterm bin/fanmux
-.if !defined(NOPORTDOCS)
PORTDOCS= README index.html
-.endif
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g' \
${WRKSRC}/fanterm
@@ -27,12 +24,10 @@ post-patch:
${WRKSRC}/fanmux
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/fanout ${PREFIX}/bin/
- ${INSTALL_SCRIPT} ${WRKSRC}/fanterm ${PREFIX}/bin/
- ${INSTALL_SCRIPT} ${WRKSRC}/fanmux ${PREFIX}/bin/
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/fanout ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/fanterm ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/fanmux ${STAGEDIR}${PREFIX}/bin/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>