summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-11-05 13:14:45 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-11-05 13:14:45 +0000
commitb388d7709fd45e9be54e4f85ef9744d2e2f4791e (patch)
tree829f539391ab03103fcf6342241e0bb3165d86d1
parent065c026fe5e21a269bbaae0ce69307c7308acbea (diff)
downloadfreebsd-ports-b388d7709fd45e9be54e4f85ef9744d2e2f4791e.zip
Fix build as a user.
Sponsored by: Absolight
-rw-r--r--games/falconseye/Makefile8
-rw-r--r--games/falconseye/files/patch-sys_unix_Makefile_top2
-rw-r--r--games/falconseye/pkg-plist530
3 files changed, 268 insertions, 272 deletions
diff --git a/games/falconseye/Makefile b/games/falconseye/Makefile
index c91c0476df46..10c3de3624ab 100644
--- a/games/falconseye/Makefile
+++ b/games/falconseye/Makefile
@@ -3,7 +3,7 @@
PORTNAME= falconseye
PORTVERSION= 1.9.3
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/NetHack-Falcon_s%20Eye%20%28source%29/${PORTVERSION}
DISTNAME= nethack_source_331_jtp_${PORTVERSION:S/.//g}
@@ -14,8 +14,8 @@ COMMENT= NetHack derivative
RUN_DEPENDS= timidity:${PORTSDIR}/audio/timidity
USES= perl5 zip
-NHDIR= "${PREFIX}/share/falconseyedir"
-MAKE_ENV= NHDIR="${NHDIR}" NETHACKCONFIG="${NETHACKCONFIG}"
+DATADIR= ${PREFIX}/share/falconseyedir
+MAKE_ENV= NHDIR="${DATADIR}" NETHACKCONFIG="${NETHACKCONFIG}"
NETHACKCONFIG= ${FILESDIR}/x-config
USE_SDL= sdl
USE_PERL5= build
@@ -45,5 +45,7 @@ post-install:
${STAGEDIR}${PREFIX}/man/man6/frecover.6
cd ${WRKSRC}/doc && ${INSTALL_MAN} nethack.6 \
${STAGEDIR}${PREFIX}/man/man6/falconseye.6
+ ${TOUCH} ${STAGEDIR}${DATADIR}/logfile ${STAGEDIR}${DATADIR}/perm \
+ ${STAGEDIR}${DATADIR}/record
.include <bsd.port.mk>
diff --git a/games/falconseye/files/patch-sys_unix_Makefile_top b/games/falconseye/files/patch-sys_unix_Makefile_top
index 1a1585904fc8..09af962183e4 100644
--- a/games/falconseye/files/patch-sys_unix_Makefile_top
+++ b/games/falconseye/files/patch-sys_unix_Makefile_top
@@ -37,7 +37,7 @@
# setgid instead of setuid. Therefore we must also allow group writing
# for the files and directories.
-GAMEPERM = 02755
-+GAMEPERM = 02555
++GAMEPERM = 0555
FILEPERM = 0664
EXEPERM = 0755
DIRPERM = 0775
diff --git a/games/falconseye/pkg-plist b/games/falconseye/pkg-plist
index b11d0ac360c0..62e9d11c3328 100644
--- a/games/falconseye/pkg-plist
+++ b/games/falconseye/pkg-plist
@@ -1,272 +1,266 @@
-@group games
bin/falconseye
bin/frecover
-share/falconseyedir/Arc-fila.lev
-share/falconseyedir/Arc-filb.lev
-share/falconseyedir/Arc-goal.lev
-share/falconseyedir/Arc-loca.lev
-share/falconseyedir/Arc-strt.lev
-share/falconseyedir/Bar-fila.lev
-share/falconseyedir/Bar-filb.lev
-share/falconseyedir/Bar-goal.lev
-share/falconseyedir/Bar-loca.lev
-share/falconseyedir/Bar-strt.lev
-share/falconseyedir/Cav-fila.lev
-share/falconseyedir/Cav-filb.lev
-share/falconseyedir/Cav-goal.lev
-share/falconseyedir/Cav-loca.lev
-share/falconseyedir/Cav-strt.lev
-share/falconseyedir/Hea-fila.lev
-share/falconseyedir/Hea-filb.lev
-share/falconseyedir/Hea-goal.lev
-share/falconseyedir/Hea-loca.lev
-share/falconseyedir/Hea-strt.lev
-share/falconseyedir/Kni-fila.lev
-share/falconseyedir/Kni-filb.lev
-share/falconseyedir/Kni-goal.lev
-share/falconseyedir/Kni-loca.lev
-share/falconseyedir/Kni-strt.lev
-share/falconseyedir/Mon-fila.lev
-share/falconseyedir/Mon-filb.lev
-share/falconseyedir/Mon-goal.lev
-share/falconseyedir/Mon-loca.lev
-share/falconseyedir/Mon-strt.lev
-share/falconseyedir/Pri-fila.lev
-share/falconseyedir/Pri-filb.lev
-share/falconseyedir/Pri-goal.lev
-share/falconseyedir/Pri-loca.lev
-share/falconseyedir/Pri-strt.lev
-share/falconseyedir/Ran-fila.lev
-share/falconseyedir/Ran-filb.lev
-share/falconseyedir/Ran-goal.lev
-share/falconseyedir/Ran-loca.lev
-share/falconseyedir/Ran-strt.lev
-share/falconseyedir/Rog-fila.lev
-share/falconseyedir/Rog-filb.lev
-share/falconseyedir/Rog-goal.lev
-share/falconseyedir/Rog-loca.lev
-share/falconseyedir/Rog-strt.lev
-share/falconseyedir/Sam-fila.lev
-share/falconseyedir/Sam-filb.lev
-share/falconseyedir/Sam-goal.lev
-share/falconseyedir/Sam-loca.lev
-share/falconseyedir/Sam-strt.lev
-share/falconseyedir/Tou-fila.lev
-share/falconseyedir/Tou-filb.lev
-share/falconseyedir/Tou-goal.lev
-share/falconseyedir/Tou-loca.lev
-share/falconseyedir/Tou-strt.lev
-share/falconseyedir/Val-fila.lev
-share/falconseyedir/Val-filb.lev
-share/falconseyedir/Val-goal.lev
-share/falconseyedir/Val-loca.lev
-share/falconseyedir/Val-strt.lev
-share/falconseyedir/Wiz-fila.lev
-share/falconseyedir/Wiz-filb.lev
-share/falconseyedir/Wiz-goal.lev
-share/falconseyedir/Wiz-loca.lev
-share/falconseyedir/Wiz-strt.lev
-share/falconseyedir/air.lev
-share/falconseyedir/asmodeus.lev
-share/falconseyedir/astral.lev
-share/falconseyedir/baalz.lev
-share/falconseyedir/bigrm-1.lev
-share/falconseyedir/bigrm-2.lev
-share/falconseyedir/bigrm-3.lev
-share/falconseyedir/bigrm-4.lev
-share/falconseyedir/bigrm-5.lev
-share/falconseyedir/castle.lev
-share/falconseyedir/cmdhelp
-share/falconseyedir/config/jtp_intr.txt
-share/falconseyedir/config/jtp_keys.txt
-share/falconseyedir/config/jtp_lit1.dat
-share/falconseyedir/config/jtp_opts.txt
-share/falconseyedir/config/jtp_snds.txt
-share/falconseyedir/data
-share/falconseyedir/defaults.nh
-share/falconseyedir/dungeon
-share/falconseyedir/earth.lev
-share/falconseyedir/fakewiz1.lev
-share/falconseyedir/fakewiz2.lev
-share/falconseyedir/fire.lev
-share/falconseyedir/graphics/backpac5.pcx
-share/falconseyedir/graphics/book1.pcx
-share/falconseyedir/graphics/book2.pcx
-share/falconseyedir/graphics/cairn.pcx
-share/falconseyedir/graphics/chargen2.pcx
-share/falconseyedir/graphics/dawn.pcx
-share/falconseyedir/graphics/dreams.pcx
-share/falconseyedir/graphics/entrance.pcx
-share/falconseyedir/graphics/jtp_cm07.pcx
-share/falconseyedir/graphics/jtp_cm08.pcx
-share/falconseyedir/graphics/jtp_cm09.pcx
-share/falconseyedir/graphics/jtp_cm12.pcx
-share/falconseyedir/graphics/jtp_cm13.pcx
-share/falconseyedir/graphics/jtp_cmb8.pcx
-share/falconseyedir/graphics/jtp_cmc7.pcx
-share/falconseyedir/graphics/jtp_mon6.pcx
-share/falconseyedir/graphics/jtp_mon7.pcx
-share/falconseyedir/graphics/jtp_mou5.pcx
-share/falconseyedir/graphics/jtp_mwi4.pcx
-share/falconseyedir/graphics/jtp_nh_1.pcx
-share/falconseyedir/graphics/jtp_obj1.pcx
-share/falconseyedir/graphics/jtp_obj2.pcx
-share/falconseyedir/graphics/jtp_st10.pcx
-share/falconseyedir/graphics/jtp_win1.pcx
-share/falconseyedir/graphics/mandolin.pcx
-share/falconseyedir/graphics/menuchr2.pcx
-share/falconseyedir/graphics/micons2.pcx
-share/falconseyedir/graphics/night.pcx
-share/falconseyedir/graphics/quitgame.pcx
-share/falconseyedir/graphics/stairway.pcx
-share/falconseyedir/graphics/ttipchr1.pcx
-share/falconseyedir/graphics/valley.pcx
-share/falconseyedir/graphics/walls02a.pcx
-share/falconseyedir/graphics/walls02b.pcx
-share/falconseyedir/graphics/walls02c.pcx
-share/falconseyedir/graphics/walls03a.pcx
-share/falconseyedir/graphics/walls03b.pcx
-share/falconseyedir/graphics/walls03c.pcx
-share/falconseyedir/graphics/yendor.pcx
-share/falconseyedir/help
-share/falconseyedir/hh
-share/falconseyedir/history
-share/falconseyedir/juiblex.lev
-share/falconseyedir/knox.lev
-share/falconseyedir/license
-share/falconseyedir/manual/arrows1.jpg
-share/falconseyedir/manual/arrows2.jpg
-share/falconseyedir/manual/buttonpanel.jpg
-share/falconseyedir/manual/char_arc.jpg
-share/falconseyedir/manual/char_kni.jpg
-share/falconseyedir/manual/char_pri.jpg
-share/falconseyedir/manual/char_ran.jpg
-share/falconseyedir/manual/char_rog.jpg
-share/falconseyedir/manual/char_tou.jpg
-share/falconseyedir/manual/char_val.jpg
-share/falconseyedir/manual/char_wiz.jpg
-share/falconseyedir/manual/contextmenu.jpg
-share/falconseyedir/manual/dng_door.jpg
-share/falconseyedir/manual/dng_strs.jpg
-share/falconseyedir/manual/giantant.jpg
-share/falconseyedir/manual/index.html
-share/falconseyedir/manual/letter_a.jpg
-share/falconseyedir/manual/letter_c.jpg
-share/falconseyedir/manual/letter_m.jpg
-share/falconseyedir/manual/letter_n.jpg
-share/falconseyedir/manual/letter_o.jpg
-share/falconseyedir/manual/letter_r.jpg
-share/falconseyedir/manual/letter_t.jpg
-share/falconseyedir/manual/letter_w.jpg
-share/falconseyedir/manual/letter_y.jpg
-share/falconseyedir/manual/main.html
-share/falconseyedir/manual/main_10.html
-share/falconseyedir/manual/main_11.html
-share/falconseyedir/manual/main_12.html
-share/falconseyedir/manual/main_2.html
-share/falconseyedir/manual/main_3.html
-share/falconseyedir/manual/main_4.html
-share/falconseyedir/manual/main_5.html
-share/falconseyedir/manual/main_6.html
-share/falconseyedir/manual/main_7.html
-share/falconseyedir/manual/main_8.html
-share/falconseyedir/manual/main_9.html
-share/falconseyedir/manual/mapwindow.jpg
-share/falconseyedir/manual/minimap.jpg
-share/falconseyedir/manual/navbar.html
-share/falconseyedir/manual/nhisomet.jpg
-share/falconseyedir/manual/nhmanual.css
-share/falconseyedir/manual/nhnavlog.jpg
-share/falconseyedir/manual/obj_food.jpg
-share/falconseyedir/manual/obj_gem.jpg
-share/falconseyedir/manual/obj_potion.jpg
-share/falconseyedir/manual/obj_ring.jpg
-share/falconseyedir/manual/obj_scroll.jpg
-share/falconseyedir/manual/obj_sword.jpg
-share/falconseyedir/manual/paper1.jpg
-share/falconseyedir/manual/scrollrun.jpg
-share/falconseyedir/manual/statusbar.jpg
-share/falconseyedir/manual/valley.jpg
-share/falconseyedir/manual/wallstyle_full.jpg
-share/falconseyedir/manual/wallstyle_halfheight.jpg
-share/falconseyedir/manual/wallstyle_transparent.jpg
-share/falconseyedir/medusa-1.lev
-share/falconseyedir/medusa-2.lev
-share/falconseyedir/minefill.lev
-share/falconseyedir/minend-1.lev
-share/falconseyedir/minend-2.lev
-share/falconseyedir/minetn-1.lev
-share/falconseyedir/minetn-2.lev
-share/falconseyedir/nethack.ico
-share/falconseyedir/opthelp
-share/falconseyedir/options
-share/falconseyedir/oracle.lev
-share/falconseyedir/oracles
-share/falconseyedir/orcus.lev
-share/falconseyedir/quest.dat
-share/falconseyedir/rumors
-share/falconseyedir/sanctum.lev
-share/falconseyedir/soko1-1.lev
-share/falconseyedir/soko1-2.lev
-share/falconseyedir/soko2-1.lev
-share/falconseyedir/soko2-2.lev
-share/falconseyedir/soko3-1.lev
-share/falconseyedir/soko3-2.lev
-share/falconseyedir/soko4-1.lev
-share/falconseyedir/soko4-2.lev
-share/falconseyedir/sound/aircaves.mid
-share/falconseyedir/sound/ambient1.mid
-share/falconseyedir/sound/ambient2.mid
-share/falconseyedir/sound/ascended.mid
-share/falconseyedir/sound/battle1.mid
-share/falconseyedir/sound/battle2.mid
-share/falconseyedir/sound/bell.raw
-share/falconseyedir/sound/cat.raw
-share/falconseyedir/sound/cldoor.raw
-share/falconseyedir/sound/counting.raw
-share/falconseyedir/sound/died.mid
-share/falconseyedir/sound/dog.raw
-share/falconseyedir/sound/earthcav.mid
-share/falconseyedir/sound/firecave.mid
-share/falconseyedir/sound/fountain.raw
-share/falconseyedir/sound/intro.mid
-share/falconseyedir/sound/lament1.mid
-share/falconseyedir/sound/lament2.mid
-share/falconseyedir/sound/levelup.mid
-share/falconseyedir/sound/levelup.raw
-share/falconseyedir/sound/lion.raw
-share/falconseyedir/sound/mines.mid
-share/falconseyedir/sound/nethack.mid
-share/falconseyedir/sound/opdoor.raw
-share/falconseyedir/sound/oracle.mid
-share/falconseyedir/sound/quit.mid
-share/falconseyedir/sound/roar.raw
-share/falconseyedir/sound/shopping.mid
-share/falconseyedir/sound/swordhit.raw
-share/falconseyedir/sound/swordmis.raw
-share/falconseyedir/sound/town.mid
-share/falconseyedir/sound/walk.raw
-share/falconseyedir/sound/watercav.mid
-share/falconseyedir/tower1.lev
-share/falconseyedir/tower2.lev
-share/falconseyedir/tower3.lev
-share/falconseyedir/valley.lev
-share/falconseyedir/water.lev
-share/falconseyedir/wizard1.lev
-share/falconseyedir/wizard2.lev
-share/falconseyedir/wizard3.lev
-share/falconseyedir/wizhelp
man/man6/falconseye.6.gz
man/man6/frecover.6.gz
-share/falconseyedir/falconseye
-@exec install -g games -m 0664 /dev/null %B/logfile
-@exec install -g games -m 0664 /dev/null %B/perm
-@exec install -g games -m 0664 /dev/null %B/record
-@unexec rm -f %B/logfile %B/perm %B/record %B/jtp_log.txt
-@exec install -d -g games -m 0575 %B/save
-@unexec rm -rf %B/save
-@dirrm share/falconseyedir/sound
-@dirrm share/falconseyedir/manual
-@dirrm share/falconseyedir/graphics
-@dirrm share/falconseyedir/config
-@dirrm share/falconseyedir
+%%DATADIR%%/Arc-fila.lev
+%%DATADIR%%/Arc-filb.lev
+%%DATADIR%%/Arc-goal.lev
+%%DATADIR%%/Arc-loca.lev
+%%DATADIR%%/Arc-strt.lev
+%%DATADIR%%/Bar-fila.lev
+%%DATADIR%%/Bar-filb.lev
+%%DATADIR%%/Bar-goal.lev
+%%DATADIR%%/Bar-loca.lev
+%%DATADIR%%/Bar-strt.lev
+%%DATADIR%%/Cav-fila.lev
+%%DATADIR%%/Cav-filb.lev
+%%DATADIR%%/Cav-goal.lev
+%%DATADIR%%/Cav-loca.lev
+%%DATADIR%%/Cav-strt.lev
+%%DATADIR%%/Hea-fila.lev
+%%DATADIR%%/Hea-filb.lev
+%%DATADIR%%/Hea-goal.lev
+%%DATADIR%%/Hea-loca.lev
+%%DATADIR%%/Hea-strt.lev
+%%DATADIR%%/Kni-fila.lev
+%%DATADIR%%/Kni-filb.lev
+%%DATADIR%%/Kni-goal.lev
+%%DATADIR%%/Kni-loca.lev
+%%DATADIR%%/Kni-strt.lev
+%%DATADIR%%/Mon-fila.lev
+%%DATADIR%%/Mon-filb.lev
+%%DATADIR%%/Mon-goal.lev
+%%DATADIR%%/Mon-loca.lev
+%%DATADIR%%/Mon-strt.lev
+%%DATADIR%%/Pri-fila.lev
+%%DATADIR%%/Pri-filb.lev
+%%DATADIR%%/Pri-goal.lev
+%%DATADIR%%/Pri-loca.lev
+%%DATADIR%%/Pri-strt.lev
+%%DATADIR%%/Ran-fila.lev
+%%DATADIR%%/Ran-filb.lev
+%%DATADIR%%/Ran-goal.lev
+%%DATADIR%%/Ran-loca.lev
+%%DATADIR%%/Ran-strt.lev
+%%DATADIR%%/Rog-fila.lev
+%%DATADIR%%/Rog-filb.lev
+%%DATADIR%%/Rog-goal.lev
+%%DATADIR%%/Rog-loca.lev
+%%DATADIR%%/Rog-strt.lev
+%%DATADIR%%/Sam-fila.lev
+%%DATADIR%%/Sam-filb.lev
+%%DATADIR%%/Sam-goal.lev
+%%DATADIR%%/Sam-loca.lev
+%%DATADIR%%/Sam-strt.lev
+%%DATADIR%%/Tou-fila.lev
+%%DATADIR%%/Tou-filb.lev
+%%DATADIR%%/Tou-goal.lev
+%%DATADIR%%/Tou-loca.lev
+%%DATADIR%%/Tou-strt.lev
+%%DATADIR%%/Val-fila.lev
+%%DATADIR%%/Val-filb.lev
+%%DATADIR%%/Val-goal.lev
+%%DATADIR%%/Val-loca.lev
+%%DATADIR%%/Val-strt.lev
+%%DATADIR%%/Wiz-fila.lev
+%%DATADIR%%/Wiz-filb.lev
+%%DATADIR%%/Wiz-goal.lev
+%%DATADIR%%/Wiz-loca.lev
+%%DATADIR%%/Wiz-strt.lev
+%%DATADIR%%/air.lev
+%%DATADIR%%/asmodeus.lev
+%%DATADIR%%/astral.lev
+%%DATADIR%%/baalz.lev
+%%DATADIR%%/bigrm-1.lev
+%%DATADIR%%/bigrm-2.lev
+%%DATADIR%%/bigrm-3.lev
+%%DATADIR%%/bigrm-4.lev
+%%DATADIR%%/bigrm-5.lev
+%%DATADIR%%/castle.lev
+%%DATADIR%%/cmdhelp
+%%DATADIR%%/config/jtp_intr.txt
+%%DATADIR%%/config/jtp_keys.txt
+%%DATADIR%%/config/jtp_lit1.dat
+%%DATADIR%%/config/jtp_opts.txt
+%%DATADIR%%/config/jtp_snds.txt
+%%DATADIR%%/data
+%%DATADIR%%/defaults.nh
+%%DATADIR%%/dungeon
+%%DATADIR%%/earth.lev
+%%DATADIR%%/fakewiz1.lev
+%%DATADIR%%/fakewiz2.lev
+@(,games,2555) %%DATADIR%%/falconseye
+%%DATADIR%%/fire.lev
+%%DATADIR%%/graphics/backpac5.pcx
+%%DATADIR%%/graphics/book1.pcx
+%%DATADIR%%/graphics/book2.pcx
+%%DATADIR%%/graphics/cairn.pcx
+%%DATADIR%%/graphics/chargen2.pcx
+%%DATADIR%%/graphics/dawn.pcx
+%%DATADIR%%/graphics/dreams.pcx
+%%DATADIR%%/graphics/entrance.pcx
+%%DATADIR%%/graphics/jtp_cm07.pcx
+%%DATADIR%%/graphics/jtp_cm08.pcx
+%%DATADIR%%/graphics/jtp_cm09.pcx
+%%DATADIR%%/graphics/jtp_cm12.pcx
+%%DATADIR%%/graphics/jtp_cm13.pcx
+%%DATADIR%%/graphics/jtp_cmb8.pcx
+%%DATADIR%%/graphics/jtp_cmc7.pcx
+%%DATADIR%%/graphics/jtp_mon6.pcx
+%%DATADIR%%/graphics/jtp_mon7.pcx
+%%DATADIR%%/graphics/jtp_mou5.pcx
+%%DATADIR%%/graphics/jtp_mwi4.pcx
+%%DATADIR%%/graphics/jtp_nh_1.pcx
+%%DATADIR%%/graphics/jtp_obj1.pcx
+%%DATADIR%%/graphics/jtp_obj2.pcx
+%%DATADIR%%/graphics/jtp_st10.pcx
+%%DATADIR%%/graphics/jtp_win1.pcx
+%%DATADIR%%/graphics/mandolin.pcx
+%%DATADIR%%/graphics/menuchr2.pcx
+%%DATADIR%%/graphics/micons2.pcx
+%%DATADIR%%/graphics/night.pcx
+%%DATADIR%%/graphics/quitgame.pcx
+%%DATADIR%%/graphics/stairway.pcx
+%%DATADIR%%/graphics/ttipchr1.pcx
+%%DATADIR%%/graphics/valley.pcx
+%%DATADIR%%/graphics/walls02a.pcx
+%%DATADIR%%/graphics/walls02b.pcx
+%%DATADIR%%/graphics/walls02c.pcx
+%%DATADIR%%/graphics/walls03a.pcx
+%%DATADIR%%/graphics/walls03b.pcx
+%%DATADIR%%/graphics/walls03c.pcx
+%%DATADIR%%/graphics/yendor.pcx
+%%DATADIR%%/help
+%%DATADIR%%/hh
+%%DATADIR%%/history
+%%DATADIR%%/juiblex.lev
+%%DATADIR%%/knox.lev
+%%DATADIR%%/license
+@(,games,664) %%DATADIR%%/logfile
+%%DATADIR%%/manual/arrows1.jpg
+%%DATADIR%%/manual/arrows2.jpg
+%%DATADIR%%/manual/buttonpanel.jpg
+%%DATADIR%%/manual/char_arc.jpg
+%%DATADIR%%/manual/char_kni.jpg
+%%DATADIR%%/manual/char_pri.jpg
+%%DATADIR%%/manual/char_ran.jpg
+%%DATADIR%%/manual/char_rog.jpg
+%%DATADIR%%/manual/char_tou.jpg
+%%DATADIR%%/manual/char_val.jpg
+%%DATADIR%%/manual/char_wiz.jpg
+%%DATADIR%%/manual/contextmenu.jpg
+%%DATADIR%%/manual/dng_door.jpg
+%%DATADIR%%/manual/dng_strs.jpg
+%%DATADIR%%/manual/giantant.jpg
+%%DATADIR%%/manual/index.html
+%%DATADIR%%/manual/letter_a.jpg
+%%DATADIR%%/manual/letter_c.jpg
+%%DATADIR%%/manual/letter_m.jpg
+%%DATADIR%%/manual/letter_n.jpg
+%%DATADIR%%/manual/letter_o.jpg
+%%DATADIR%%/manual/letter_r.jpg
+%%DATADIR%%/manual/letter_t.jpg
+%%DATADIR%%/manual/letter_w.jpg
+%%DATADIR%%/manual/letter_y.jpg
+%%DATADIR%%/manual/main.html
+%%DATADIR%%/manual/main_10.html
+%%DATADIR%%/manual/main_11.html
+%%DATADIR%%/manual/main_12.html
+%%DATADIR%%/manual/main_2.html
+%%DATADIR%%/manual/main_3.html
+%%DATADIR%%/manual/main_4.html
+%%DATADIR%%/manual/main_5.html
+%%DATADIR%%/manual/main_6.html
+%%DATADIR%%/manual/main_7.html
+%%DATADIR%%/manual/main_8.html
+%%DATADIR%%/manual/main_9.html
+%%DATADIR%%/manual/mapwindow.jpg
+%%DATADIR%%/manual/minimap.jpg
+%%DATADIR%%/manual/navbar.html
+%%DATADIR%%/manual/nhisomet.jpg
+%%DATADIR%%/manual/nhmanual.css
+%%DATADIR%%/manual/nhnavlog.jpg
+%%DATADIR%%/manual/obj_food.jpg
+%%DATADIR%%/manual/obj_gem.jpg
+%%DATADIR%%/manual/obj_potion.jpg
+%%DATADIR%%/manual/obj_ring.jpg
+%%DATADIR%%/manual/obj_scroll.jpg
+%%DATADIR%%/manual/obj_sword.jpg
+%%DATADIR%%/manual/paper1.jpg
+%%DATADIR%%/manual/scrollrun.jpg
+%%DATADIR%%/manual/statusbar.jpg
+%%DATADIR%%/manual/valley.jpg
+%%DATADIR%%/manual/wallstyle_full.jpg
+%%DATADIR%%/manual/wallstyle_halfheight.jpg
+%%DATADIR%%/manual/wallstyle_transparent.jpg
+%%DATADIR%%/medusa-1.lev
+%%DATADIR%%/medusa-2.lev
+%%DATADIR%%/minefill.lev
+%%DATADIR%%/minend-1.lev
+%%DATADIR%%/minend-2.lev
+%%DATADIR%%/minetn-1.lev
+%%DATADIR%%/minetn-2.lev
+%%DATADIR%%/nethack.ico
+%%DATADIR%%/opthelp
+%%DATADIR%%/options
+%%DATADIR%%/oracle.lev
+%%DATADIR%%/oracles
+%%DATADIR%%/orcus.lev
+@(,games,664) %%DATADIR%%/perm
+%%DATADIR%%/quest.dat
+@(,games,664) %%DATADIR%%/record
+%%DATADIR%%/rumors
+%%DATADIR%%/sanctum.lev
+%%DATADIR%%/soko1-1.lev
+%%DATADIR%%/soko1-2.lev
+%%DATADIR%%/soko2-1.lev
+%%DATADIR%%/soko2-2.lev
+%%DATADIR%%/soko3-1.lev
+%%DATADIR%%/soko3-2.lev
+%%DATADIR%%/soko4-1.lev
+%%DATADIR%%/soko4-2.lev
+%%DATADIR%%/sound/aircaves.mid
+%%DATADIR%%/sound/ambient1.mid
+%%DATADIR%%/sound/ambient2.mid
+%%DATADIR%%/sound/ascended.mid
+%%DATADIR%%/sound/battle1.mid
+%%DATADIR%%/sound/battle2.mid
+%%DATADIR%%/sound/bell.raw
+%%DATADIR%%/sound/cat.raw
+%%DATADIR%%/sound/cldoor.raw
+%%DATADIR%%/sound/counting.raw
+%%DATADIR%%/sound/died.mid
+%%DATADIR%%/sound/dog.raw
+%%DATADIR%%/sound/earthcav.mid
+%%DATADIR%%/sound/firecave.mid
+%%DATADIR%%/sound/fountain.raw
+%%DATADIR%%/sound/intro.mid
+%%DATADIR%%/sound/lament1.mid
+%%DATADIR%%/sound/lament2.mid
+%%DATADIR%%/sound/levelup.mid
+%%DATADIR%%/sound/levelup.raw
+%%DATADIR%%/sound/lion.raw
+%%DATADIR%%/sound/mines.mid
+%%DATADIR%%/sound/nethack.mid
+%%DATADIR%%/sound/opdoor.raw
+%%DATADIR%%/sound/oracle.mid
+%%DATADIR%%/sound/quit.mid
+%%DATADIR%%/sound/roar.raw
+%%DATADIR%%/sound/shopping.mid
+%%DATADIR%%/sound/swordhit.raw
+%%DATADIR%%/sound/swordmis.raw
+%%DATADIR%%/sound/town.mid
+%%DATADIR%%/sound/walk.raw
+%%DATADIR%%/sound/watercav.mid
+%%DATADIR%%/tower1.lev
+%%DATADIR%%/tower2.lev
+%%DATADIR%%/tower3.lev
+%%DATADIR%%/valley.lev
+%%DATADIR%%/water.lev
+%%DATADIR%%/wizard1.lev
+%%DATADIR%%/wizard2.lev
+%%DATADIR%%/wizard3.lev
+%%DATADIR%%/wizhelp
+@dir(,games,575) %%DATADIR%%/save
+@unexec rm -f %D/%%DATADIR%%/logfile %D/%%DATADIR%%/perm %D/%%DATADIR%%/record %D/%%DATADIR%%/jtp_log.txt
+@unexec rm -rf %D/%%DATADIR%%/save