summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2024-02-24 11:46:06 +0300
committerGleb Popov <arrowd@FreeBSD.org>2024-02-24 11:46:31 +0300
commitb10b5eaba2f20b96afa5ff129d759a9e62d7fb52 (patch)
treef41422bb826f875d1b8911c8c423ea642fd5cd2a
parent36c21f98ff445e373ab61726ee8b64e02f8984f7 (diff)
downloadfreebsd-ports-b10b5eaba2f20b96afa5ff129d759a9e62d7fb52.zip
benchmarks/ttcp: Simplify Makefile
PR: 276759
-rw-r--r--benchmarks/ttcp/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/benchmarks/ttcp/Makefile b/benchmarks/ttcp/Makefile
index 32a074aa304f..1b9fdb08e70f 100644
--- a/benchmarks/ttcp/Makefile
+++ b/benchmarks/ttcp/Makefile
@@ -12,13 +12,10 @@ LICENSE= BSD0CLAUSE
CFLAGS+= -Wno-strict-prototypes
PLIST_FILES= bin/ttcp share/man/man1/ttcp.1.gz
-PORTDOCS_PLIST_FILES= share/doc/ttcp/README share/doc/ttcp/CHANGES \
- share/doc/ttcp/LICENSE
PORTDOCS= README CHANGES LICENSE
OPTIONS_DEFINE= DOCS
-# because the ports framework doesn't cope well with bare ${PORTNAME} ${WRKSRC}
-post-extract:
- ${MV} ${WRKDIR}/${PORTNAME} ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
do-build:
${CC} ${CFLAGS} -o ${WRKSRC}/ttcp ${WRKSRC}/ttcp.c