summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2000-03-11 15:04:12 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2000-03-11 15:04:12 +0000
commitb0ac72ef1842d79ae834a393f596b627a44ed127 (patch)
tree58b7bd3a07d5abaa848045e0fcd2f63b6d7c85fb
parent32c28780d6058ff95d116fb6f2fd484063c46298 (diff)
downloadfreebsd-ports-b0ac72ef1842d79ae834a393f596b627a44ed127.zip
IP Stack Integrity Checker
Its purpose is to test the stability of an IP Stack and its component stacks (TCP, UDP, ICMP et. al.) It does this be generating random packets of the desired protocol. PR: 16976 Submitted by: Brad Hendrickse <bradh@uunet.co.za>
-rw-r--r--net-mgmt/isic/Makefile20
-rw-r--r--net-mgmt/isic/distinfo1
-rw-r--r--net-mgmt/isic/pkg-comment1
-rw-r--r--net-mgmt/isic/pkg-descr14
-rw-r--r--net-mgmt/isic/pkg-plist5
-rw-r--r--net/isic/Makefile20
-rw-r--r--net/isic/distinfo1
-rw-r--r--net/isic/pkg-comment1
-rw-r--r--net/isic/pkg-descr14
-rw-r--r--net/isic/pkg-plist5
10 files changed, 82 insertions, 0 deletions
diff --git a/net-mgmt/isic/Makefile b/net-mgmt/isic/Makefile
new file mode 100644
index 000000000000..25eab79242ca
--- /dev/null
+++ b/net-mgmt/isic/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: isic
+# Version required: 0.05
+# Date created: 25 February 2000
+# Whom: Brad Hendrickse <bradh@uunet.co.za>
+#
+# $FreeBSD$
+#
+
+DISTNAME= isic-0.05
+CATEGORIES= net
+MASTER_SITES= http://expert.cc.purdue.edu/~frantzen/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= bradh@uunet.co.za
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/isic/distinfo b/net-mgmt/isic/distinfo
new file mode 100644
index 000000000000..b638a5b32d6b
--- /dev/null
+++ b/net-mgmt/isic/distinfo
@@ -0,0 +1 @@
+MD5 (isic-0.05.tgz) = da75f4ff2b78477396b0ab30fbdbb616
diff --git a/net-mgmt/isic/pkg-comment b/net-mgmt/isic/pkg-comment
new file mode 100644
index 000000000000..3e352a228b5f
--- /dev/null
+++ b/net-mgmt/isic/pkg-comment
@@ -0,0 +1 @@
+IP Stack Integrity Checker
diff --git a/net-mgmt/isic/pkg-descr b/net-mgmt/isic/pkg-descr
new file mode 100644
index 000000000000..fdef77e362ef
--- /dev/null
+++ b/net-mgmt/isic/pkg-descr
@@ -0,0 +1,14 @@
+IP Stack Integrity Checker
+
+Its purpose is to test the stability of an IP Stack and its component stacks
+(TCP, UDP, ICMP et. al.) It does this be generating random packets of the
+desired protocol. The packets can have tendancies. ie by default all packets
+have a 50% chance of having IP Options. The packets are then sent against the
+target machine to either penetrate its firewall rules or find bugs in the IP
+stack.
+
+WWW: http://expert.cc.purdue.edu/~frantzen/
+
+--
+Brad Hendrickse
+bradh@uunet.co.za
diff --git a/net-mgmt/isic/pkg-plist b/net-mgmt/isic/pkg-plist
new file mode 100644
index 000000000000..4ab4bf83b0a0
--- /dev/null
+++ b/net-mgmt/isic/pkg-plist
@@ -0,0 +1,5 @@
+bin/isic
+bin/tcpsic
+bin/udpsic
+bin/icmpsic
+bin/esic
diff --git a/net/isic/Makefile b/net/isic/Makefile
new file mode 100644
index 000000000000..25eab79242ca
--- /dev/null
+++ b/net/isic/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: isic
+# Version required: 0.05
+# Date created: 25 February 2000
+# Whom: Brad Hendrickse <bradh@uunet.co.za>
+#
+# $FreeBSD$
+#
+
+DISTNAME= isic-0.05
+CATEGORIES= net
+MASTER_SITES= http://expert.cc.purdue.edu/~frantzen/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= bradh@uunet.co.za
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/net/isic/distinfo b/net/isic/distinfo
new file mode 100644
index 000000000000..b638a5b32d6b
--- /dev/null
+++ b/net/isic/distinfo
@@ -0,0 +1 @@
+MD5 (isic-0.05.tgz) = da75f4ff2b78477396b0ab30fbdbb616
diff --git a/net/isic/pkg-comment b/net/isic/pkg-comment
new file mode 100644
index 000000000000..3e352a228b5f
--- /dev/null
+++ b/net/isic/pkg-comment
@@ -0,0 +1 @@
+IP Stack Integrity Checker
diff --git a/net/isic/pkg-descr b/net/isic/pkg-descr
new file mode 100644
index 000000000000..fdef77e362ef
--- /dev/null
+++ b/net/isic/pkg-descr
@@ -0,0 +1,14 @@
+IP Stack Integrity Checker
+
+Its purpose is to test the stability of an IP Stack and its component stacks
+(TCP, UDP, ICMP et. al.) It does this be generating random packets of the
+desired protocol. The packets can have tendancies. ie by default all packets
+have a 50% chance of having IP Options. The packets are then sent against the
+target machine to either penetrate its firewall rules or find bugs in the IP
+stack.
+
+WWW: http://expert.cc.purdue.edu/~frantzen/
+
+--
+Brad Hendrickse
+bradh@uunet.co.za
diff --git a/net/isic/pkg-plist b/net/isic/pkg-plist
new file mode 100644
index 000000000000..4ab4bf83b0a0
--- /dev/null
+++ b/net/isic/pkg-plist
@@ -0,0 +1,5 @@
+bin/isic
+bin/tcpsic
+bin/udpsic
+bin/icmpsic
+bin/esic