summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-02-08 14:18:50 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-02-08 14:18:50 +0000
commitae21656d2ccad7bea8bc26247ee4ddb87601ae02 (patch)
tree67fa2ad301491d7eb3a54ec97b346e507e2b8dc6
parent02dbedfbfbe2087e253f5e10647d5c5e3bed1daf (diff)
downloadfreebsd-ports-ae21656d2ccad7bea8bc26247ee4ddb87601ae02.zip
- Add stage support
-rw-r--r--ftp/jftp/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/ftp/jftp/Makefile b/ftp/jftp/Makefile
index 5271a299e181..478126881261 100644
--- a/ftp/jftp/Makefile
+++ b/ftp/jftp/Makefile
@@ -25,10 +25,9 @@ PLIST_DIRS= %%DATADIR%%
PLIST_FILES= bin/jftp %%DATADIR%%/jftp.jar
SUB_FILES= jftp.sh
-NO_STAGE= yes
do-install:
- ${MKDIR} ${DATADIR}/
- ${INSTALL_SCRIPT} ${WRKDIR}/jftp.sh ${PREFIX}/bin/jftp
- ${INSTALL_DATA} ${WRKSRC}/build/jars/jftp.jar ${DATADIR}/
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/jftp.sh ${STAGEDIR}${PREFIX}/bin/jftp
+ ${INSTALL_DATA} ${WRKSRC}/build/jars/jftp.jar ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>