summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-23 16:18:45 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-23 16:18:45 +0000
commita7c31bfbbb13085a42dd88f97a7ea4abd1ba5235 (patch)
tree30ae81bd7106673658115c12fdbfa2fe80b511e4
parent464b717938ae279f9b72362c9317cea185a404dd (diff)
downloadfreebsd-ports-a7c31bfbbb13085a42dd88f97a7ea4abd1ba5235.zip
- Add NO_ARCH
- Switch to options helpers - Silence post-patch - Switch to plist owner/perm handling, fixing build from non-root PR: 203565 Submitted by: amdmi3 Approved by: maintainer timeout (lwhsu, 2 weeks)
-rw-r--r--www/webgrind/Makefile14
-rw-r--r--www/webgrind/pkg-plist16
2 files changed, 16 insertions, 14 deletions
diff --git a/www/webgrind/Makefile b/www/webgrind/Makefile
index 8c8c9d5d43fb..4077e857a343 100644
--- a/www/webgrind/Makefile
+++ b/www/webgrind/Makefile
@@ -21,22 +21,20 @@ SNAPSHOT= 20140207
USE_PHP= yes
NO_BUILD= yes
+NO_ARCH= yes
-.include <bsd.port.options.mk>
+PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
-.if ${PORT_OPTIONS:MCALLGRAPH}
-USES+= python
-RUN_DEPENDS+= dot:${PORTSDIR}/graphics/graphviz
-.endif
+CALLGRAPH_USES= python
+CALLGRAPH_RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
-post-patch:
- ${REINPLACE_CMD} -e 's,/usr/bin/python,/usr/local/bin/python,' ${WRKSRC}/config.php
+post-patch-CALLGRAPH-on:
+ @${REINPLACE_CMD} -e 's,/usr/bin/python,${PYTHON_CMD},' ${WRKSRC}/config.php
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}
(cd ${WRKSRC}/ && ${COPYTREE_SHARE} "*" ${STAGEDIR}${WWWDIR} "! -name *.bak")
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${WWWDIR}
@${FIND} ${STAGEDIR}${WWWDIR} -type f -exec ${CHMOD} 0444 {} \;
@${FIND} ${STAGEDIR}${WWWDIR} -type d -exec ${CHMOD} 0755 {} \;
diff --git a/www/webgrind/pkg-plist b/www/webgrind/pkg-plist
index 1d7d63300aac..23380e7c47ad 100644
--- a/www/webgrind/pkg-plist
+++ b/www/webgrind/pkg-plist
@@ -1,3 +1,5 @@
+@owner %%WWWOWN%%
+@group %%WWWGRP%%
%%WWWDIR%%/README.md
%%WWWDIR%%/config.php
%%WWWDIR%%/img/asc.gif
@@ -38,9 +40,11 @@
%%WWWDIR%%/styles/style.css
%%WWWDIR%%/templates/fileviewer.phtml
%%WWWDIR%%/templates/index.phtml
-@dirrm %%WWWDIR%%/templates
-@dirrm %%WWWDIR%%/styles
-@dirrm %%WWWDIR%%/library
-@dirrm %%WWWDIR%%/js
-@dirrm %%WWWDIR%%/img
-@dirrm %%WWWDIR%%
+@dir %%WWWDIR%%/templates
+@dir %%WWWDIR%%/styles
+@dir %%WWWDIR%%/library
+@dir %%WWWDIR%%/js
+@dir %%WWWDIR%%/img
+@dir %%WWWDIR%%
+@owner
+@group