summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-02-10 20:22:20 +0000
committerSteve Wills <swills@FreeBSD.org>2014-02-10 20:22:20 +0000
commita7514f82eb7587a7d865d2dc3b6cedd67f772b15 (patch)
treef14ab8fe4edd2202a49d6d8a9f632a277ffb301a
parent0023edddfa8d36abd277ca470dace4db389ab600 (diff)
downloadfreebsd-ports-a7514f82eb7587a7d865d2dc3b6cedd67f772b15.zip
- Fix build when newer gcc which includes a libffi is installed
PR: ports/186468 Submitted by: Jim Ohlstein <jim@ohlste.in>
-rw-r--r--lang/ruby19/Makefile5
-rw-r--r--lang/ruby20/Makefile5
2 files changed, 8 insertions, 2 deletions
diff --git a/lang/ruby19/Makefile b/lang/ruby19/Makefile
index 387450da3aa5..17db8517dcfa 100644
--- a/lang/ruby19/Makefile
+++ b/lang/ruby19/Makefile
@@ -18,9 +18,12 @@ LICENSE= BSD2CLAUSE RUBY
LICENSE_COMB= dual
LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
- libffi.so:${PORTSDIR}/devel/libffi \
libyaml.so:${PORTSDIR}/textproc/libyaml
+# Using LIB_DEPENDS finds the libffi from gcc which causes problems
+BUILD_DEPENDS= libffi>=0:${PORTSDIR}/devel/libffi
+RUN_DEPENDS= libffi>=0:${PORTSDIR}/devel/libffi
+
GNU_CONFIGURE= yes
WRKSRC= ${RUBY_WRKSRC}
CONFIGURE_ARGS= ${RUBY_CONFIGURE_ARGS} \
diff --git a/lang/ruby20/Makefile b/lang/ruby20/Makefile
index d18feedb4ca8..63d1256cba3a 100644
--- a/lang/ruby20/Makefile
+++ b/lang/ruby20/Makefile
@@ -18,9 +18,12 @@ LICENSE= BSD2CLAUSE RUBY
LICENSE_COMB= dual
LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
- libffi.so:${PORTSDIR}/devel/libffi \
libyaml.so:${PORTSDIR}/textproc/libyaml
+# Using LIB_DEPENDS finds the libffi from gcc which causes problems
+BUILD_DEPENDS= libffi>=0:${PORTSDIR}/devel/libffi
+RUN_DEPENDS= libffi>=0:${PORTSDIR}/devel/libffi
+
GNU_CONFIGURE= yes
WRKSRC= ${RUBY_WRKSRC}
CONFIGURE_ARGS= ${RUBY_CONFIGURE_ARGS} \