summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-10-19 20:20:43 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-10-19 20:20:43 +0000
commita4a28c6f7f46703ae531a896dc60743e3cf77b95 (patch)
treecb192a5f453be307b208b24ee0011d76366980cb
parent66c9a990146af687bf79457d9aeebf87ff7fd28d (diff)
downloadfreebsd-ports-a4a28c6f7f46703ae531a896dc60743e3cf77b95.zip
- Use USES=localbase
- Strip shared library - Bump PORTREVISION for package change
-rw-r--r--math/p5-Math-GMPz/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/math/p5-Math-GMPz/Makefile b/math/p5-Math-GMPz/Makefile
index 0a952f1b2f0f..6a91b24150f2 100644
--- a/math/p5-Math-GMPz/Makefile
+++ b/math/p5-Math-GMPz/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Math-GMPz
PORTVERSION= 0.40
+PORTREVISION= 1
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -17,8 +18,12 @@ LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
TEST_DEPENDS= p5-Math-GMP>=0:${PORTSDIR}/math/p5-Math-GMP \
p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
-CONFIGURE_ARGS= INC=-I${LOCALBASE}/include LIBS="-L${LOCALBASE}/lib -lgmp"
USE_PERL5= configure
-USES= perl5
+USES= localbase perl5
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Math/GMPz/GMPz.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Math/GMPz/Random/Random.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Math/GMPz/V/V.so
.include <bsd.port.mk>