summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2014-01-27 03:41:33 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2014-01-27 03:41:33 +0000
commita0f2a563638f3476de197a042550d8ba9aaaecf9 (patch)
treea13e13dc4eea05790ef0c33706329390266bcd2b
parent8406ec7127173ef54f128db8adfd33bee877a899 (diff)
downloadfreebsd-ports-a0f2a563638f3476de197a042550d8ba9aaaecf9.zip
- New port math/octave-forge-image-acquisition.
The octave-forge package is the result of The GNU Octave Repositry project, which is intended to be a central location for custom scripts, functions and extensions for GNU Octave. contains the source for all the functions plus build and install scripts. This is image-acquisition.
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-image-acquisition/Makefile32
-rw-r--r--math/octave-forge-image-acquisition/distinfo2
-rw-r--r--math/octave-forge-image-acquisition/pkg-descr12
-rw-r--r--math/octave-forge-image-acquisition/pkg-plist1
5 files changed, 48 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index a4532545d660..7f08bdf7f241 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -306,6 +306,7 @@
SUBDIR += octave-forge-gsl
SUBDIR += octave-forge-ident
SUBDIR += octave-forge-image
+ SUBDIR += octave-forge-image-acquisition
SUBDIR += octave-forge-informationtheory
SUBDIR += octave-forge-integration
SUBDIR += octave-forge-io
diff --git a/math/octave-forge-image-acquisition/Makefile b/math/octave-forge-image-acquisition/Makefile
new file mode 100644
index 000000000000..3042e51852fb
--- /dev/null
+++ b/math/octave-forge-image-acquisition/Makefile
@@ -0,0 +1,32 @@
+# Created by: Stephen Montgomery-Smith <stephen@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= octave-forge-image-acquisition
+PORTVERSION= 0.1.1
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= v4l2:${PORTSDIR}/multimedia/libv4l \
+ fltk:${PORTSDIR}/x11-toolkits/fltk
+
+GNU_CONFIGURE= yes
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= octave-${OCTAVE_PKGNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ ${RM} -f ${WRKSRC}/../inst/DESCRIPTION
+ ${RM} -f ${WRKSRC}/../inst/ltfat/DESCRIPTION
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>
diff --git a/math/octave-forge-image-acquisition/distinfo b/math/octave-forge-image-acquisition/distinfo
new file mode 100644
index 000000000000..279015ff9503
--- /dev/null
+++ b/math/octave-forge-image-acquisition/distinfo
@@ -0,0 +1,2 @@
+SHA256 (octave-forge/image-acquisition-0.1.1.tar.gz) = 7039e60c8824f15dca2e47f10208c356cb9b1284096839d54d9f1066e320b59d
+SIZE (octave-forge/image-acquisition-0.1.1.tar.gz) = 130208
diff --git a/math/octave-forge-image-acquisition/pkg-descr b/math/octave-forge-image-acquisition/pkg-descr
new file mode 100644
index 000000000000..893ca9bc1a84
--- /dev/null
+++ b/math/octave-forge-image-acquisition/pkg-descr
@@ -0,0 +1,12 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is image-acquisition.
+
+ The Octave-forge Image Aquisition package provides functions to capture
+ images from connected devices. Currently only v4l2 is supported.
+ See also http://wiki.octave.org/Image_acquisition_package
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-image-acquisition/pkg-plist b/math/octave-forge-image-acquisition/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-image-acquisition/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty