summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2015-10-25 20:38:11 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2015-10-25 20:38:11 +0000
commit9c88366292d482a14dc4fc02ac8d77f0a3cedbf7 (patch)
tree9fee0e4fb093921a450365deb65d66c184473241
parentd8c079f57dace71ca9ea7aceb803de0f5ac47083 (diff)
downloadfreebsd-ports-9c88366292d482a14dc4fc02ac8d77f0a3cedbf7.zip
Replace USE_GCC=4.8+ by USE_GCC=yes. Both are equivalent as of today,
and generally we want to use the default version of GCC in cases like these. Approved by: portmgr blanket
-rw-r--r--databases/tarantool/Makefile2
-rw-r--r--dns/dnsdist/Makefile2
-rw-r--r--net-im/telegram/Makefile2
-rw-r--r--www/node/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/databases/tarantool/Makefile b/databases/tarantool/Makefile
index f6f5b152babb..3d3d87b56b9a 100644
--- a/databases/tarantool/Makefile
+++ b/databases/tarantool/Makefile
@@ -15,7 +15,7 @@ LICENSE= BSD2CLAUSE
TR_REV= 130-ge3f2420
MAKE_JOBS_UNSAFE=yes
USES= cmake compiler:c++11-lang gettext gmake perl5 readline
-USE_GCC= 4.8+ # clang bug PR/201270
+USE_GCC= yes # clang bug PR/201270
USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}
SUB_FILES= pkg-message
diff --git a/dns/dnsdist/Makefile b/dns/dnsdist/Makefile
index f4e8b767d41c..af3a2e2470d7 100644
--- a/dns/dnsdist/Makefile
+++ b/dns/dnsdist/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libboost_serialization.so:${PORTSDIR}/devel/boost-libs \
CXXFLAGS+= -D_GLIBCXX_USE_C99
LDFLAGS+= -L${LOCALBASE}/lib -latomic
GNU_CONFIGURE= yes
-USE_GCC= 4.8+
+USE_GCC= yes
USES= bison cpe gmake libtool lua:52 pkgconfig readline tar:bz2
CONFIGURE_ARGS= --enable-libsodium
INSTALL_TARGET= install-strip
diff --git a/net-im/telegram/Makefile b/net-im/telegram/Makefile
index 79b967e2c7c4..29fa9252f8b7 100644
--- a/net-im/telegram/Makefile
+++ b/net-im/telegram/Makefile
@@ -32,7 +32,7 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 1000024
-USE_GCC= 4.8+
+USE_GCC= yes
.endif
post-extract:
diff --git a/www/node/Makefile b/www/node/Makefile
index 50f1010b6efc..fc61994daed1 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -39,7 +39,7 @@ CFLAGS+= -Wno-unused-const-variable
.endif
.else
MAKE_ARGS+= strictaliasing=off
-USE_GCC= 4.8+
+USE_GCC= yes
.endif
post-patch: