summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-02-19 17:59:35 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-02-19 17:59:35 +0000
commit9bef23ecc29dae54905bb65b16a9a12b9755b68d (patch)
treeeae081012bb7ce89aaf16b01813aa97edd0f15f4
parentd97de5c8eaf29f26fe7ef54245d7ca4925f62b60 (diff)
downloadfreebsd-ports-9bef23ecc29dae54905bb65b16a9a12b9755b68d.zip
Clean up USES
With hat: portmgr
-rw-r--r--archivers/py-pyliblzma/Makefile2
-rw-r--r--audio/cplay/Makefile2
-rw-r--r--audio/py-opuslib/Makefile2
-rw-r--r--audio/py-py-jack/Makefile2
-rw-r--r--cad/py-pycam/Makefile2
-rw-r--r--comms/py-gammu/Makefile2
-rw-r--r--databases/ldb15/Makefile2
-rw-r--r--databases/py-riak/Makefile2
-rw-r--r--databases/tdb/Makefile2
-rw-r--r--deskutils/gourmet/Makefile2
-rw-r--r--devel/py-backports_abc/Makefile2
-rw-r--r--devel/py-enum-compat/Makefile2
-rw-r--r--devel/py-enum34/Makefile2
-rw-r--r--devel/py-futures/Makefile2
-rw-r--r--devel/py-llvmcpy/Makefile2
-rw-r--r--devel/py-pathlib/Makefile2
-rw-r--r--devel/py-riak_pb/Makefile2
-rw-r--r--devel/py-selectors2/Makefile2
-rw-r--r--devel/py-selectors34/Makefile2
-rw-r--r--devel/py-should_dsl/Makefile2
-rw-r--r--devel/py-singledispatch/Makefile2
-rw-r--r--devel/py-total-ordering/Makefile2
-rw-r--r--devel/py-typing/Makefile2
-rw-r--r--devel/staf/Makefile2
-rw-r--r--devel/talloc/Makefile2
-rw-r--r--devel/tevent/Makefile2
-rw-r--r--graphics/py-actdiag/Makefile2
-rw-r--r--graphics/py-blockdiag/Makefile2
-rw-r--r--graphics/py-nwdiag/Makefile2
-rw-r--r--graphics/py-seqdiag/Makefile2
-rw-r--r--mail/py-spambayes/Makefile2
-rw-r--r--multimedia/kodi/Makefile2
-rw-r--r--net-mgmt/ccnet-server/Makefile2
-rw-r--r--net-mgmt/seafile-client/Makefile2
-rw-r--r--net-p2p/deluge-cli/Makefile2
-rw-r--r--net-p2p/deluge/Makefile2
-rw-r--r--net/dshell/Makefile2
-rw-r--r--net/py-libnet/Makefile2
-rw-r--r--net/samba410/Makefile2
-rw-r--r--ports-mgmt/portell/Makefile2
-rw-r--r--security/py-backports.ssl_match_hostname/Makefile2
-rw-r--r--sysutils/hatop/Makefile2
-rw-r--r--sysutils/py-ploy_ec2/Makefile2
-rw-r--r--sysutils/py-ploy_fabric/Makefile2
-rw-r--r--sysutils/py-scriptine/Makefile2
-rw-r--r--sysutils/py-shutilwhich/Makefile2
-rw-r--r--sysutils/rdiff-backup/Makefile2
-rw-r--r--textproc/py-esmre/Makefile2
-rw-r--r--textproc/py-zope.app.locales/Makefile2
-rw-r--r--www/geeknote/Makefile2
-rw-r--r--www/py-evernote/Makefile2
-rw-r--r--www/py-goobook/Makefile2
-rw-r--r--www/py-requestbuilder/Makefile2
-rw-r--r--www/py-trello/Makefile2
-rw-r--r--www/seahub/Makefile2
-rw-r--r--www/trac-devel/Makefile2
-rw-r--r--www/trac-ldap/Makefile2
-rw-r--r--www/trac-ldapauthstore/Makefile2
-rw-r--r--www/trac/Makefile2
59 files changed, 59 insertions, 59 deletions
diff --git a/archivers/py-pyliblzma/Makefile b/archivers/py-pyliblzma/Makefile
index 9c6637a83471..3daa71edb9f6 100644
--- a/archivers/py-pyliblzma/Makefile
+++ b/archivers/py-pyliblzma/Makefile
@@ -14,7 +14,7 @@ COMMENT= Python binding for the LZMA compression library
LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= pkgconfig python:-2.7 tar:bzip2
+USES= pkgconfig python:2.7 tar:bzip2
USE_PYTHON= autoplist distutils
post-install:
diff --git a/audio/cplay/Makefile b/audio/cplay/Makefile
index ecab5e149974..e721469d9115 100644
--- a/audio/cplay/Makefile
+++ b/audio/cplay/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
GH_ACCOUNT= hukka
-USES= gettext gmake python:-2.7 shebangfix
+USES= gettext gmake python:2.7 shebangfix
SHEBANG_FILES= ${WRKSRC}/cplay cnq
MAKE_ARGS= PREFIX="${STAGEDIR}${PREFIX}"
diff --git a/audio/py-opuslib/Makefile b/audio/py-opuslib/Makefile
index 7230fec69bd2..f4ecb76f3878 100644
--- a/audio/py-opuslib/Makefile
+++ b/audio/py-opuslib/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libopus.so:audio/opus
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=4.4.1:devel/py-coverage@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}nose>=1.3.7:devel/py-nose@${PY_FLAVOR}
-USES= python:-2.7
+USES= python:2.7
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/audio/py-py-jack/Makefile b/audio/py-py-jack/Makefile
index c2a6c61930b3..4a1ba284791f 100644
--- a/audio/py-py-jack/Makefile
+++ b/audio/py-py-jack/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libjack.so:audio/jack
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>0:math/py-numpy@${PY_FLAVOR}
-USES= python:-2.7 localbase
+USES= python:2.7 localbase
USE_PYTHON= distutils autoplist
post-patch:
diff --git a/cad/py-pycam/Makefile b/cad/py-pycam/Makefile
index da301da71bfd..0998d770ca71 100644
--- a/cad/py-pycam/Makefile
+++ b/cad/py-pycam/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/__init__.py:x11-toolkits/py-gtk2@$
${PYTHON_SITELIBDIR}/OpenGL/__init__.py:graphics/py-PyOpenGL@${PY_FLAVOR} \
${PYTHON_SITELIBDIR}/gtk-2.0/gtk/gdkgl/__init__.py:x11-toolkits/py-gtkglext@${PY_FLAVOR}
-USES= python:-2.7
+USES= python:2.7
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/comms/py-gammu/Makefile b/comms/py-gammu/Makefile
index 5d57d9b48766..8cf486e5d2bb 100644
--- a/comms/py-gammu/Makefile
+++ b/comms/py-gammu/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libGammu.so:comms/gammu
-USES= pkgconfig python:-2.7
+USES= pkgconfig python:2.7
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/databases/ldb15/Makefile b/databases/ldb15/Makefile
index 9ef185c66590..00cb7c1d5556 100644
--- a/databases/ldb15/Makefile
+++ b/databases/ldb15/Makefile
@@ -96,7 +96,7 @@ PLIST_FILES= include/ldb_version.h \
${PKGCONFIGDIR}/ldb.pc
.if defined(NO_PYTHON)
-USES+= python:2.7+,build,test
+USES+= python:build,test
CONFIGURE_ARGS+= --disable-python
.else
USES+= python:3.4+
diff --git a/databases/py-riak/Makefile b/databases/py-riak/Makefile
index b1c4f55080b7..5cdf0206b63c 100644
--- a/databases/py-riak/Makefile
+++ b/databases/py-riak/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}riak_pb>=2.0.0:devel/py-riak_pb@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}openssl>=0.14:security/py-openssl@${PY_FLAVOR}
-USES= python:-2.7
+USES= python:2.7
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/databases/tdb/Makefile b/databases/tdb/Makefile
index 4b3187eccf29..2eff943fb5ce 100644
--- a/databases/tdb/Makefile
+++ b/databases/tdb/Makefile
@@ -57,7 +57,7 @@ PLIST_FILES+= include/tdb.h \
.if defined(NO_PYTHON)
-USES+= python:2.7+,build,test
+USES+= python:build,test
CONFIGURE_ARGS+= --disable-python
.else
USES+= python:3.4+
diff --git a/deskutils/gourmet/Makefile b/deskutils/gourmet/Makefile
index 365861a5897f..9798e4530d83 100644
--- a/deskutils/gourmet/Makefile
+++ b/deskutils/gourmet/Makefile
@@ -30,7 +30,7 @@ OPTIONS_DEFINE= IPYTHON
IPYTHON_DESC= Interactive shell support
IPYTHON_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ipython>0:devel/ipython@${PY_FLAVOR}
-USES= gettext gnome python:-2.7
+USES= gettext gnome python:2.7
USE_GNOME= intltool pygnome2 pygtk2
USE_PYTHON= autoplist distutils
PLIST_FILES+= man/man1/gourmet.1.gz
diff --git a/devel/py-backports_abc/Makefile b/devel/py-backports_abc/Makefile
index af74417cdb43..c72a9c997c95 100644
--- a/devel/py-backports_abc/Makefile
+++ b/devel/py-backports_abc/Makefile
@@ -12,7 +12,7 @@ COMMENT= Backport of recent additions to the 'collections.abc' module
LICENSE= PSFL
-USES= python:-3.4
+USES= python:2.7
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/devel/py-enum-compat/Makefile b/devel/py-enum-compat/Makefile
index fbb7eb332d78..a0b7c63f2a42 100644
--- a/devel/py-enum-compat/Makefile
+++ b/devel/py-enum-compat/Makefile
@@ -11,7 +11,7 @@ COMMENT= Python 3.4 Enum dummy no-op package
LICENSE= MIT
-USES= python:-3.3
+USES= python:2.7
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/devel/py-enum34/Makefile b/devel/py-enum34/Makefile
index bb51def49938..6e8921420115 100644
--- a/devel/py-enum34/Makefile
+++ b/devel/py-enum34/Makefile
@@ -12,7 +12,7 @@ COMMENT= Python 3.4 Enum backported to 3.3, 3.2, 3.1, 2.7
LICENSE= BSD3CLAUSE
-USES?= python:-3.3
+USES= python:2.7
USE_PYTHON= distutils autoplist
OPTIONS_DEFINE= DOCS
diff --git a/devel/py-futures/Makefile b/devel/py-futures/Makefile
index ce1dc5e0aacd..f0076f392473 100644
--- a/devel/py-futures/Makefile
+++ b/devel/py-futures/Makefile
@@ -13,7 +13,7 @@ COMMENT= Backport of the concurrent.futures package from Python 3
LICENSE= PSFL
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:-2.7
+USES= python:2.7
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/devel/py-llvmcpy/Makefile b/devel/py-llvmcpy/Makefile
index 1781bcae7d20..5edd655322d7 100644
--- a/devel/py-llvmcpy/Makefile
+++ b/devel/py-llvmcpy/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= llvm-config${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT} \
${PYTHON_PKGNAMEPREFIX}pycparser>0:devel/py-pycparser@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}shutilwhich>0:sysutils/py-shutilwhich@${PY_FLAVOR}
-USES= python:-3.3 # sysutils/py-shutilwhich has this
+USES= python:2.7 # sysutils/py-shutilwhich has this
USE_GITHUB= yes
GH_ACCOUNT= revng
USE_PYTHON= distutils autoplist
diff --git a/devel/py-pathlib/Makefile b/devel/py-pathlib/Makefile
index a0470567c785..4790b3b65f28 100644
--- a/devel/py-pathlib/Makefile
+++ b/devel/py-pathlib/Makefile
@@ -12,7 +12,7 @@ COMMENT= Python 3.4 pathlib backported to 3.3, 3.2, 3.1, 2.7, 2.6
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= python:-3.3
+USES= python:2.7
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/devel/py-riak_pb/Makefile b/devel/py-riak_pb/Makefile
index a1888a57bdbc..ff45829e2c97 100644
--- a/devel/py-riak_pb/Makefile
+++ b/devel/py-riak_pb/Makefile
@@ -14,7 +14,7 @@ LICENSE= APACHE20
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}protobuf>=2.4.1:devel/py-protobuf@${PY_FLAVOR}
-USES= python:-2.7
+USES= python:2.7
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/devel/py-selectors2/Makefile b/devel/py-selectors2/Makefile
index cc61131264b1..7f95163e12cf 100644
--- a/devel/py-selectors2/Makefile
+++ b/devel/py-selectors2/Makefile
@@ -12,7 +12,7 @@ COMMENT= Backported, durable, and portable I/O selectors for Python
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:-3.3
+USES= python:2.7
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/devel/py-selectors34/Makefile b/devel/py-selectors34/Makefile
index 25d1fc2af96b..5ed441465ce6 100644
--- a/devel/py-selectors34/Makefile
+++ b/devel/py-selectors34/Makefile
@@ -14,7 +14,7 @@ LICENSE= PSFL
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
NO_ARCH= yes
-USES= python:-3.3
+USES= python:2.7
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/devel/py-should_dsl/Makefile b/devel/py-should_dsl/Makefile
index cc064372f9b3..62ab879e3f61 100644
--- a/devel/py-should_dsl/Makefile
+++ b/devel/py-should_dsl/Makefile
@@ -13,7 +13,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
NO_ARCH= yes
-USES= python:-3.2
+USES= python:2.7
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/devel/py-singledispatch/Makefile b/devel/py-singledispatch/Makefile
index d54095e1c722..5e159f65f06a 100644
--- a/devel/py-singledispatch/Makefile
+++ b/devel/py-singledispatch/Makefile
@@ -15,7 +15,7 @@ LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
-USES= python:-3.3
+USES= python:2.7
USE_PYTHON= distutils concurrent autoplist
NO_ARCH= yes
diff --git a/devel/py-total-ordering/Makefile b/devel/py-total-ordering/Makefile
index 0a8708cde573..510945750148 100644
--- a/devel/py-total-ordering/Makefile
+++ b/devel/py-total-ordering/Makefile
@@ -10,7 +10,7 @@ MAINTAINER= truckman@FreeBSD.org
COMMENT= Backport functools.total_ordering to Python 2.x
NO_ARCH= yes
-USES= python:-2.7
+USES= python:2.7
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/devel/py-typing/Makefile b/devel/py-typing/Makefile
index a878d84f0d94..8c6b8d6a5bf6 100644
--- a/devel/py-typing/Makefile
+++ b/devel/py-typing/Makefile
@@ -12,7 +12,7 @@ COMMENT= Type Hints for Python
LICENSE= PSFL
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:-3.4
+USES= python:2.7
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/devel/staf/Makefile b/devel/staf/Makefile
index 168df495d257..0dff77f59249 100644
--- a/devel/staf/Makefile
+++ b/devel/staf/Makefile
@@ -72,7 +72,7 @@ PERL_MAKE_ARGS= PERL_V${PERL_V}_ROOT=${LOCALBASE} \
PERL_V${PERL_V}_INCLUDEDIRS=${LOCALBASE}/lib/perl5/${PERL_VER}/${PERL_ARCH}/CORE \
PERL_BUILD_V${PERL_V}=1
-PYTHON_USES= python:-3.4
+PYTHON_USES= python:2.7
PYTHON_VARS= staf_projects+=python \
use_python=py3kplist
PYTHON_MAKE_ARGS= PYTHON_V${PYTHON_SUFFIX}_ROOT=${LOCALBASE} \
diff --git a/devel/talloc/Makefile b/devel/talloc/Makefile
index 46a22b4b81a5..a11d8c1b36c5 100644
--- a/devel/talloc/Makefile
+++ b/devel/talloc/Makefile
@@ -47,7 +47,7 @@ PLIST_FILES+= include/talloc.h \
${PKGCONFIGDIR}/talloc.pc
.if defined(NO_PYTHON)
-USES+= python:2.7+,build,test
+USES+= python:build,test
CONFIGURE_ARGS+= --disable-python
.else
USES+= python:3.4+
diff --git a/devel/tevent/Makefile b/devel/tevent/Makefile
index d9db9f36cf61..90c3f5cf803e 100644
--- a/devel/tevent/Makefile
+++ b/devel/tevent/Makefile
@@ -53,7 +53,7 @@ PLIST_FILES+= include/tevent.h \
${PKGCONFIGDIR}/tevent.pc
.if defined(NO_PYTHON)
-USES+= python:2.7+,build,test
+USES+= python:build,test
CONFIGURE_ARGS+= --disable-python
.else
USES+= python:3.4+
diff --git a/graphics/py-actdiag/Makefile b/graphics/py-actdiag/Makefile
index 2d6c09f3ec27..4ba90c08bba1 100644
--- a/graphics/py-actdiag/Makefile
+++ b/graphics/py-actdiag/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=2.2.1:graphics/py-pillow@${PY_FLAVOR
${PYTHON_PKGNAMEPREFIX}blockdiag>=1.5.0:graphics/py-blockdiag@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}funcparserlib>=0.3.6:devel/py-funcparserlib@${PY_FLAVOR}
-USES= python:-3.4
+USES= python:2.7
USE_PYTHON= autoplist distutils
DOCSDIR= ${PREFIX}/share/doc/${PKGBASE}
diff --git a/graphics/py-blockdiag/Makefile b/graphics/py-blockdiag/Makefile
index 034f2daa5fae..6ffd1fd37533 100644
--- a/graphics/py-blockdiag/Makefile
+++ b/graphics/py-blockdiag/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=2.2.1:graphics/py-pillow@${PY_FLAVOR
${PYTHON_PKGNAMEPREFIX}funcparserlib>=0.3.6:devel/py-funcparserlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}webcolors>=0:graphics/py-webcolors@${PY_FLAVOR}
-USES= python:-3.4
+USES= python:2.7
USE_PYTHON= autoplist distutils
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
diff --git a/graphics/py-nwdiag/Makefile b/graphics/py-nwdiag/Makefile
index b8ecc15fd609..6c6581932fab 100644
--- a/graphics/py-nwdiag/Makefile
+++ b/graphics/py-nwdiag/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=2.2.1:graphics/py-pillow@${PY_FLAVOR
${PYTHON_PKGNAMEPREFIX}funcparserlib>=0.3.6:devel/py-funcparserlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}blockdiag>=1.5.0:graphics/py-blockdiag@${PY_FLAVOR}
-USES= python:-3.4
+USES= python:2.7
USE_PYTHON= autoplist distutils
DOCSDIR= ${PREFIX}/share/doc/${PKGBASE}
diff --git a/graphics/py-seqdiag/Makefile b/graphics/py-seqdiag/Makefile
index 3ba75e8eafcc..1cd7dcf00150 100644
--- a/graphics/py-seqdiag/Makefile
+++ b/graphics/py-seqdiag/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=2.2.1:graphics/py-pillow@${PY_FLAVOR
${PYTHON_PKGNAMEPREFIX}funcparserlib>=0.3.6:devel/py-funcparserlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}blockdiag>=1.5.0:graphics/py-blockdiag@${PY_FLAVOR}
-USES= python:-3.4
+USES= python:2.7
USE_PYTHON= autoplist distutils
DOCSDIR= ${PREFIX}/share/doc/${PKGBASE}
diff --git a/mail/py-spambayes/Makefile b/mail/py-spambayes/Makefile
index 35a33c261083..679f13f4001b 100644
--- a/mail/py-spambayes/Makefile
+++ b/mail/py-spambayes/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bsddb>0:databases/py-bsddb@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dns>=2.0:dns/py-dns@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}lockfile>=0.2:devel/py-lockfile@${PY_FLAVOR}
-USES= python:-2.7
+USES= python:2.7
USE_PYTHON= distutils autoplist
USE_RC_SUBR= pyspamd
diff --git a/multimedia/kodi/Makefile b/multimedia/kodi/Makefile
index 1e4835283ab9..9a5a30a4c464 100644
--- a/multimedia/kodi/Makefile
+++ b/multimedia/kodi/Makefile
@@ -62,7 +62,7 @@ LIB_DEPENDS= libass.so:multimedia/libass \
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
USES= autoreconf:build compiler:c++11-lib gettext gmake gnome iconv \
- jpeg libtool pkgconfig python:-2.7 ssl
+ jpeg libtool pkgconfig python:2.7 ssl
KODI_ARCH_i386= x86
KODI_ARCH_amd64=x86_64
diff --git a/net-mgmt/ccnet-server/Makefile b/net-mgmt/ccnet-server/Makefile
index 1d0ca9776196..67d2e08d2ab0 100644
--- a/net-mgmt/ccnet-server/Makefile
+++ b/net-mgmt/ccnet-server/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libsearpc.so:devel/libsearpc \
libjansson.so:devel/jansson
USES= autoreconf compiler:c11 gnome libtool localbase mysql:client \
- pathfix pgsql pkgconfig python:-2.7 shebangfix ssl
+ pathfix pgsql pkgconfig python:2.7 shebangfix ssl
USE_GITHUB= yes
GH_ACCOUNT= haiwen
USE_GNOME= glib20
diff --git a/net-mgmt/seafile-client/Makefile b/net-mgmt/seafile-client/Makefile
index 1c8c2a27670c..ab4e32a7c5e8 100644
--- a/net-mgmt/seafile-client/Makefile
+++ b/net-mgmt/seafile-client/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
bash:shells/bash
USES= autoreconf gnome iconv libarchive libtool localbase \
- pathfix pkgconfig python:-2.7 shebangfix sqlite ssl
+ pathfix pkgconfig python:2.7 shebangfix sqlite ssl
USE_GITHUB= yes
GH_ACCOUNT= haiwen
GH_PROJECT= seafile
diff --git a/net-p2p/deluge-cli/Makefile b/net-p2p/deluge-cli/Makefile
index 199d1ca4c9a1..f826d53546c2 100644
--- a/net-p2p/deluge-cli/Makefile
+++ b/net-p2p/deluge-cli/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xdg>=0.18:devel/py-xdg@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
-USES= gettext python:-2.7
+USES= gettext python:2.7
USE_PYTHON= autoplist distutils
USE_GITHUB= yes
GH_ACCOUNT= deluge-torrent
diff --git a/net-p2p/deluge/Makefile b/net-p2p/deluge/Makefile
index 3ddf44d69027..51a9f9061207 100644
--- a/net-p2p/deluge/Makefile
+++ b/net-p2p/deluge/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83:devel/py-dbus@${PY_FLAVOR} \
xdg-utils>=1.0.2:devel/xdg-utils \
deluge:net-p2p/deluge-cli
-USES= gnome metaport python:-2.7
+USES= gnome metaport python:2.7
USE_GNOME= librsvg2 pygtk2
.include <bsd.port.mk>
diff --git a/net/dshell/Makefile b/net/dshell/Makefile
index d9f47cfaae1c..d7d1abcbb41c 100644
--- a/net/dshell/Makefile
+++ b/net/dshell/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= bash:shells/bash \
${PYTHON_PKGNAMEPREFIX}pypcap>0:net/py-pypcap@${PY_FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= python:-2.7 shebangfix
+USES= python:2.7 shebangfix
USE_GITHUB= yes
NO_ARCH= yes
diff --git a/net/py-libnet/Makefile b/net/py-libnet/Makefile
index 9ae5ae591198..7fbbda1afd3f 100644
--- a/net/py-libnet/Makefile
+++ b/net/py-libnet/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libnet.so:net/libnet
-USES= python:-2.7
+USES= python:2.7
USE_PYTHON= autoplist concurrent distutils
OPTIONS_DEFINE= EXAMPLES
diff --git a/net/samba410/Makefile b/net/samba410/Makefile
index a22cdf40d3d4..ce46de425665 100644
--- a/net/samba410/Makefile
+++ b/net/samba410/Makefile
@@ -411,7 +411,7 @@ SAMBA4_MODULES+= auth_skel pdb_test gpext_security gpext_registry gpext_scripts
.endif
# Python bindings
.if defined(NO_PYTHON)
-USES+= python:2.7+,build,test
+USES+= python:build,test
CONFIGURE_ARGS+= --disable-python
PLIST_SUB+= SAMBA4_PYTHON="@comment "
SUB_LIST+= SAMBA4_PYTHON="@comment "
diff --git a/ports-mgmt/portell/Makefile b/ports-mgmt/portell/Makefile
index 51485dc30971..53f702fcb560 100644
--- a/ports-mgmt/portell/Makefile
+++ b/ports-mgmt/portell/Makefile
@@ -12,7 +12,7 @@ COMMENT= Quick display of FreeBSD port descriptions
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bsddb>0:databases/py-bsddb@${PY_FLAVOR}
-USES= python:-2.7 shebangfix zip
+USES= python:2.7 shebangfix zip
SHEBANG_FILES= *.py
NO_BUILD= yes
diff --git a/security/py-backports.ssl_match_hostname/Makefile b/security/py-backports.ssl_match_hostname/Makefile
index b5498e4437ca..e10d76c0fa69 100644
--- a/security/py-backports.ssl_match_hostname/Makefile
+++ b/security/py-backports.ssl_match_hostname/Makefile
@@ -14,7 +14,7 @@ LICENSE= PSFL
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}backports>0:devel/py-backports@${PY_FLAVOR}
-USES= python:-3.4
+USES= python:2.7
USE_PYTHON= autoplist distutils
POST_PLIST= trim-backports-namespace
diff --git a/sysutils/hatop/Makefile b/sysutils/hatop/Makefile
index d99ffa708698..acdac677468d 100644
--- a/sysutils/hatop/Makefile
+++ b/sysutils/hatop/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv3+
RUN_DEPENDS= ${LOCALBASE}/sbin/haproxy:net/haproxy
-USES= python:2.7+ shebangfix
+USES= python shebangfix
SHEBANG_FILES= bin/hatop
NO_BUILD= yes
NO_ARCH= yes
diff --git a/sysutils/py-ploy_ec2/Makefile b/sysutils/py-ploy_ec2/Makefile
index 4b9effa9f4c2..720cf9e7394b 100644
--- a/sysutils/py-ploy_ec2/Makefile
+++ b/sysutils/py-ploy_ec2/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools@${PY_FLAVOR
${PYTHON_PKGNAMEPREFIX}boto>=2.0:devel/py-boto@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}lazy>0:devel/py-lazy@${PY_FLAVOR}
-USES= python:-2.7
+USES= python:2.7
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/sysutils/py-ploy_fabric/Makefile b/sysutils/py-ploy_fabric/Makefile
index bf36305fc447..443bdb80918e 100644
--- a/sysutils/py-ploy_fabric/Makefile
+++ b/sysutils/py-ploy_fabric/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ploy>=1.0.0:sysutils/py-ploy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}fabric1>=1.4.0,1:devel/py-fabric1@${PY_FLAVOR}
-USES= python:-2.7 zip
+USES= python:2.7 zip
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/sysutils/py-scriptine/Makefile b/sysutils/py-scriptine/Makefile
index 9276886edb7e..9bc96312bbe1 100644
--- a/sysutils/py-scriptine/Makefile
+++ b/sysutils/py-scriptine/Makefile
@@ -12,7 +12,7 @@ COMMENT= Python shell scripts made easy
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:-2.7
+USES= python:2.7
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/sysutils/py-shutilwhich/Makefile b/sysutils/py-shutilwhich/Makefile
index ece33045b9aa..78fa6f4833ee 100644
--- a/sysutils/py-shutilwhich/Makefile
+++ b/sysutils/py-shutilwhich/Makefile
@@ -13,7 +13,7 @@ LICENSE= PSFL
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
-USES= python:-3.3
+USES= python:2.7
USE_GITHUB= yes
USE_PYTHON= autoplist distutils
diff --git a/sysutils/rdiff-backup/Makefile b/sysutils/rdiff-backup/Makefile
index f1cdb8c4a8b1..39695044c3cc 100644
--- a/sysutils/rdiff-backup/Makefile
+++ b/sysutils/rdiff-backup/Makefile
@@ -20,7 +20,7 @@ CONFLICTS= rdiff-backup-devel-[0-9]* rdiff-backup-1.0*
PORTSCOUT= limitw:1,even
-USES= python:-2.7
+USES= python:2.7
USE_PYTHON= distutils
USE_LDCONFIG= yes
diff --git a/textproc/py-esmre/Makefile b/textproc/py-esmre/Makefile
index bc0220e76ff1..3a75d8ab4914 100644
--- a/textproc/py-esmre/Makefile
+++ b/textproc/py-esmre/Makefile
@@ -13,7 +13,7 @@ COMMENT= Regular expression accelerator in Python
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= python:-2.7
+USES= python:2.7
USE_PYTHON= autoplist distutils
post-install:
diff --git a/textproc/py-zope.app.locales/Makefile b/textproc/py-zope.app.locales/Makefile
index 43fd64d1df83..e61dff3bd38a 100644
--- a/textproc/py-zope.app.locales/Makefile
+++ b/textproc/py-zope.app.locales/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface@${P
${PYTHON_PKGNAMEPREFIX}zope.tal>=0:textproc/py-zope.tal@${PY_FLAVOR}
NO_ARCH= yes
-USES= python:-2.7
+USES= python:2.7
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/www/geeknote/Makefile b/www/geeknote/Makefile
index a9306b3944e4..393ceaccb197 100644
--- a/www/geeknote/Makefile
+++ b/www/geeknote/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}evernote>=1.17:www/py-evernote@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.0:www/py-beautifulsoup@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}thrift>0:devel/py-thrift@${PY_FLAVOR}
-USES= python:-2.7
+USES= python:2.7
USE_GITHUB= yes
USE_PYTHON= autoplist distutils
diff --git a/www/py-evernote/Makefile b/www/py-evernote/Makefile
index 2268ae810df5..fbf592b6ffaf 100644
--- a/www/py-evernote/Makefile
+++ b/www/py-evernote/Makefile
@@ -15,7 +15,7 @@ LICENSE= BSD2CLAUSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}oauth2>0:net/py-oauth2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}thrift>0:devel/py-thrift@${PY_FLAVOR}
-USES= python:-2.7
+USES= python:2.7
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/www/py-goobook/Makefile b/www/py-goobook/Makefile
index 5752f32b1430..f16c2a3afe11 100644
--- a/www/py-goobook/Makefile
+++ b/www/py-goobook/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}oauth2client>=1.4.12:security/py-oauth2clien
${PYTHON_PKGNAMEPREFIX}httplib2>=0.9.1:www/py-httplib2@${PY_FLAVOR}
NO_ARCH= yes
-USES= python:-2.7
+USES= python:2.7
USE_PYTHON= autoplist distutils
PLIST_FILES= man/man1/goobook.1.gz
diff --git a/www/py-requestbuilder/Makefile b/www/py-requestbuilder/Makefile
index f30ddc72615c..0987316c0b92 100644
--- a/www/py-requestbuilder/Makefile
+++ b/www/py-requestbuilder/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.4:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
-USES= python:-2.7
+USES= python:2.7
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/www/py-trello/Makefile b/www/py-trello/Makefile
index c9c461a47d54..c66740243ef2 100644
--- a/www/py-trello/Makefile
+++ b/www/py-trello/Makefile
@@ -18,7 +18,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0.9.1:www/py-requests@${PY_FLAVOR}
-USES= python:-2.7 zip
+USES= python:2.7 zip
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/www/seahub/Makefile b/www/seahub/Makefile
index 65f72a813e73..9733f00e4d6e 100644
--- a/www/seahub/Makefile
+++ b/www/seahub/Makefile
@@ -35,7 +35,7 @@ RUN_DEPENDS= bash:shells/bash \
${PYTHON_PKGNAMEPREFIX}qrcode>0:textproc/py-qrcode@${PY_FLAVOR} \
${PY_FUTURES}
-USES= gettext-tools:build python:-2.7 shebangfix
+USES= gettext-tools:build python:2.7 shebangfix
USE_GITHUB= yes
GH_ACCOUNT= haiwen
SHEBANG_FILES= *.sh tests/*.sh *.template *.py tools/*.py seahub/*.py
diff --git a/www/trac-devel/Makefile b/www/trac-devel/Makefile
index 10c20e80e5e8..15899271ccfa 100644
--- a/www/trac-devel/Makefile
+++ b/www/trac-devel/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=2.3.4:devel/py-babel@${PY_FLAVOR} \
CONFLICTS_INSTALL= trac
-USES= python:-2.7 shebangfix
+USES= python:2.7 shebangfix
SHEBANG_FILES= trac/tests/functional/better_twill.py trac/tests/functional/tester.py \
trac/tests/functional/testenv.py trac/tests/functional/compat.py \
trac/tests/functional/__init__.py contrib/emailfilter.py \
diff --git a/www/trac-ldap/Makefile b/www/trac-ldap/Makefile
index e1c8d512d95f..2272155f7600 100644
--- a/www/trac-ldap/Makefile
+++ b/www/trac-ldap/Makefile
@@ -20,7 +20,7 @@ NO_ARCH= yes
PORTSCOUT= ignore:1
SVN_REVISION= 15146
-USES= python:-2.7
+USES= python:2.7
USE_PYTHON= distutils autoplist
# Maintainter targets below this point
diff --git a/www/trac-ldapauthstore/Makefile b/www/trac-ldapauthstore/Makefile
index c83ffc439f80..120ec49d25ca 100644
--- a/www/trac-ldapauthstore/Makefile
+++ b/www/trac-ldapauthstore/Makefile
@@ -22,7 +22,7 @@ NO_ARCH= yes
PORTSCOUT= ignore:1
SVN_REVISION= 15146
-USES= python:-2.7
+USES= python:2.7
USE_PYTHON= distutils autoplist
# Maintainter targets below this point
diff --git a/www/trac/Makefile b/www/trac/Makefile
index 832caf15f41a..06a8156b9c1e 100644
--- a/www/trac/Makefile
+++ b/www/trac/Makefile
@@ -23,7 +23,7 @@ CONFLICTS_INSTALL= trac-devel
PORTSCOUT= limit:^1\.2\.[0-9]*
-USES= python:-2.7 shebangfix
+USES= python:2.7 shebangfix
SHEBANG_FILES= trac/tests/functional/better_twill.py trac/tests/functional/tester.py \
trac/tests/functional/testenv.py trac/tests/functional/compat.py \
trac/tests/functional/__init__.py contrib/emailfilter.py \