summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-12-05 20:37:11 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-12-05 20:37:11 +0000
commit9317164fa0e2212a801a87e4cf17af04575ae51f (patch)
tree85488661b885951599d390e6c11b0c6882e61365
parent3cdfc7d574af604a11477b9582efc49d11091578 (diff)
downloadfreebsd-ports-9317164fa0e2212a801a87e4cf17af04575ae51f.zip
New port: devel/p5-PerlIO-via-Timeout
This package implements a PerlIO layer, that adds read / write timeout. This can be useful to avoid blocking while accessing a handle (file, socket, ...), and fail after some time. The timeout is implemented by using <select> on the handle before reading/writing. WARNING the handle won't timeout if you use sysread or syswrite on it, because these functions works at a lower level. However if you're trying to implement a timeout for a socket, see IO::Socket::Timeout that implements exactly that. WWW: http://search.cpan.org/dist/PerlIO-via-Timeout
-rw-r--r--devel/Makefile2
-rw-r--r--devel/p5-PerlIO-via-Timeout/Makefile20
-rw-r--r--devel/p5-PerlIO-via-Timeout/distinfo2
-rw-r--r--devel/p5-PerlIO-via-Timeout/pkg-descr13
-rw-r--r--devel/p5-PerlIO-via-Timeout/pkg-plist4
5 files changed, 40 insertions, 1 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 13b1b37ca034..b71a7a0f8d93 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2887,7 +2887,6 @@
SUBDIR += p5-Perl-Tidy
SUBDIR += p5-Perl-Unsafe-Signals
SUBDIR += p5-Perl-Version
- SUBDIR += p5-Perl-osnames
SUBDIR += p5-Perl4-CoreLibs
SUBDIR += p5-Perl6-Builtins
SUBDIR += p5-Perl6-Export
@@ -2903,6 +2902,7 @@
SUBDIR += p5-PerlIO-locale
SUBDIR += p5-PerlIO-utf8_strict
SUBDIR += p5-PerlIO-via-MD5
+ SUBDIR += p5-PerlIO-via-Timeout
SUBDIR += p5-PerlIO-via-dynamic
SUBDIR += p5-PerlIO-via-symlink
SUBDIR += p5-PerlX-Maybe
diff --git a/devel/p5-PerlIO-via-Timeout/Makefile b/devel/p5-PerlIO-via-Timeout/Makefile
new file mode 100644
index 000000000000..97828471f5dd
--- /dev/null
+++ b/devel/p5-PerlIO-via-Timeout/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= PerlIO-via-Timeout
+PORTVERSION= 0.32
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pi@FreeBSD.org
+COMMENT= PerlIO layer to add read & write timeouts to a handle
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+NO_ARCH= yes
+
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/devel/p5-PerlIO-via-Timeout/distinfo b/devel/p5-PerlIO-via-Timeout/distinfo
new file mode 100644
index 000000000000..a4575618b8fa
--- /dev/null
+++ b/devel/p5-PerlIO-via-Timeout/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PerlIO-via-Timeout-0.32.tar.gz) = 9278f9ef668850d913d98fa4c0d7e7d667cff3503391f4a4eae73a246f2e7916
+SIZE (PerlIO-via-Timeout-0.32.tar.gz) = 13560
diff --git a/devel/p5-PerlIO-via-Timeout/pkg-descr b/devel/p5-PerlIO-via-Timeout/pkg-descr
new file mode 100644
index 000000000000..3184e5a724d8
--- /dev/null
+++ b/devel/p5-PerlIO-via-Timeout/pkg-descr
@@ -0,0 +1,13 @@
+This package implements a PerlIO layer, that adds read / write
+timeout. This can be useful to avoid blocking while accessing a
+handle (file, socket, ...), and fail after some time.
+
+The timeout is implemented by using <select> on the handle before
+reading/writing.
+
+WARNING the handle won't timeout if you use sysread or syswrite on
+it, because these functions works at a lower level. However if
+you're trying to implement a timeout for a socket, see IO::Socket::Timeout
+that implements exactly that.
+
+WWW: http://search.cpan.org/dist/PerlIO-via-Timeout
diff --git a/devel/p5-PerlIO-via-Timeout/pkg-plist b/devel/p5-PerlIO-via-Timeout/pkg-plist
new file mode 100644
index 000000000000..1d458eff0e4d
--- /dev/null
+++ b/devel/p5-PerlIO-via-Timeout/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/PerlIO/via/README.pod
+%%SITE_PERL%%/PerlIO/via/Timeout.pm
+%%PERL5_MAN3%%/PerlIO::via::README.3.gz
+%%PERL5_MAN3%%/PerlIO::via::Timeout.3.gz