summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Grafton <john.grafton@runbox.com>2022-11-23 07:51:40 +0100
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-11-24 17:03:14 +0100
commit9253d1d72ab19f596d075f42552af8c5ce552cc7 (patch)
treea4aa338c2d446ff6f0475ccd74e5cde213ee1994
parentb390a914547a65cf5863f50b623834c5af0aee1a (diff)
downloadfreebsd-ports-9253d1d72ab19f596d075f42552af8c5ce552cc7.zip
x11-wm/jwm: Update to 2.4.3
ChangeLog: https://joewing.net/projects/jwm/ New Features * Mouse bindings are now configurable * Added key bindings * Added ~/.config/jwm/jwmrc as the new default location for per-user configuration * Maximized windows once again have borders and can be resized * The placement of window buttons is now configurable * Restored automatic tray "autohide" functionality using autohide="on" * Added support for CDATA to the XML parser * Moved the group and list attributes to the TaskListStyle tag * Added key bindings to resize a window from a specific corner or side * Add Type tag to Group Bug Fixes * Don't SetDefaultCursor in AddClientToWindow * Use pango to address font fixes * Fix for large titles that are centered or right aligned * Fix tooltip delay Updated Translations * Portuguese * Portuguese Brazil * Turkish * Spanish * Danish * Lithuanian Add UPDATING entry due to config changes. PR: 267931 Reported by: john.grafton@runbox.com (maintainer)
-rw-r--r--UPDATING14
-rw-r--r--x11-wm/jwm/Makefile35
-rw-r--r--x11-wm/jwm/distinfo6
-rw-r--r--x11-wm/jwm/pkg-plist4
4 files changed, 39 insertions, 20 deletions
diff --git a/UPDATING b/UPDATING
index 89581b00adc3..8816cb7b9e06 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,20 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20221123:
+ AFFECTS: x11-wm/jwm
+ AUTHOR: fernape@FreeBSD.org
+
+ jwm 2.4 introduces changes in the configuration. To convert an existing v2.3
+ configuration file using xsltproc, run:
+
+ cp ~/.jwmrc ~/.jwmrc.old
+ xsltproc jwm-2.4.xslt ~/.jwmrc.old > ~/.jwmrc
+
+ If you have multiple configuration files, it may be necessary to apply the
+ XSLT to some or all of them depending on what configuration options are stored
+ in the file.
+
20221017:
AFFECTS: archivers/star
AUTHOR: fernape@FreeBSD.org
diff --git a/x11-wm/jwm/Makefile b/x11-wm/jwm/Makefile
index b6c4e62f7ede..83e178007fee 100644
--- a/x11-wm/jwm/Makefile
+++ b/x11-wm/jwm/Makefile
@@ -1,8 +1,7 @@
PORTNAME= jwm
-PORTVERSION= 2.4.2
-PORTREVISION= 1
+PORTVERSION= 2.4.3
CATEGORIES= x11-wm
-MASTER_SITES= https://github.com/joewing/jwm/releases/download/v${PORTVERSION}/
+MASTER_SITES= https://github.com/joewing/jwm/releases/download/v${PORTVERSION}/
MAINTAINER= john.grafton@gmail.com
COMMENT= Joe's Window Manager
@@ -11,6 +10,12 @@ WWW= https://joewing.net/projects/jwm/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libharfbuzz.so:print/harfbuzz \
+ libglib-2.0.so.0:devel/glib20 \
+ libgobject-2.0.so.0:devel/glib20 \
+ libpango-1.0.so.0:x11-toolkits/pango
+
USES= iconv localbase pkgconfig tar:xz xorg
USE_XORG= x11
GNU_CONFIGURE= yes
@@ -20,44 +25,40 @@ OPTIONS_DEFINE= CAIRO DEBUG FRIBIDI JPEG NLS PNG SVG XEXT XFT \
OPTIONS_DEFAULT= FRIBIDI JPEG PNG XEXT XFT XINERAMA XMU XPM XRENDER
OPTIONS_SUB= yes
+FRIBIDI_DESC= Unicode Bidirectional Algorithm support
+XEXT_DESC= X11 Shape Extension support
+XMU_DESC= X11 Miscellaneous Utilities support
+XRENDER_DESC= X11 Render Extension support
+
CAIRO_USES= gnome
CAIRO_USE= GNOME=cairo
CAIRO_CONFIGURE_ENABLE= cairo
DEBUG_CONFIGURE_ENABLE= debug
-FRIBIDI_DESC= Unicode Bidirectional Algorithm support
FRIBIDI_LIB_DEPENDS= libfribidi.so:converters/fribidi
FRIBIDI_CONFIGURE_ENABLE=fribidi
JPEG_USES= jpeg
JPEG_CONFIGURE_ENABLE= jpeg
-LIB_DEPENDS+=libfontconfig.so:x11-fonts/fontconfig
-LIB_DEPENDS+=libharfbuzz.so:print/harfbuzz
-LIB_DEPENDS+=libglib-2.0.so.0:devel/glib20
-LIB_DEPENDS+=libgobject-2.0.so.0:devel/glib20
-LIB_DEPENDS+=libpango-1.0.so.0:x11-toolkits/pango
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
PNG_LIB_DEPENDS= libpng.so:graphics/png
PNG_CONFIGURE_ENABLE= png
SVG_USE= GNOME=librsvg2
SVG_CONFIGURE_ENABLE= rsvg
-XEXT_DESC= X11 Shape Extension support
XEXT_USE= XORG=xext
XEXT_CONFIGURE_ENABLE= shape
-XFT_USE= XORG=xft
-XFT_CONFIGURE_ENABLE= xft
XFT_IMPLIES= XRENDER
XFT_LIB_DEPENDS= libfreetype.so:print/freetype2
+XFT_USE= XORG=xft
+XFT_CONFIGURE_ENABLE= xft
+XINERAMA_IMPLIES= XEXT
XINERAMA_USE= XORG=xinerama
XINERAMA_CONFIGURE_ENABLE=xinerama
-XINERAMA_IMPLIES= XEXT
-XMU_DESC= X11 Miscellaneous Utilities support
+XMU_IMPLIES= XEXT
XMU_USE= XORG=xmu
XMU_CONFIGURE_ENABLE= xmu
-XMU_IMPLIES= XEXT
+XPM_IMPLIES= XEXT
XPM_USE= XORG=xpm
XPM_CONFIGURE_ENABLE= xpm
-XPM_IMPLIES= XEXT
-XRENDER_DESC= X11 Render Extension support
XRENDER_USE= XORG=xrender
XRENDER_CONFIGURE_ENABLE=xrender
diff --git a/x11-wm/jwm/distinfo b/x11-wm/jwm/distinfo
index a513ab5e7689..a22d49469a9c 100644
--- a/x11-wm/jwm/distinfo
+++ b/x11-wm/jwm/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1656520075
-SHA256 (jwm-2.4.2.tar.xz) = 4e07a21774e9defcdddb3ffaa3e18dfe113dfe168fe0428c5e0da987c95e26e5
-SIZE (jwm-2.4.2.tar.xz) = 316000
+TIMESTAMP = 1669143800
+SHA256 (jwm-2.4.3.tar.xz) = ee3b4ee0c452ef31fcb9303ab50aaf496cf5bdf7b5f1fdc9a1251b7175ca67ab
+SIZE (jwm-2.4.3.tar.xz) = 317192
diff --git a/x11-wm/jwm/pkg-plist b/x11-wm/jwm/pkg-plist
index 514999e3c015..33f9c2290aab 100644
--- a/x11-wm/jwm/pkg-plist
+++ b/x11-wm/jwm/pkg-plist
@@ -4,6 +4,7 @@ man/man1/jwm.1.gz
%%DATADIR%%/jwm-blue.svg
%%DATADIR%%/jwm-gray.svg
%%DATADIR%%/jwm-orange.svg
+%%DATADIR%%/jwm-red.svg
%%DATADIR%%/jwm.xbm
%%NLS%%share/locale/da/LC_MESSAGES/jwm.mo
%%NLS%%share/locale/de/LC_MESSAGES/jwm.mo
@@ -11,10 +12,13 @@ man/man1/jwm.1.gz
%%NLS%%share/locale/fr/LC_MESSAGES/jwm.mo
%%NLS%%share/locale/hu/LC_MESSAGES/jwm.mo
%%NLS%%share/locale/it/LC_MESSAGES/jwm.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/jwm.mo
%%NLS%%share/locale/nl/LC_MESSAGES/jwm.mo
%%NLS%%share/locale/pl/LC_MESSAGES/jwm.mo
%%NLS%%share/locale/pt/LC_MESSAGES/jwm.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/jwm.mo
%%NLS%%share/locale/ru/LC_MESSAGES/jwm.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/jwm.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/jwm.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/jwm.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/jwm.mo