summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2020-05-11 23:39:43 +0000
committerDiane Bruce <db@FreeBSD.org>2020-05-11 23:39:43 +0000
commit91dd9e62375f38dcfa9e2214347d9837b18c8810 (patch)
treea6ec8366cd68314d796d34b3605f0784b14ce240
parent0141c04501caeed12918cdd7cd2b96b5dee7a80f (diff)
downloadfreebsd-ports-91dd9e62375f38dcfa9e2214347d9837b18c8810.zip
- pugixml-1.10 conflicts with libSavitar-4.5.0 on
/usr/local/lib/cmake/pugixml/pugixml-config-release.cmake [1] - I had a TODO in original Makefile to rewrite to use our system pugixml [2] [1] maciej@pasternacki.net [2] db PR: ports/246316
-rw-r--r--devel/libsavitar/Makefile13
-rw-r--r--devel/libsavitar/files/patch-CMakeLists.txt11
-rw-r--r--devel/libsavitar/files/patch-src_MeshData.cpp11
-rw-r--r--devel/libsavitar/files/patch-src_Namespace.cpp11
-rw-r--r--devel/libsavitar/files/patch-src_SceneNode.cpp11
-rw-r--r--devel/libsavitar/pkg-plist1
6 files changed, 49 insertions, 9 deletions
diff --git a/devel/libsavitar/Makefile b/devel/libsavitar/Makefile
index 41a300123716..070e38e27f9d 100644
--- a/devel/libsavitar/Makefile
+++ b/devel/libsavitar/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libSavitar
DISTVERSION= 4.5.0
+PORTREVISION= 1
CATEGORIES= devel cad
DIST_SUBDIR= Ultimaker
@@ -12,19 +13,15 @@ LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sip>0:devel/py-sip@${PY_FLAVOR}
+LIB_DEPENDS= libpugixml.so:textproc/pugixml
USES= cmake compiler:c++11-lang python:3.4+
USE_GITHUB= yes
GH_ACCOUNT= Ultimaker
+USE_GITHUB= yes
GH_TAGNAME= 96eba0e
USE_LDCONFIG= yes
-
-# need this hack so as not to conflict with pugixml
-# XXX TODO rework port to use pugixml instead
-post-install:
- ${RM} ${STAGEDIR}${PREFIX}/include/pugiconfig.hpp
- ${RM} ${STAGEDIR}${PREFIX}/include/pugixml.hpp
- ${RM} ${STAGEDIR}${PREFIX}/lib/cmake/pugixml/pugixml-config.cmake
- ${RM} ${STAGEDIR}${PREFIX}/lib/libpugixml.a
+CFLAGS+= "-I${LOCALBASE}/include"
+LDFLAGS+= "-L${LOCALBASE}/lib"
.include <bsd.port.mk>
diff --git a/devel/libsavitar/files/patch-CMakeLists.txt b/devel/libsavitar/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..350b4f496b75
--- /dev/null
+++ b/devel/libsavitar/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2020-05-11 21:56:56 UTC
++++ CMakeLists.txt
+@@ -15,7 +15,7 @@ if(BUILD_TESTS)
+ find_package(Threads QUIET)
+ endif()
+
+-add_subdirectory(pugixml)
++#add_subdirectory(pugixml)
+
+ if(BUILD_PYTHON)
+ list(APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
diff --git a/devel/libsavitar/files/patch-src_MeshData.cpp b/devel/libsavitar/files/patch-src_MeshData.cpp
new file mode 100644
index 000000000000..9d8a5686dd02
--- /dev/null
+++ b/devel/libsavitar/files/patch-src_MeshData.cpp
@@ -0,0 +1,11 @@
+--- src/MeshData.cpp.orig 2020-05-11 21:53:20 UTC
++++ src/MeshData.cpp
+@@ -17,7 +17,7 @@
+ */
+
+ #include "MeshData.h"
+-#include "../pugixml/src/pugixml.hpp"
++#include <pugixml.hpp>
+ #include <cstring>
+ #include <iostream>
+ #include <stdexcept> //For std::runtime_error.
diff --git a/devel/libsavitar/files/patch-src_Namespace.cpp b/devel/libsavitar/files/patch-src_Namespace.cpp
new file mode 100644
index 000000000000..5da35e038d06
--- /dev/null
+++ b/devel/libsavitar/files/patch-src_Namespace.cpp
@@ -0,0 +1,11 @@
+--- src/Namespace.cpp.orig 2020-05-11 21:53:27 UTC
++++ src/Namespace.cpp
+@@ -3,7 +3,7 @@
+
+ #include "Namespace.h"
+
+-#include "../pugixml/src/pugixml.hpp"
++#include <pugixml.hpp>
+
+ namespace xml_namespace
+ {
diff --git a/devel/libsavitar/files/patch-src_SceneNode.cpp b/devel/libsavitar/files/patch-src_SceneNode.cpp
new file mode 100644
index 000000000000..e055e80807d8
--- /dev/null
+++ b/devel/libsavitar/files/patch-src_SceneNode.cpp
@@ -0,0 +1,11 @@
+--- src/SceneNode.cpp.orig 2020-05-11 21:53:40 UTC
++++ src/SceneNode.cpp
+@@ -18,7 +18,7 @@
+
+ #include "SceneNode.h"
+ #include "Namespace.h"
+-#include "../pugixml/src/pugixml.hpp"
++#include <pugixml.hpp>
+ #include <iostream>
+ using namespace Savitar;
+
diff --git a/devel/libsavitar/pkg-plist b/devel/libsavitar/pkg-plist
index 7d5720bdac1c..7ab811ee3d36 100644
--- a/devel/libsavitar/pkg-plist
+++ b/devel/libsavitar/pkg-plist
@@ -11,7 +11,6 @@ lib/cmake/Savitar/Savitar-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/Savitar/Savitar-targets.cmake
lib/cmake/Savitar/SavitarConfig.cmake
lib/cmake/Savitar/SavitarConfigVersion.cmake
-lib/cmake/pugixml/pugixml-config-%%CMAKE_BUILD_TYPE%%.cmake
lib/libSavitar.so
lib/libSavitar.so.0
lib/libSavitar.so.0.1.1