summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-30 17:26:40 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-30 17:26:40 +0000
commit918d9f33149028e1cbe7218554dfc00cc3c6d967 (patch)
tree26821d09c6891ec8ac9c70016275988744a70d58
parentca857605752e690fee612b50c1afc7da12ae35aa (diff)
downloadfreebsd-ports-918d9f33149028e1cbe7218554dfc00cc3c6d967.zip
Fix build on amd64 on 8 and 9.
-rw-r--r--security/rndpassw/Makefile2
-rw-r--r--security/rndpassw/files/patch-src_rndpassw.c22
2 files changed, 21 insertions, 3 deletions
diff --git a/security/rndpassw/Makefile b/security/rndpassw/Makefile
index cc7a01a29cf5..5b6a276e2bd5 100644
--- a/security/rndpassw/Makefile
+++ b/security/rndpassw/Makefile
@@ -10,7 +10,7 @@ COMMENT= CLI password generator
LICENSE= BSD3CLAUSE
-USES= tar:bzip2
+USES= tar:bzip2
PLIST_FILES= bin/rndpassw \
man/man1/rndpassw.1.gz
diff --git a/security/rndpassw/files/patch-src_rndpassw.c b/security/rndpassw/files/patch-src_rndpassw.c
index 2425b3c5abbc..5117ff8bb7f5 100644
--- a/security/rndpassw/files/patch-src_rndpassw.c
+++ b/security/rndpassw/files/patch-src_rndpassw.c
@@ -1,5 +1,5 @@
---- src/rndpassw.c.orig 2014-03-04 18:01:47.477094722 +0100
-+++ src/rndpassw.c 2014-03-04 18:02:16.047437566 +0100
+--- src/rndpassw.c.orig 2014-03-02 18:22:27.000000000 -0500
++++ src/rndpassw.c 2014-08-30 13:24:58.742060993 -0400
@@ -24,7 +24,7 @@
int main(int argc, char **argv)
@@ -9,3 +9,21 @@
int passlen = -1, passcnt = -1;
int opt, mixlen = 0, entlen, fd;
unsigned i, y, baselen = 0;
+@@ -133,7 +133,7 @@
+
+ entoff = entbuf = malloc(entlen);
+ if(entbuf == NULL) {
+- fprintf(stderr, "Could not allocate %zd bytes\n", entlen);
++ fprintf(stderr, "Could not allocate %zd bytes\n", (size_t)entlen);
+ return (1);
+ }
+
+@@ -148,7 +148,7 @@
+ /* create and fill dictionary */
+ mixbuf = malloc(mixlen);
+ if(mixbuf == NULL) {
+- fprintf(stderr, "Could not allocate %zd bytes of memory\n", mixlen);
++ fprintf(stderr, "Could not allocate %zd bytes of memory\n", (size_t)mixlen);
+ return (1);
+ }
+