summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2015-11-24 09:17:47 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2015-11-24 09:17:47 +0000
commit8fc164d6dfea0453fa79e642bbed57a6861cfccf (patch)
treee58349788382795be276d78630af35fcf94b9881
parent4c63218f5ccb8f6a3d2dc97f2ad8c7aaa9425198 (diff)
downloadfreebsd-ports-8fc164d6dfea0453fa79e642bbed57a6861cfccf.zip
- Update to 2015.11.24.
PR: ports/204776 Submitted by: Christoph Moench-Tegeder <cmt@burggraben.net>
-rw-r--r--www/youtube_dl/Makefile2
-rw-r--r--www/youtube_dl/distinfo4
-rw-r--r--www/youtube_dl/files/patch-youtube_dl____init__.py10
3 files changed, 8 insertions, 8 deletions
diff --git a/www/youtube_dl/Makefile b/www/youtube_dl/Makefile
index d72ef08a9e26..27d30f03a98c 100644
--- a/www/youtube_dl/Makefile
+++ b/www/youtube_dl/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= youtube_dl
-PORTVERSION= 2015.11.13
+PORTVERSION= 2015.11.24
CATEGORIES= www
MASTER_SITES= https://yt-dl.org/downloads/${PORTVERSION}/
DISTNAME= youtube-dl-${PORTVERSION}
diff --git a/www/youtube_dl/distinfo b/www/youtube_dl/distinfo
index e8484c007c98..51bd2f23801c 100644
--- a/www/youtube_dl/distinfo
+++ b/www/youtube_dl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (youtube-dl-2015.11.13.tar.gz) = dd75b284de30aeff6b85d8550ad19cb8ca481961eb762304b6576ffeb8022408
-SIZE (youtube-dl-2015.11.13.tar.gz) = 1788412
+SHA256 (youtube-dl-2015.11.24.tar.gz) = cceeb606e723c0291de85eecb9a551ca887f3be4db786ad621011a9201a482b1
+SIZE (youtube-dl-2015.11.24.tar.gz) = 1803588
diff --git a/www/youtube_dl/files/patch-youtube_dl____init__.py b/www/youtube_dl/files/patch-youtube_dl____init__.py
index d895712e5f5c..625feec8e476 100644
--- a/www/youtube_dl/files/patch-youtube_dl____init__.py
+++ b/www/youtube_dl/files/patch-youtube_dl____init__.py
@@ -1,6 +1,6 @@
---- youtube_dl/__init__.py.orig 2015-05-15 08:01:24 UTC
-+++ youtube_dl/__init__.py
-@@ -36,7 +36,6 @@ from .utils import (
+--- youtube_dl/__init__.py.orig 2015-11-24 09:44:40.030482000 +0100
++++ youtube_dl/__init__.py 2015-11-24 09:45:54.856110000 +0100
+@@ -36,7 +36,6 @@
std_headers,
write_string,
)
@@ -8,13 +8,13 @@
from .downloader import (
FileDownloader,
)
-@@ -370,17 +369,13 @@ def _real_main(argv=None):
+@@ -375,17 +374,13 @@
}
with YoutubeDL(ydl_opts) as ydl:
- # Update version
- if opts.update_self:
-- update_self(ydl.to_screen, opts.verbose)
+- update_self(ydl.to_screen, opts.verbose, ydl._opener)
-
# Remove cache dir
if opts.rm_cachedir: