summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-02-26 16:29:50 -0800
committerYuri Victorovich <yuri@FreeBSD.org>2024-02-26 16:31:17 -0800
commit8f19a6a71d6b96023b7d9fb19985fbf2842f5c94 (patch)
treef5080148d628c3c1ffa4b775f6bdd39ae41960d2
parent364455ea62e65acfadd2f53d7041311914341552 (diff)
downloadfreebsd-ports-8f19a6a71d6b96023b7d9fb19985fbf2842f5c94.zip
devel/google-perftools: update 2.10 → 2.15
-rw-r--r--devel/google-perftools/Makefile3
-rw-r--r--devel/google-perftools/distinfo6
-rw-r--r--devel/google-perftools/files/patch-Makefile.am17
-rw-r--r--devel/google-perftools/files/patch-src_base_dynamic__annotations.c39
-rw-r--r--devel/google-perftools/files/patch-src_stacktrace.cc13
-rw-r--r--devel/google-perftools/pkg-plist12
6 files changed, 18 insertions, 72 deletions
diff --git a/devel/google-perftools/Makefile b/devel/google-perftools/Makefile
index ac2de91162e0..4c50df6509a3 100644
--- a/devel/google-perftools/Makefile
+++ b/devel/google-perftools/Makefile
@@ -1,7 +1,6 @@
PORTNAME= google-perftools
DISTVERSIONPREFIX= gperftools-
-DISTVERSION= 2.10
-PORTREVISION= 4
+DISTVERSION= 2.15
CATEGORIES= devel
MASTER_SITES= https://github.com/gperftools/gperftools/releases/download/gperftools-${PORTVERSION}/
DISTNAME= gperftools-${PORTVERSION}
diff --git a/devel/google-perftools/distinfo b/devel/google-perftools/distinfo
index 24da0716d4fd..4ee20330c5e4 100644
--- a/devel/google-perftools/distinfo
+++ b/devel/google-perftools/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1655613288
-SHA256 (gperftools-2.10.tar.gz) = 83e3bfdd28b8bcf53222c3798d4d395d52dadbbae59e8730c4a6d31a9c3732d8
-SIZE (gperftools-2.10.tar.gz) = 1616679
+TIMESTAMP = 1709196244
+SHA256 (gperftools-2.15.tar.gz) = c69fef855628c81ef56f12e3c58f2b7ce1f326c0a1fe783e5cae0b88cbbe9a80
+SIZE (gperftools-2.15.tar.gz) = 1511014
diff --git a/devel/google-perftools/files/patch-Makefile.am b/devel/google-perftools/files/patch-Makefile.am
index 011506ac6890..2c80307acbc5 100644
--- a/devel/google-perftools/files/patch-Makefile.am
+++ b/devel/google-perftools/files/patch-Makefile.am
@@ -1,13 +1,12 @@
---- Makefile.am.orig 2021-02-28 23:41:19 UTC
+--- Makefile.am.orig 2024-01-05 00:50:17 UTC
+++ Makefile.am
-@@ -122,8 +122,8 @@ googleinclude_HEADERS = \
- # Add your documentation files (in doc/) in addition to these
- # top-level boilerplate files. Also add a TODO file if you have one.
- # We'll add to this later, on a library-by-library basis
--dist_doc_DATA = AUTHORS COPYING ChangeLog INSTALL NEWS README README_windows.txt \
-- TODO ChangeLog.old
-+dist_doc_DATA = AUTHORS NEWS README README_windows.txt
-+
+@@ -108,8 +108,7 @@ googleinclude_HEADERS = \
+ # your documentation files (in doc/) in addition to these top-level
+ # boilerplate files. We'll add to this later, on a library-by-library
+ # basis
+-dist_doc_DATA = AUTHORS COPYING INSTALL NEWS README README_windows.txt \
+- ChangeLog.old
++dist_doc_DATA = AUTHORS NEWS README README_windows.txt
# The libraries (.so's) you want to install
# We'll add to this later, on a library-by-library basis
diff --git a/devel/google-perftools/files/patch-src_base_dynamic__annotations.c b/devel/google-perftools/files/patch-src_base_dynamic__annotations.c
deleted file mode 100644
index 3850e05461a5..000000000000
--- a/devel/google-perftools/files/patch-src_base_dynamic__annotations.c
+++ /dev/null
@@ -1,39 +0,0 @@
-- add another way to determine if the process is run under valgrind - based on LD_PRELOAD patterns presence
-- Submitted: https://github.com/gperftools/gperftools/pull/1316
-
---- src/base/dynamic_annotations.c.orig 2021-02-15 06:44:21 UTC
-+++ src/base/dynamic_annotations.c
-@@ -43,6 +43,21 @@
- #include "base/dynamic_annotations.h"
- #include "getenv_safe.h" // for TCMallocGetenvSafe
-
-+static int running_on_valgrind_preload = -1;
-+void __attribute__ ((constructor)) premain() {
-+ char *LD_PRELOAD = getenv("LD_PRELOAD");
-+ if (LD_PRELOAD == NULL)
-+ LD_PRELOAD = getenv("LD_32_PRELOAD");
-+ running_on_valgrind_preload = LD_PRELOAD != NULL &&
-+ (
-+ strstr(LD_PRELOAD, "/valgrind/") != NULL
-+ ||
-+ strstr(LD_PRELOAD, "/vgpreload") != NULL
-+ )
-+ ?
-+ 1 : 0;
-+}
-+
- static int GetRunningOnValgrind(void) {
- #ifdef RUNNING_ON_VALGRIND
- if (RUNNING_ON_VALGRIND) return 1;
-@@ -51,6 +66,11 @@ static int GetRunningOnValgrind(void) {
- if (running_on_valgrind_str) {
- return strcmp(running_on_valgrind_str, "0") != 0;
- }
-+
-+ // use the LD_PRELOAD trick from https://stackoverflow.com/questions/365458/how-can-i-detect-if-a-program-is-running-from-within-valgrind
-+ if (running_on_valgrind_preload == 1)
-+ return 1;
-+
- return 0;
- }
-
diff --git a/devel/google-perftools/files/patch-src_stacktrace.cc b/devel/google-perftools/files/patch-src_stacktrace.cc
deleted file mode 100644
index b2c2d59ec27b..000000000000
--- a/devel/google-perftools/files/patch-src_stacktrace.cc
+++ /dev/null
@@ -1,13 +0,0 @@
-- workaround for https://github.com/gperftools/gperftools/issues/1271
-
---- src/stacktrace.cc.orig 2022-02-13 17:53:31 UTC
-+++ src/stacktrace.cc
-@@ -219,7 +219,7 @@ static GetStackImplementation *all_impls[] = {
-
- // ppc and i386 implementations prefer arch-specific asm implementations.
- // arm's asm implementation is broken
--#if defined(__i386__) || defined(__ppc__) || defined(__PPC__) || defined(__loongarch64)
-+#if defined(__i386__) || defined(__x86_64__) || defined(__ppc__) || defined(__PPC__) || defined(__loongarch64)
- #if !defined(NO_FRAME_POINTER)
- #define TCMALLOC_DONT_PREFER_LIBUNWIND
- #endif
diff --git a/devel/google-perftools/pkg-plist b/devel/google-perftools/pkg-plist
index 4eedc715497d..0f3036f7154e 100644
--- a/devel/google-perftools/pkg-plist
+++ b/devel/google-perftools/pkg-plist
@@ -22,27 +22,27 @@ include/gperftools/tcmalloc.h
%%PROFILER%%lib/libprofiler.a
%%PROFILER%%lib/libprofiler.so
%%PROFILER%%lib/libprofiler.so.0
-%%PROFILER%%lib/libprofiler.so.0.5.5
+%%PROFILER%%lib/libprofiler.so.0.5.11
lib/libtcmalloc.a
lib/libtcmalloc.so
lib/libtcmalloc.so.4
-lib/libtcmalloc.so.4.5.10
+lib/libtcmalloc.so.4.5.16
%%PROFILER%%lib/libtcmalloc_and_profiler.a
%%PROFILER%%lib/libtcmalloc_and_profiler.so
%%PROFILER%%lib/libtcmalloc_and_profiler.so.4
-%%PROFILER%%lib/libtcmalloc_and_profiler.so.4.6.5
+%%PROFILER%%lib/libtcmalloc_and_profiler.so.4.6.11
lib/libtcmalloc_debug.a
lib/libtcmalloc_debug.so
lib/libtcmalloc_debug.so.4
-lib/libtcmalloc_debug.so.4.5.10
+lib/libtcmalloc_debug.so.4.5.16
lib/libtcmalloc_minimal.a
lib/libtcmalloc_minimal.so
lib/libtcmalloc_minimal.so.4
-lib/libtcmalloc_minimal.so.4.5.10
+lib/libtcmalloc_minimal.so.4.5.16
lib/libtcmalloc_minimal_debug.a
lib/libtcmalloc_minimal_debug.so
lib/libtcmalloc_minimal_debug.so.4
-lib/libtcmalloc_minimal_debug.so.4.5.10
+lib/libtcmalloc_minimal_debug.so.4.5.16
libdata/pkgconfig/libprofiler.pc
libdata/pkgconfig/libtcmalloc.pc
libdata/pkgconfig/libtcmalloc_debug.pc